none
ConfigMgr Error - No MP Certificates RRS feed

  • Question

  • I'm currently experiencing an issue with my ConfigMgr 2007 R2 setup.  I had OSD working (for the most part) but now I'm running into an issue where I will boot into PXE, it get all the way thru the Initializing Hardware phase, and then just reboots.  It happens to quickly for me to see the error message on screen.

    After looking thru the smsts.log file, I see an error saying "No MP Certificates.".  It then exists with error code 0x80004005 and reboots the system.  I've looked all over but to no avail.  If anyone knows why this may be happening I'd sure appreciate the help.

    Thanks,
    D

    • Moved by Carol BaileyMicrosoft employee Tuesday, May 26, 2009 6:02 PM OSD-specific, applies to mixed mode (From:Configuration Manager Internet Clients and Native Mode)
    Wednesday, May 6, 2009 5:26 PM

Answers

  • Two things:

    1. If you are running in mixed mode, you could try re-installing the MP. This would force the site to re-create the MP certificates.

    2. Your PXE server may be having problems accessing the database to get the MP certificate. Check the SMSPXE.log file on the PXE service point. Also, you may have to re-start the PXE service point (by re-starting the WDS service). This would force the SCCM PXE provider to re-read the database for the MP information.
    Friday, May 29, 2009 7:06 PM

All replies

  • To clarify - you've posted this in the native mode forum, but is your site actually in native mode?  Certificates are used with both native mode and mixed mode (in mixed mode they are automatically generated by Configuration Manager).  Are existing clients in this site communicating successfully with the management point (receiving policy, sending inventory etc)?

    Wednesday, May 6, 2009 8:20 PM
  • This is over a week old now - any update?
    Saturday, May 16, 2009 1:19 AM
  • Any update on this topic. I'm having the same problem. I'm running a Mixed Environment.

    Thanks,
    T
    Wednesday, May 20, 2009 2:20 PM
  • Moving to Operating System Deployment forum for OSD help (and doesn't appear to be specific to native mode).
    Tuesday, May 26, 2009 6:00 PM
  • Two things:

    1. If you are running in mixed mode, you could try re-installing the MP. This would force the site to re-create the MP certificates.

    2. Your PXE server may be having problems accessing the database to get the MP certificate. Check the SMSPXE.log file on the PXE service point. Also, you may have to re-start the PXE service point (by re-starting the WDS service). This would force the SCCM PXE provider to re-read the database for the MP information.
    Friday, May 29, 2009 7:06 PM
  • Hi D,

    Just had the EXACT same symptoms. I dunno if my solution will help you, but I blogged it here
    http://blogs.msdn.com/boduff/archive/2009/06/01/sccm-reboot-during-osd-install-no-mp-certificates.aspx

    Hope it helps...

    Bob
    Monday, June 1, 2009 10:55 AM
  • How do you reinstall the MP? Having this issues as well.

    Update:

    This is from the SMSTS.LOG file

    Setting _SMSTSx86UnknownMachineGUID TS environment variable TSPxe 10/9/2009 10:12:12 AM 1140 (0x0474)
    sMPCert.size() > 0, HRESULT=80004005 (e:\nts_sms_fre\sms\client\tasksequence\tsmbootstrap\tsmediawizardcontrol.cpp,564) TSPxe 10/9/2009 10:12:12 AM 1140 (0x0474)
    No MP Certificates. TSPxe 10/9/2009 10:12:12 AM 1140 (0x0474)
    Exiting TSMediaWizardControl::GetPolicy. TSPxe 10/9/2009 10:12:12 AM 1140 (0x0474)
    GetPolicy(), HRESULT=80004005 (e:\nts_sms_fre\sms\client\tasksequence\tsmbootstrap\tsmediawizardcontrol.cpp,2072) TSPxe 10/9/2009 10:12:12 AM 1140 (0x0474)
    RunWizardForPXE(), HRESULT=80004005 (e:\nts_sms_fre\sms\client\tasksequence\tsmbootstrap\tsmediawizardcontrol.cpp,2402) TSPxe 10/9/2009 10:12:12 AM 1140 (0x0474)
    oTSMediaWizardControl.Run( sMediaRoot, true, true ), HRESULT=80004005 (e:\nts_sms_fre\sms\client\tasksequence\tsmbootstrap\tsmbootstrap.cpp,937) TSPxe 10/9/2009 10:12:12 AM 1140 (0x0474)
    Execute( eExecutionEnv, sConfigPath, sTSXMLFile, uBootCount, &uExitCode ), HRESULT=80004005 (e:\nts_sms_fre\sms\client\tasksequence\tsmbootstrap\tsmbootstrap.cpp,1106) TSPxe 10/9/2009 10:12:12 AM 1140 (0x0474)
    Exiting with return code 0x80004005 TSPxe 10/9/2009 10:12:12 AM 1140 (0x0474)
    Execution complete. TSBootShell 10/9/2009 10:12:12 AM 756 (0x02F4)

    Friday, October 9, 2009 1:13 PM
  • Hi all,

    If Config Manager running on Server 2008 - here is how I fixed it on my machine.

    I had these very certificate errors, i.e. in my smsts.log "No MP Certificates", it turned out it was an MP problem.

    MP relies on WEBDAV not only being installed, but being configured correctly.

    So if you check configuration manager\logs\MPSetup.log, you may see the following error:

    11-05-2009 11:41:08> Installing the SMSMP
    <11-05-2009 11:41:08> Passed OS version check.
    <11-05-2009 11:41:08> IIS Service is installed.
    <11-05-2009 11:41:08> checking WebDAV configuraitons
    <11-05-2009 11:41:09> Failed to get WebDAV settings on the machine (0x80070003)

    To correct this error message, uninstall the MP, then follow this article:

    http://technet.microsoft.com/en-us/library/cc431377.aspx

    Then re-install the MP

    I stopped getting the certificate errors after this.
    • Proposed as answer by Jools86 Monday, November 23, 2009 10:50 AM
    Monday, November 23, 2009 10:50 AM
  • I am facing the same problem although my site is in Native Mode. I do have the PXE boot working and the policy retrieved on the child primary site but when I try to do a pxe on the secondary I am done with that part but when I enter in the password it says that the policy couldnot be retrieved. When I open the SMSTS.log I see the same error I have updated the boot images on the DP, I also did restart WDS service no luck.

    I donot find any MP Issues in the MPSetup.log etc

    Need Help

    Thanks

    Amim Muhammad Khan


    AMIM MUHAMMAD KHAN | CTTCNET USER GROUP LEAD | EVENT SPEAKER, MCT, MCTS, MCITP-ENTERPRISE, MCSA http://amimkhan.wordpress.com

    Thursday, July 19, 2012 8:16 AM