locked
Unable to open xls file in edit mode. RRS feed

  • Question

  • XLS files that I have created in office 2007 and saved down to 2003 format cannot be opened in edit mode by some users who have office 2003.  Trying to open from Sharepoint site with server version 2007.  Versioning is on.  Check out is required.  They have the appropriate permissions as contributer.  Any ideas?  I had them run this thinking it would help, but no dice.  "Go To Start > Run > Type webfldrs.msi

    Click on Select Reinstall Mode button (not Reinstall button)

    Select all options

    Click on OK

    Now click on the Reinstall button

    Click on OK

    Click on Yes to restart the machine or manually restart the machine.

     

    Also make sure that IE is set as your default web browser."

     

     

     



    • Moved by Mike Walsh FIN Thursday, March 31, 2011 2:53 PM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Thursday, March 31, 2011 2:48 PM

Answers

  • Hi blumm1,

     

    Many reason can make you unable to open Excel document. Did you get any error message or event log in this process? If you have, could you please post it here so that we can know more about your problem and help you to solve it.

     

    Maybe you can go through this thread to see if it is similar with your case: http://social.technet.microsoft.com/Forums/en-GB/sharepointgeneral/thread/fe1dbceb-a655-48c0-b84d-45875b3b56ee.

     

    Thanks & Regards,

    Peng Lei

    • Marked as answer by David HM Monday, April 11, 2011 9:00 AM
    Friday, April 8, 2011 7:40 AM
  • Hi,

    In addition to peng lei's answer try the below steps: they worked for me.

    You didn't mention any error: the error i got was below. Hope this works for you as well.

    The document could not be opened for editing. A Windows SharePoint Services compatible application could not be found to edit the document

    according to me, Some times the office 2007 files may leave their components/features in 2003 format files if you same as office 97 to 2003 type.

    Try to install office 2007 components thats comes as a free download from sharepoint designer.

    Download sp designer 2007 > then select custom install option , uncheck sp designer and select office 2007 tools and features and install. reboot is not required.

    Please check the issue and update if you get any other error.

     


    Best Regards, Ashok Yadala
    • Marked as answer by David HM Monday, April 11, 2011 9:00 AM
    Friday, April 8, 2011 1:55 PM

All replies

  • Hi blumm1,

     

    Many reason can make you unable to open Excel document. Did you get any error message or event log in this process? If you have, could you please post it here so that we can know more about your problem and help you to solve it.

     

    Maybe you can go through this thread to see if it is similar with your case: http://social.technet.microsoft.com/Forums/en-GB/sharepointgeneral/thread/fe1dbceb-a655-48c0-b84d-45875b3b56ee.

     

    Thanks & Regards,

    Peng Lei

    • Marked as answer by David HM Monday, April 11, 2011 9:00 AM
    Friday, April 8, 2011 7:40 AM
  • Hi,

    In addition to peng lei's answer try the below steps: they worked for me.

    You didn't mention any error: the error i got was below. Hope this works for you as well.

    The document could not be opened for editing. A Windows SharePoint Services compatible application could not be found to edit the document

    according to me, Some times the office 2007 files may leave their components/features in 2003 format files if you same as office 97 to 2003 type.

    Try to install office 2007 components thats comes as a free download from sharepoint designer.

    Download sp designer 2007 > then select custom install option , uncheck sp designer and select office 2007 tools and features and install. reboot is not required.

    Please check the issue and update if you get any other error.

     


    Best Regards, Ashok Yadala
    • Marked as answer by David HM Monday, April 11, 2011 9:00 AM
    Friday, April 8, 2011 1:55 PM