none
MDT Build Machine now unable to access the usual Deployment Share by Server Name RRS feed

  • Question

  • My MDT Build Environment is very simple: one Hyper-V host with a Deployment Share, one tiny DHCP server started as application as needed, one VM build machine; no DNS server; no Internet connection for the build machine.

    Apart initial problems that required the use od this tini DHCP server, I used this setup to successfully build many images.

    Now, after 2 weeks I wasn't using MDT, I started to build another image and I discovered that build machine is unable to connect to deployment share.

    - "ping computername" succeed but use by default IPv6

    - if I disable IPv6 on host, "ping computername" succeed with IPv4

    - net use \\ipaddress\deploymentshare succeed

    - net use \\computername\deploymentshare fails

    - after wpeutil DisableFirewall, net use \\computername\deploymentshare succeed

    - Hyper V internal network connection default to public, but "Set-NetConnectionProfile -NetworkCategory Private" doens't change the results

    I ddidn't changed anything on MDT boot image, but I maybe changed something on Hyper-V host and configurations.

    I absolutely never had to do "wpeutil DisableFirewall" to access my share.

    Any idea?

    Monday, January 1, 2018 10:30 AM

All replies

  • With Hyper-V, I use a custom vSwitch which gives the VM access to the LAN I use for development (behind a NAT). On that LAN is a DHCP service (the router), which is configured to provide the IP address of DNS servers which can resolve the hostname of the MDT server. Ideally, the MDT server should be behind the NAT to keep development traffic off of the production network. 

    Make sure NetBIOS over TCP/IP is enabled on your VM if you want to use COMPUTERNAME as opposed to hostname. Using TCP/IP, you need a DNS server or a preconfigured HOSTS file.


    Jason

    Monday, January 1, 2018 1:55 PM
  • In my test/lab environment I don't have any router or internet connection, any dhcp/dns/wins service. My Hyper-V switch is "internal" so I run only a tiny dhcp as application. Forgot to write that NetBios name resolution appear as enabled on both host and MDT Boot Guest, but appear not to work any more unless I manually disable firewall under MDT Boot guest with wpeutil.

    Everything worked as expected 10 days ago or so and I don't remember to have changed any host settings that could affect this process.

    Tuesday, January 2, 2018 7:21 AM