locked
SQLEXPRESS 2008 on Win 7 x64 - error when trying to connect to server RRS feed

  • Question

  • I have SQLEXPRESS 2008 R2 running well on Win XP Pro 32. I installed Win 7 Pro x64 in dual boot config. Installed SQLEXPRESS 2008 on Win 7 using file SQLEXPRWT_x64_ENU. Trying to use MSSMS and to connect to SQLEXPRESS using Windows Authentication, I get this error after waiting some time: "Cannot connect to SQLEXPRESS. Additional Information: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 53)".

    What I tried but did not work: Use Server name (local) instead of SQLEXPRESS; enabled all 4 available protocols (Shared Memory, Named Pipes, TCP/IP, VIA) and stopped and started SqlServer (SQLEXPRESS).

    Please help me resolve this error - thanks!


    r4
    Thursday, March 31, 2011 3:21 PM

Answers

  • What I tried but did not work: Use Server name (local) instead of SQLEXPRESS;

    You need to use (type in) Server Name as

    localhost\SQLExpress   

    OR

    (local)\SQLExpress

    OR

    <ComputerName>\SQLExpress

    etc.




    • Proposed as answer by Pradeep Adiga Thursday, March 31, 2011 7:50 PM
    • Marked as answer by robertrackl Friday, April 1, 2011 5:19 AM
    Thursday, March 31, 2011 3:57 PM

All replies

  • What I tried but did not work: Use Server name (local) instead of SQLEXPRESS;

    You need to use (type in) Server Name as

    localhost\SQLExpress   

    OR

    (local)\SQLExpress

    OR

    <ComputerName>\SQLExpress

    etc.




    • Proposed as answer by Pradeep Adiga Thursday, March 31, 2011 7:50 PM
    • Marked as answer by robertrackl Friday, April 1, 2011 5:19 AM
    Thursday, March 31, 2011 3:57 PM
  • Thanks! - That was the problem exactly.

     


    r4
    Thursday, March 31, 2011 4:49 PM