locked
Direct X 7.0a Compatibility RRS feed

  • Question

  • I bought the Diablo2 cd, which I was playing on a earlier model of windows, I think (windows xp )now I have a new computer that's running windows 7. I get this message when I try to run setup with this cd. The 'Microsoft DirectX 7.0a package is not compatible with the version of windows you are running. So where do I go from here ?
    Friday, August 21, 2015 7:20 PM

Answers

  • Hi,

    Based on my research, you probably need to install the Diablo2 1.13 first, you can download it from official website, and then doing the following:

    1) Navigate to the folder you installed d2 (mine was C: \program files(x86)\Diablo II)
    2) Right click Diablo II.exe
    3) Select "Properties
    4) On the Compatibility tab, select Windows XP Service Pack 3
    5) Also check the box that says "run as administrator" (or something like that)
    6) Repeat the process for Game.exe which is located in the same folder

    Reference:

    http://us.battle.net/d3/en/forum/topic/4916892022?page=2

    http://www.diabloii.net/forums/threads/diablo-ii-wont-run-on-windows-7-help.786727/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,

    George Zhao
    TechNet Community Support


    It's recommended to download and install Configuration Analyzer Tool (OffCAT), which is developed by Microsoft Support teams. Once the tool is installed, you can run it at any time to scan for hundreds of known issues in Office programs.

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    Monday, August 24, 2015 8:57 AM