locked
Can't get autodiscovery working RRS feed

  • Question

  • I have a exchange 2010 environment and I added exchange 2016 to co-exist before retire exchange 2010. 

    Exchange 2010 uses Email.mycompany.com as external/internal URL.

    Exchange 2016 uses mail.mycompany.com as external/internal URL.

    Now, if a PC is joined domain, it can auto-configure 2016 mailbox without problem. But if the PC isn't joined the domain, or from outside of network, It doesn't work. I ran Microsoft connectivity diagnostics, it failed with below message:

    Attempting to test potential Autodiscover URL https://mycompany.com:443/Autodiscover/Autodiscover.xml Testing of this potential Autodiscover URL failed.

    The URL it should look for is https://mail.mycompany.com:443/Autodiscover/Autodiscover.xml. I am not sure what is wrong. How can I fix it? Thanks.


    Monday, September 18, 2017 11:45 PM

Answers

  • Hi,

    Do you change the DNS record to new Exchange 2016 server?

    Because of the proxy behavior only works from Exchange 2016 to Exchange 2010, thus we need change all public DNS records and point to Exchange 2016 server.
    Note: we need to add new namespace (i.e. mail.mycompany.com) in Exchange certificate as well.

    By the way, if this issue remain exists, please post the whole test steps in ExRCA?
    It's more helpful for further troubleshooting.

    Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by AlanG2015 Wednesday, September 20, 2017 10:36 PM
    Wednesday, September 20, 2017 8:23 AM

All replies

  • I have a exchange 2010 environment and I added exchange 2016 to co-exist before retire exchange 2010. 

    Exchange 2010 uses Email.mycompany.com as external/internal URL.

    Exchange 2016 uses mail.mycompany.com as external/internal URL.

    Now, if a PC is joined domain, it can auto-configure 2016 email account without problem. But if the PC isn't joined the domain, or from outside of network, It doesn't work. I ran Microsoft connectivity diagnostics, it failed with below message:


    Attempting to test potential Autodiscover URL https://mycompany.com:443/Autodiscover/Autodiscover.xml Testing of this potential Autodiscover URL failed.

    The URL it should look for is https://mail.mycompany.com:443/Autodiscover/Autodiscover.xml. I am not sure what is wrong. How can I fix it? Thanks.

    • Moved by Edward van BiljonMVP Wednesday, September 20, 2017 6:16 AM Moved to correct Forum
    • Merged by Allen_WangJF Wednesday, September 20, 2017 2:14 PM Duplicate
    Tuesday, September 19, 2017 6:25 PM
  • you also need to register autodiscover.mycompany.com against your external ip
    Tuesday, September 19, 2017 6:38 PM
  • A non-domain joined PC won't use the URLs you've defined because it doesn't have access to them. It will first check at mycompany.com then autodiscover.mycompany.com. In most cases, organizations configure autodiscover.mycompany.com for external access.

    You also have the option to use an SRV record to point autodiscover at a specific DNS name. That could be used to point to mail.mycompany.com. However, most mobile clients won't use that.

    This link has a detailed description of the process: http://markgossa.blogspot.ca/2015/11/exchange-2013-2016-autodiscover-srv-record.html


    Byron Wright (http://byronwright.blogspot.ca)

    Tuesday, September 19, 2017 7:17 PM
  • Hi,

    Do you change the DNS record to new Exchange 2016 server?

    Because of the proxy behavior only works from Exchange 2016 to Exchange 2010, thus we need change all public DNS records and point to Exchange 2016 server.
    Note: we need to add new namespace (i.e. mail.mycompany.com) in Exchange certificate as well.

    By the way, if this issue remain exists, please post the whole test steps in ExRCA?
    It's more helpful for further troubleshooting.

    Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by AlanG2015 Wednesday, September 20, 2017 10:36 PM
    Wednesday, September 20, 2017 8:23 AM