locked
ClearType failure in windows title bar RRS feed

  • General discussion

  • I have my monitor rotated by 180 degree, thus I have to use the BGR ClearType setting, however in the title bar of every program the other mode (RGB) gets still used.
    So everywhere the font looks ok, except in the title bar.

    edit: I just checked it again, ClearType never properly works, regardless of the display rotation, in the title bar!
    Thursday, October 1, 2009 4:20 PM

All replies

  • Do you have Aero on or off?

    I presently have it off in Win 7 and it appears to be oriented properly.



    What video card/drivers do you have?

    -Noel
    Friday, October 2, 2009 5:07 AM
  • Hi Fraenky001,

    Are you using a RC version?

    I found the follwoing informaiton on our internal database:

    The text in window titlebars when Aero Glass is on is antialiased using greyscale antialiasing. In Vista this was done using ClearType. This makes the title text look slightly different from the client area text.

    According to record, the issue should be fixed in RTM version.

    For your reference:

    Font rasterization

    Hope it helps.

    Thanks.

    Friday, October 2, 2009 8:33 AM
  • Thanks for the answer and the example picture, here is how it looks on my PC with the default screen orientation.
    It just looks wrong. I have the feeling that it also looked correct sometimes, but don't know when and what I've changed.
    I use Windows 7 RTM Professional x64 German and I have Aero and all the other fancy stuff turned on.

    Friday, October 2, 2009 9:05 PM
  • update:
    I played a bit around with the settings and my conclusion is: ClearType does not really work on the taskbar.

    I rebooted my system, and this is how it looked like, as a comparison I opened MS Office 2010 Technical Preview which, surprisingly, has this issue not, there it seems as if the greyscale method gets used, however, notepad looks ugly:


    Then I changed my desktop design to a high contrast setting and later switched back to my previous design again, after that it looked like this:


    Then I changed the ClearType settings to BGR, set to high contrast, set to normal back and changed the ClearType back to the correct RGB, after that it looks like this:




    And now I need a solution :)
    Friday, October 2, 2009 9:31 PM
  • You are ABSOLUTELY correct that ClearType is bassackwards in your default view (first image you posted). 

    Note the red fringes on the right of the characters, blue on the left - vs the opposite in the data down in the window itself.

    Worse yet, there are a number of places where grayscale antialiasing is also being used.  In fact, in your single IE view all three (proiper ClearType, grayscale AA, and backwards ClearType) are apparent.  At least the grayscale AA can't be backwards.  :-/

    That's an amazingly random result.  Makes one wonder...  Does Microsoft even test this stuff any more?

    -Noel
    Saturday, October 3, 2009 6:52 PM
  • Hi all,

    Thank you for your discussion. Currently, I do not found workaround on the issue. I will report this thread to our bug department to check this issue.

    Thanks again.
    Monday, October 5, 2009 8:03 AM
  • HKEY_CURRENT_USER\Control Panel\Desktop

    FontSmoothing
    Value "0" or "1": disables font smoothing
    Value "2": enables font smoothing

    FontSmoothingType
    Value "0" or "1": switch to gray font smoothing
    Value "2": switch to colored font smoothing

    FontSmoothingGamma
    Value between 0 to 2200 decimal: Intensity of color. 0=dark, 2200=light

    FontSmoothingOrientation
    Value "1": RGB format (red, green, blue), normal
    Value "2": BGR format (blue, green, red)

    Monday, October 5, 2009 12:18 PM