none
Offer Remote Assistance Problem. "A Program Could Not Start" Error.

    Question

  • Hello, I have not been able to find an answer for this online anywhere, but I'm sure it's got a simple answer. Hat's off to anyone who can answer this.

    I am having problems with the 'offer remote assistance' feature at work. I recieve a 'Program could not start. Please try again.' error when I attempt to make a connection from 'Offer Remote Assistance'

    Everything is set up correctly in Group Policy (default domain policy) as far as I know.

    I CAN get it to work by doing one of two things. On an individual computer:

    1. drop the local 'network service' account into the Administrators group, OR,

    2. change what the RDC (Remote Procedure Call) service logs on as, from the usual 'network service' account to 'local system' account.

    Making these changes on each computer is obviously not practical, but I'm not sure I want the 'network service' account set as admin anyway, and I'm not sure I want the 'local system' the account in charge of RPC service. Plus, when the RPC is changed to log on as 'local system' you can't change it back....at least I haven't looked beyone it's now greyed out option yet.

    Any domain wide settings that might solve this? I appreciate any input. Thank you.

    Friday, November 12, 2010 5:10 PM

Answers

  • Hi,

     

    Hi,

     

     

    According to your reply, this issue is related to permission setting. I’d like to perform the following steps to check if the Remote Assistance is correct, or not?

     

     

    1.        Open My computer propterties -> remote tab -> ensure the 'Allow Remote

    assistance invitations...' option is selected and in the advanced settings the

    'Allow this computer to be controlled remotely' is selected

     

    2.        Ensure the HelpAssistant user account is enabled (This account is disabled by

    default). Add the "administrators" group to HelpAssistant account.

     

    3.        Ensure the policy to Offer Remote assistance is enabled and you have added users

    to the 'Helpers: Show' list (Add the specific user account or group)

     

    "Computer Configuration\Administrative Templates\System\Remote Assistance"

     

    For example, to allow any authenticated user to offer remote assistance Enable "Offer

    Remote Assistance Properties", click "Show" helpers button, Add button then type in

    "Authenticated Users" without quotes. Other groups and account names can be

    added.

     

    Please make sure the policy takes effect by running the gpupdate /force command or

    by doing a reboot.

     

    4.       Restart the machines.

     

    Check the behavior.If the issue still persists,

     

    Meanwhile, this issue could also be caused by the system services as following:

     

    Security settings ==> System services ==> HELP and Support ( configure this policy to Automatic). By default this Service will not have Permission for the "Network Service" Account and you should add "Network Service" account to this.

     

     

    Hope this helps.

     

    Tuesday, November 16, 2010 5:49 AM
    Moderator

All replies

  • Hi,

     

    Beads on my knowledge, this issue could be caused by disabling Solicited Remote Assistance via GPO.

     

    For more information:

     

    If the Solicited Remote Assistance policy is disabled, you cannot offer assistance to a Novice computer

    http://support.microsoft.com//kb/826088

     

    To enable Solicited Remote Assistance policy in group policy, please follow the steps as below.

     

    1. Open your group policy editor on your DC, edit the right GPO you want to use.

     

    2. Click on the Computer Configuration icon to expand the available options. Expand the Administrative Templates icon.

    3. Expand the System icon.

    4. Expand the Remote Assistance icon.

    Two options will be available: Solicited Remote Assistance and Offer Remote Assistance. Double click Solicited Remote Assistance.

    5. Change the setting from "Not Configured" or "Disabled" to "Enabled". You may wish to modify the settings for "Permit remote control of this Computer, Maximum ticket time (hours), and Select the method for sending e-mail invitations. Make the settings appropriate for your environment. Click OK.

    6. Close Group Policy Object Editor.

    7. Ensure that group policy is refreshed. To do so, click Start, Run, and type "Gpupdate /force" (without the quotes). This should ensure that the policy setting is applied.

    8. Test the connection.

     

    If this issue persists, please help to confirm then following questions:

     

    1.       What’s the version of RDC client on the machine?

     

    2.       Does this issue occur on the all of clients or just only the specific client, such as Windows XP, Vista, 7 or Server 2008?

      

    3.       What type of OS you’re using on both sides?

     

    4.       Have you got any event on both sides, especially the System and Application categories? There may be some useful information about the cause why this issue happens.

    Monday, November 15, 2010 9:22 AM
    Moderator
  • I appreciate your reply! The Solicited Remote Assistance policy is actually set to not configured. If I remember correctly I even enabled it once to see if it made a difference. To asnwer your questions:

    1. As long as the machines have SP3 on them, I'm pretty sure they also have the latest RDC client.

    2. Using XP. I don't think you can connect up (later OS versions), but you can go down (from Windows 7 to XP)

    3. I've been sticking with XP Pro PC to XP Pro PC just to keep from adding to the problem.

    4. Not sure what you mean but as far as errors, it only occurs on the PC that's offering, but I've determined the problem is on the novice end PC with network service not having proper access or cannot authenticate through the domain. It's probably something that needs set up in GP that allows the network service to authenticate across the domain.

    I'm just blown away I can't find anything on this as far as any conclusion someone found.

    Monday, November 15, 2010 5:59 PM
  • Hi,

     

    Hi,

     

     

    According to your reply, this issue is related to permission setting. I’d like to perform the following steps to check if the Remote Assistance is correct, or not?

     

     

    1.        Open My computer propterties -> remote tab -> ensure the 'Allow Remote

    assistance invitations...' option is selected and in the advanced settings the

    'Allow this computer to be controlled remotely' is selected

     

    2.        Ensure the HelpAssistant user account is enabled (This account is disabled by

    default). Add the "administrators" group to HelpAssistant account.

     

    3.        Ensure the policy to Offer Remote assistance is enabled and you have added users

    to the 'Helpers: Show' list (Add the specific user account or group)

     

    "Computer Configuration\Administrative Templates\System\Remote Assistance"

     

    For example, to allow any authenticated user to offer remote assistance Enable "Offer

    Remote Assistance Properties", click "Show" helpers button, Add button then type in

    "Authenticated Users" without quotes. Other groups and account names can be

    added.

     

    Please make sure the policy takes effect by running the gpupdate /force command or

    by doing a reboot.

     

    4.       Restart the machines.

     

    Check the behavior.If the issue still persists,

     

    Meanwhile, this issue could also be caused by the system services as following:

     

    Security settings ==> System services ==> HELP and Support ( configure this policy to Automatic). By default this Service will not have Permission for the "Network Service" Account and you should add "Network Service" account to this.

     

     

    Hope this helps.

     

    Tuesday, November 16, 2010 5:49 AM
    Moderator