locked
SQL 2005 (ugh) DTSX packages with Loop Container fail RRS feed

  • Question

  • Hi , I have the following problem wich could not be solved:Within a packages  i have a ForEach Loop Container wich contains Enumerator type: Foreach ADO Enumerator.

    1. Does anybody know this type of error?

    2. can I work around this?

     It give's me the following error:

    Microsoft (R) SQL Server Execute Package Utility  Version 9.00.4035.00 for 64-bit  Copyright (C) Microsoft Corp 1984-2005. All rights reserved.    Started:  12:30:54  Error: 2011-05-19 12:30:56.32     Code: 0xC0014023     Source: Foreach Loop Container      Description: The GetEnumerator method of the ForEach Enumerator has failed with error 0x80070002 "The system cannot find the file specified.". This occurs when the ForEach Enumerator cannot enumerate.  End Error  DTExec: The package execution returned DTSER_FAILURE (1).  Started: 


    Komt deze foutmelding vaak, soms of altijd voor?
    Monday, May 23, 2011 12:20 PM

Answers

All replies

  • The error seems to be clear. Are you looping through some files in this foreach loop? Are you sure that the files exist? Try also writing the names of the files into some extra log file in that loop, so you can check later.
    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog
    Monday, May 23, 2011 12:29 PM
  • Following is the correct forum for your question:

    SQL Server Integration Services

     


    Kalman Toth, SQL Server & BI Training; SQL 2008 GRAND SLAM
    Sunday, May 29, 2011 10:33 AM
  • You state that you are using an ADO Enumerator however your error is "The system cannot find the file specified." which doesn't make sense as the ADO Enumerator doesn't use FIle Name.  What exactly are you trying to do?

     


    Jeff Wharton
    MSysDev (C.Sturt), MDbDsgnMgt (C.Sturt) MCT, MCPD, MCITP, MCDBA
    Blog: http://mrwharty.wordpress.com/
    Please mark solved if I've answered your question, vote for it as helpful to help other user's find a solution quicker
    Sunday, May 29, 2011 10:54 AM
  • First, your question is not clear. Under what circumstance, you have got your error message? in BIDS? Or in BIDS it is ok but it is failed with this error while you put it into an SQL agent job?

    Without the clear uderstanding, I don't know how to answer this question with certain. But I think this is simply an file access problem: either file not exists or the account running the SSIS package doesn't have permission to the folder where the files live.

    Sunday, May 29, 2011 11:23 AM
  • Thanks for the reply, i have a created a new topic in the correct threat. When I run the package in BIDS it works ok (execept one package , wich i think it is because of the large amount of data). the agent however fails . @Jeff. you are right i do not use File the enemerator must only use the first row of the variable wich i present. (it is getting the current month for reporting)  @Steven, I don't understand,,, wich file ? Do you mean it cannot a log file or a temp dir.. I realy have put some effort into this and tweaked almost everythink with different variables. (threat, parrell task, more rows, less rows, more memory)

     


    Komt deze foutmelding vaak, soms of altijd voor?
    Tuesday, June 7, 2011 7:25 AM