none
AGPM installation fails premature

    Question

  • 2015-09-23 16:09:34.222 [pid=0xe48,tid=0xb74] DllMain() called with DLL_THREAD_ATTACH
    2015-09-23 16:09:34.233 [pid=0xe48,tid=0x1254] Domain controller DNS name =
    2015-09-23 16:09:34.235 [pid=0xe48,tid=0x1254] Entering MyGetComputerNameEx().
    2015-09-23 16:09:34.237 [pid=0xe48,tid=0x1254] Leaving MyGetComputerNameEx().
    2015-09-23 16:09:34.239 [pid=0xe48,tid=0x1254] Entering MyGetComputerNameEx().
    2015-09-23 16:09:34.241 [pid=0xe48,tid=0x1254] Leaving MyGetComputerNameEx().
    2015-09-23 16:09:34.243 [pid=0xe48,tid=0x1254] SPN = AgpmServer/
    2015-09-23 16:09:34.255 [pid=0xe48,tid=0x1254] ADsGetObject() query = LDAP://
    2015-09-23 16:09:34.268 [pid=0xe48,tid=0x1254] Directory Search query = servicePrincipalName=AgpmServer/
    2015-09-23 16:09:34.272 [pid=0xe48,tid=0x1254] AccountListCount = 0
    2015-09-23 16:09:34.274 [pid=0xe48,tid=0x1108] DllMain() called with DLL_THREAD_ATTACH
    2015-09-23 16:09:34.275 [pid=0xe48,tid=0x1254] MSI property 'ServiceAccount' = _agpm_test@
    2015-09-23 16:09:34.276 [pid=0xe48,tid=0x1254] DsCrackNames() failed to convert name "_agpm_test@" to a FQDN.
    2015-09-23 16:09:34.278 [pid=0xe48,tid=0x1254]     DS_NAME_ERROR = 0x00000002, The name cannot be found or the caller does not have permission to access the name.
    2015-09-23 16:09:34.281 [pid=0xe48,tid=0x1254] Leaving MsiWriteAccountSpn(). [ hr = 0x80070057 "The parameter is incorrect." ]
    2015-09-23 16:09:34.283 [pid=0xe48,tid=0x1254] DllMain() called with DLL_PROCESS_DETACH

    Wednesday, September 23, 2015 11:36 PM

All replies

  • Hi SS87,

    Thanks for your post.

    According to the error, "The name cannot be found or the caller does not have permission to access the name", it might be caused by incorrect user account settings or permission settings.

    Please try the following suggestions:

    1. Log on the system with the service account that would be used for AGPM. Could you install AGPM now?
    2. If not, add the service account to Administrator group and try again.

    You may refer to the thread discussed before.

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/d446fdbc-6f88-40b0-be8e-d6e7da8c0fa1/agpm-troubleshooting-installation-problems?forum=winserverGP

    Best Regards,

    Mary Dong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 24, 2015 3:15 AM
    Moderator
  • so I added the service account to admin group and also tried login with service account and then trying but it still doesnt work still the same thing 

    014] DsCrackNames() failed to convert name "_agpm_test" to a FQDN.
    2015-09-24 10:08:43.684 [pid=0xaf4,tid=0x1014]     DS_NAME_ERROR = 0x00000002, The name cannot be found or the caller does not have permission to access the name.
    2015-09-24 10:08:43.684 [pid=0xaf4,tid=0x1014] Leaving MsiWriteAccountSpn(). [ hr = 0x80070057 "The parameter is incorrect." ]
    2015-09-24 10:08:43.684 [pid=0xaf4,tid=0x1014] DllMain() called with DLL_PROCESS_DETACH

    Thursday, September 24, 2015 5:16 PM
  • Hi,

    Could please also check if Windows Firewall service was "disabled" and turned off.

    Start the service if it disabled, and try if it could successfully install AGPM and apply policy.

    Reference:

    Interesting install issue with AGPM V3.0

    http://blogs.technet.com/b/janelewis/archive/2009/09/18/interesting-install-issue-with-agpm-v3-0.aspx

    Best Regards,

    Mary Dong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 25, 2015 5:36 AM
    Moderator
  • It was disabled, I start and set it as automatic and tried again but still same error 
    Monday, September 28, 2015 6:52 PM