Windows Vista Home Premium - Problem with (rundll32) after Graphics card driver installed RRS feed

  • Question

  • Hello Everyone,

    Details about my PC's hardware:

    CPU: Intel's Core 2 Duo E8500

    Motherboard: Gigabyte (EP45-UD3P rev.1.1)

    RAM: 4GB kit Kingston DDR2 800MHz

    Graphics Card: Nvidia chipset Geforce GTX 260 O.C (N260OC-896H-B)

    Operating System: Windows Vista Home Premium 64-bit OEM

    Hard Drive: Seagate Barracuda 250GB 3.5" SATA 8MB 7200RPM ST3250318AS

    Power Supply: Corsair 850 TX-850W

    *I have not updated my chipset drivers (I’m using the ones from cd), motherboard bios version I’m using is F7*

    *Note: I am not a IT specialist, but I can follow simple instructions with the instruction manuals the Windows Vista and Graphics card supplied.* Which means after i installed Windows Vista, motherboard drivers, old graphics card drivers, everything was working fine.


    Problem: I am having problems with my Windows Vista Home Premium 64-bit OEM and Nvidia graphics card drivers.

    What is the actual problem? The problem is “Windows host has stopped working (Rundll32)” . At the Windows box displayed "Windows host has stopped working (Rundll32), the details at the bottom displays this:


    Problem signature:

    Problem Event Name: APPCRASH

    Application Name: rundll32.exe

    *The rest of details I forgot what was written*


    How the problem occurred?

    These are the steps I have taken:

    -         Installed Windows Vista Home Premium + activated the product key.

    -         Installed Vista Service Pack 2.

    -         Installed the motherboard drivers (LAN, Audio, Chipset, Sata).

    -         Downloaded and installed Windows updates from Windows Update (import crucial ones).

    -         Installed graphics driver from Gigabyte installation cd.


    At this point everything is working fine. If Nvidia released a new driver version, I then download the latest driver from their website.

    Download drivers----> Geforce GTX 260 ---- Windows Vista 64 ------- English

    I then uninstall the old drivers from Control Panel , clicking Programs , and then clicking Programs and Features .

    I then select Nvidia drivers and uninstall and reboot.

    I then click on the new driver installer and install the latest drivers. Everything works fine. I did the same process and everything is working fine until Nvidia released driver version 191.07

    I install that version and rebooted and after rebooted my PC would just load “Windows host has stopped working (Rundll32).

    Also my CPU usage was maxed out.

    I tried uninstalling that driver version and installing 3 times, but the outcome is the same.

    So I click on system restore point and restore to a location before I installed the latest driver.

    After the PC reboots, everything is working fine.

    I have tried buying a new hdd and new Windows Vista, only this time I downloaded the latest Nvidia driver v197.45.


    Once I have activated my Windows, I installed the latest driver, once finished rebooted and the problem still occurs.


    I have even tried installing the driver from safe mode networking and the outcome still the same.


    Questions: What steps can I take to solve this problem?


    I have tried searching on the net, but their problems are just with Windows not when they installed a new graphics driver.


    If you’re thinking either I have downloaded the wrong drivers or haven’t uninstalled the old graphics driver properly, I know for a fact I have downloaded the right drivers for my graphics card and I have even tried buying a new hdd along with new Vista and installed the new drivers.


    I have asked around if any of my work colleagues experienced the same problem, none of them do.


    Can it be that my motherboard bios are not up to date or my chipset drivers are not up to date?


    Can it be that my graphics card is faulty? If my graphics car is faulty then how come it works with previous Nvidia drivers?





    Tuesday, May 4, 2010 4:29 AM

All replies

  • Just what are you using that graphics card for?  If it happens to be computation, rather than graphics, note that the GPUGRID project has found that some of the older GTX260 cards do not work well for computation with some of the newer drivers - something about failures in the code for distributing the work to be done among the not-all-working set of graphics cores that the graphics chips on GTX260 cards have.


    I've seen nothing relevant on whether that problem also extends to using such boards for graphics.

    Wednesday, May 19, 2010 8:23 PM