locked
SoftGrid v4.2 Server installation - bad special characters? RRS feed

  • Question

  • Howdy all,

    I haven't been active here for a while, but I came across something I figured someone may know the answer too.

    During a fresh SoftGrid Server v4.2 installation, I was attempting to use the current password for my browser account which contained the special characters: !, @, #, and $. I kept receiving a MSIInstaller error 1013: SoftGrid Virtual Application Server -- The installation program was unable to connect to the domain. The server is part of the domain & I can log in to the server with this service account / password successfully, but when I attempted to use the password 3 times during installation it would lockout the account.  A coworker suggested changing the password using other special characters & it finally worked.

    Does anyone know if there are documented special characters that do not work during the SoftGrid server installation?

    Thanks in advance.
    badshadd
    Monday, December 29, 2008 1:43 PM

Answers

  • In 4.2 (and earlier) that password would be stored in a table in the database (in the clear, no less, which is why that browser account should not be given permission to do anything other than enumerate AD accounts).  [NOTE: This is fixed in version 4.5 as passwords are never stored in the clear.]  Thus the issue would be in using any character that would interfere with the SQL statement to insert or get the value.  My training partner Kevin Kaminski documents the characters 
        \  /  "  *  ?  "  <  >  |
    to which I would add
       '
    (but I have not tested this).

    These characters will also mess up folder and file names when you import apps.

    A final "gotcha" on pre 4.5 versions which is database related is that the name of VAS machines may not start with a number (such as "2k3Vas").  I don't know if this was fixed in 4.5 as I just don't name machnes that way any more because of this.


    Good to see you back in action, though!
    • Proposed as answer by znack Tuesday, November 22, 2011 8:22 AM
    • Marked as answer by badshadd Tuesday, November 22, 2011 8:51 AM
    Tuesday, December 30, 2008 5:39 PM
    Moderator

All replies

  • In 4.2 (and earlier) that password would be stored in a table in the database (in the clear, no less, which is why that browser account should not be given permission to do anything other than enumerate AD accounts).  [NOTE: This is fixed in version 4.5 as passwords are never stored in the clear.]  Thus the issue would be in using any character that would interfere with the SQL statement to insert or get the value.  My training partner Kevin Kaminski documents the characters 
        \  /  "  *  ?  "  <  >  |
    to which I would add
       '
    (but I have not tested this).

    These characters will also mess up folder and file names when you import apps.

    A final "gotcha" on pre 4.5 versions which is database related is that the name of VAS machines may not start with a number (such as "2k3Vas").  I don't know if this was fixed in 4.5 as I just don't name machnes that way any more because of this.


    Good to see you back in action, though!
    • Proposed as answer by znack Tuesday, November 22, 2011 8:22 AM
    • Marked as answer by badshadd Tuesday, November 22, 2011 8:51 AM
    Tuesday, December 30, 2008 5:39 PM
    Moderator
  • Tim Mangan said:

    A final "gotcha" on pre 4.5 versions which is database related is that the name of VAS machines may not start with a number (such as "2k3Vas").  I don't know if this was fixed in 4.5 as I just don't name machnes that way any more because of this.



    I haven't tested either, but after a quick check on 4.5 Management Server I discovered that server.conf has disappeared from conf -directory and now SQL connection settings are in registry (under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SoftGrid\4.5\Server , to be precise).

    This would suggest that the problem is now gone as "not starting with number" was because of fact that in XML, element cannot have name starting with the number (pre 4.5 SoftGrid used server's name as element name).

    br,
    Kalle
    Tuesday, December 30, 2008 10:28 PM
    Moderator