none
VM Guest can't access internet suddently

    Question

  • We have 10 Vms guest on one host.

    Only one of VM guest exchange server can't access internet.

    Restart the Guest NIC card can fix the issue but we don't know the exchange network can't be access internet.

    Any advise?

    Thanks.

    Friday, March 10, 2017 12:23 PM

All replies

  • I'd check results of ipconfig /all, test if pinging gateway is successful. Also try to;

    tracert 8.8.8.8

    to rule out routing issues (could be problematic DNS).

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.


    Friday, March 10, 2017 1:37 PM
  • It can ping the default gateway.

    Can ping the DNS , all VMs guest use same gateway and DNS server.

    Saturday, March 11, 2017 4:51 AM
  • Please post the results of;

    ipconfig /all

    tracert 8.8.8.8

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Saturday, March 11, 2017 12:45 PM
  • To add to Dave's request, it is helpful to provide the text output of ipconfig /all for both a working and non-working system so the output can be compared for us to better understand the network configurations.  When you perform the ipconfig /all you will receive a fair bit of detail on tunnel adapters.  When you capture the information, you can edit out the information about the tunnel adapters to make the output more manageable.

    . : | : . : | : . tim

    Saturday, March 11, 2017 2:32 PM
  • Here is the ip configuration for the VM.

    Saturday, March 11, 2017 3:34 PM
  • Wondering what's the purpose of the second IPv4 address? It appears the gateway 10.1.1.254 does not provide the route. On my desktop here I can get to 8.8.8.8 in 9 hops.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Saturday, March 11, 2017 3:52 PM
  • exchange server network block ping and trace to outside.

    But it able to access google.com.

    Saturday, March 11, 2017 3:54 PM
  • So problem solved? If not you may need to disable whatever is providing the blocking on the network for long enough to trouble shoot it.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.


    Saturday, March 11, 2017 3:57 PM
  • it happen randomly, restart the network card always fix the problem, but I can't find the root cause.

    It happen one weeks ....appear three times...very painful.

    Sunday, March 12, 2017 3:41 AM
  • Hi Mick,

    Random issues are difficult to reproduce to analyze.

    If restarting could solve the issue, I suggest you delete the virtual NIC and recreate a new one.

    And also try to update the NIC driver on host.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, March 13, 2017 1:36 AM
    Moderator
  • only one VM have this issue, I think the Host NIC drive should be ok for Another VMs. 

    But exchange is import server, after this issue I've dedicated one NIC for it and monitor how can re-produce the issue.

    Monday, March 13, 2017 1:14 PM
  • Hi Mick,

    >>But exchange is import server, after this issue I've dedicated one NIC for it and monitor how can re-produce the issue.

    Welcome to share the information if you got any news.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 14, 2017 1:12 AM
    Moderator
  • When the exchange network have issue the inbound traffic is ok but the outbound have problem...

    I'm try to remove this NIC and Add new NIC for this VM guest.

    Wednesday, March 15, 2017 1:59 PM