locked
Custom Sharepoint list in datasheet view not working correctly in Standard view mode RRS feed

  • Question

  • Hi

    I'm having a problem with customized list in Sharepoint that I created using Datasheet view.

    Since I want to use this list in a webpart page, but instead of displaying it as a Datasheet view, I want to show it in a view with a Standard View, I had to create a new view for this list with this style.

    But the problem is that after I added the list in my web part page and picked the standard view I needed,  I realized that the "Add New Item" link is not showing.

    Is there any workaround to fix this problem and add the "Add new item" link ?

    Friday, October 4, 2013 6:43 PM

Answers

  • Hello,

    "Add New Item" will be visible to contributor or above rights so please verify.

    You also need to check Tool bar type of that webpart in webpart page. Edit your webpart page-->edit webpart-->make sure that you have selected full tool bar in tool bar type.

    If still face same issue then please post the pic of your webpart page.


    Hemendra:Yesterday is just a memory,Tomorrow we may never see
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, October 7, 2013 7:25 AM
    Moderator
  • As a further check, make sure that the permission group ( if it's not contribute) has the Add Item permission enabled.
    Tuesday, October 8, 2013 3:37 PM
    Answerer

All replies

  • Hello,

    "Add New Item" will be visible to contributor or above rights so please verify.

    You also need to check Tool bar type of that webpart in webpart page. Edit your webpart page-->edit webpart-->make sure that you have selected full tool bar in tool bar type.

    If still face same issue then please post the pic of your webpart page.


    Hemendra:Yesterday is just a memory,Tomorrow we may never see
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, October 7, 2013 7:25 AM
    Moderator
  • As a further check, make sure that the permission group ( if it's not contribute) has the Add Item permission enabled.
    Tuesday, October 8, 2013 3:37 PM
    Answerer