locked
Certificate errors going to Yahoo Finance RRS feed

  • Question

  • Whenever anyone from my company tries to go to finance.yahoo.com using IE 11, the site takes a long time to load and then they get multiple certificate revocation errors.  Eventually after responding to the box several times, the page loads with some missing spaces for ads.  

    If we use Chrome, the page loads without the certificate errors but the ads are removed due to a setting in our firewall.

    We do not use Certificate Services in our environment, so it appears to be something in the way that IE is handling the page.  

    Ideas on how to proceed without making my users use Chrome for some sites, Firefox for others and IE for still others.

    Friday, May 1, 2015 4:25 PM

All replies

  • Hi,

    the most likely answer is to check the system time (Start>Control Panel>Date and Time)

    see https://answers.yahoo.com/question/index?qid=20090515132548AAQeH1C

    Please include the exact address (copied from the browser address bar) of any websites you are having problems with your questions (yahoo uses locale servers and redirects.... f12>Networking tab, click the start button, then return to the web page and navigate to the yahoo domain... the requests and responses will be recorded in the Networking tab of the Developer tool.)

    If a site works in other browsers but not IE, then it is either....

    1. Your IE security zone settings... Security tab of Internet Options>click "Reset all zones to default"

    --- you should not place public access sites like yahoo or finance.yahoo in the Trusted sites list (https works in all IE security zone..... most public sites like yahoo use a separate domain like account.yahoo to verify the users credentials read from a cookie... IE has a security zone setting preventing navigation into a zone of lower integrity)... If you access yahoo finance from an intranet application, then you need to add *.yahoo.com to the trusted sites list.

    Bear in mind that domains added to security zones using Group Policy do not appear in the users Internet Options.

    2. An IE Addon (the Addons model for different browsers is different)... regardless of the brand, the first step in troubleshooting web browser issues is to test in noAddons mode.

    the simplest solution is to reset the client... Internet Options>Advanced tab>click the Reset Internet Explorer button.. this will disable any loaded addons, reset the Security tab and Advanced tab of Internet Options... you should close all open IE instances and restart IE for the full changes to take affect.

    3. You have not applied a Windows Update security patch... Programs and Features>Installed windows updates.

    a quick administrators test is to logon to the users machine using your administrators credentials.. and navigate to the problem site... if it works on your administrator account then you know it is the users settings.

    Regards.


    Rob^_^


    Saturday, May 2, 2015 3:54 AM
  • The website is http://finance.yahoo.com/ .  I have checked all the above suggestions and still have the same issues.  1) Date/Time accurate, 2) IE with no addons has same results 3) Security Zone settings were reset 4) Patches applied.  I am the admin so have tested multiple ways.

    In addition, this happens on every machine in my environment.

    Tuesday, May 5, 2015 1:18 PM
  • Hi Ferg,

    I am based in AU so I can't test that url. (you could try to reach https://au.finance.yahoo.com/?p=finance.yahoo.com but I think their servers will redirect back to the US node).

    What you can try from your end....(or someone else here with a US location).

    1. Open GPEdit and examine your Trusted Zone template and remove any yahoo domains.... (GP configured security sites do not appear in the users Internet Options lists)... IE has a security zone setting preventing navigation into a zone of lower integrity.... Yahoo and other public access sites have sub-domains eg. account.yahoo.com that are used for user validation.... You could replace http://yahoo.com with http://*.yahoo.com in your trusted sites list, but there are other non-yahoo domains (yimg.com) that are cdn's to their pages... it is best left from any IE security zone, so that all content defaults to the Internet zone).

    2. Start Run>cmd>tracert finance.yahoo.com (look for any hosts file entries)

    3. Either

    download and install Fiddler (http://telerik.com/fiddler) - uses a proxy, so if placing it in the middle corrects the problem, then it may be your company's proxy server.

    or

    Using the Developer tool (F12>Networking tab, click the start button to capture request and responses)... return to the web browser and refresh it (f5) to capture the network traffic....once completed loading (after the cert errors) return to the developer tool to inspect the traffic.

    Post back with your results... in the mean time someone else here with access to the US domain may investigate and come up with a definitive answer for you.

    Regards.


    Rob^_^

    • Proposed as answer by Yolanda Zhu Tuesday, May 19, 2015 7:59 AM
    Wednesday, May 6, 2015 2:56 AM
  • I was able to go to au.finance.yahoo.com and it loaded without the certificate errors.

    There are no group policies, no host file entries and no proxy servers.  I have captured traffic but not sure what I am looking for in the file.

    Tuesday, May 19, 2015 1:20 PM
  • Hi,

    I’d suggest that we also post at Yahoo forum. There you can get more effective suggestion by other experts who familiar with design of their website and have more similar practice on this.

    In the other hand, make sure your computer's time and date are accurate.

    If the error continues after trying the above steps:

    Launch Internet Explorer on a desktop computer.

    Click Tools | Internet Options.

    Click the Advanced tab.

    Under "Security", uncheck the boxes "Check for publisher's revocation" and "Check for server certificate revocation."

    Close and relaunch Internet Explorer, check the issue again.

    Regards,

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, May 22, 2015 2:06 AM
  • Unfortunately, even with these boxes unchecked, I still get a security alert prompt multiple times.
    Wednesday, May 27, 2015 1:36 PM