none
disable field "Planned" in timesheet RRS feed

  • Question

  • In timesheet:

    -Green rectangle: "Отпуск" - request for vacation, "Административные" - administrative time

    -Red rectangle: "Фактические" - Actual, "Плановые"-Planned

    

    How can I make inactive the "Planned" field ? Because resources make mistake: they fill "Planned" field instead of "Actual". Therefore, resource manager sees that request comes with 0h in Actual Field (he sees only Actual Field).

    Wednesday, May 2, 2012 9:52 AM

All replies

  • There is no way to centrally disable the Planned Row. In my opinioin this needs to be handled through training, and having users uncheck the box for Planned on the ribbon as shown below.

    You could try the Development and Customization forum, to see if you there are any javascript/jquery ways to do this.


    Prasanna Adavi, PMP, MCTS http://thinkepm.blogspot.com

    Wednesday, May 2, 2012 11:59 AM
    Moderator
  • Hi there--

    Below link might help , It's for the PS2007 . You may try with Jquery/Javascript on PS2010 :

    http://www.projectserverhelp.com/Lists/Posts/Post.aspx?ID=8

    Hope that helps.


    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    Wednesday, May 2, 2012 12:29 PM
  • i change pwastyle.css:

    .XmlGridPlannedWork  {

    display: none;

    }

    But it's not work.

    Thursday, May 3, 2012 6:46 AM
  • Hi There,

    I was able to disabled/enabled/Hide the option using the Jquery. You can uncheck the checkbox "Planned &"set the properties as disabled true or display None in css. You can allsco set property as Uncheck & then hide it.
    Control ID= Ribbon.ContextualTabs.TiedMode.Home.ShowHide.PlannedWork-Medium

    <script type="text/javascript"> 
    var elem = document.getElementById("Ribbon.ContextualTabs.TiedMode.Home.ShowHide.PlannedWork-Medium"); 
    elem.style.display = "none"; 
    </script> 

    Hope that helps.


    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    Thursday, May 3, 2012 11:20 AM
  • Your tips is very helpfull, thank you!
    Friday, May 4, 2012 5:03 AM
  • You are most welcome :)

    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    Friday, May 4, 2012 5:14 AM
  • Works for me. This seems to be a far esier way of removing the "Planned" row. Once the .css file is modified, be sure to restart IIS and clear your cache (might be overkill...)

    This works for me...in PWAstyle.css...

    }
    .XmlGridPlannedWork  {
            display: none;
     background-color: #fffff0;
    }

    THis file is located here: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\TEMPLATE\LAYOUTS\PWA\STYLES

    Friday, July 13, 2012 4:36 PM
  • Is this really a mistake? Whe users enter future planned time for a vacation and the PM approves it, the system creates a calendar exception. This is generally considered a desirable behavior.

    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG

    Monday, July 16, 2012 1:14 PM
    Moderator
  • I want to see Planned field, but it would be nice if we could make this field inactive.

    I know that there is such a style - "computed-backgroundcolor: gray", which makes the field Planned visible, but you can not enter anything.

    Use this style is not working.

    Tuesday, July 17, 2012 5:56 AM