locked
My wallpaper gets badly compressed RRS feed

  • Question

  • Here is a screenshot of my blank desktop with the background I just made, meant to parody others' super messy ones. The background file is square so that it matches in portrait mode. As you can see, it has become very badly compressed. I've even tried using it in jpg and bmp with no success. What the heck???

    ...thanks for any help!
    • Moved by Carey FrischMVP Saturday, September 19, 2009 2:21 PM Moved to relevant category (From:Windows 7 Miscellaneous)
    Saturday, September 19, 2009 6:22 AM

All replies

  • Dunno, looks pretty fine to me, except for some JPEG artifacts. Those must've come from you graphics editing software, since such kind of artifacts appear only from data compression, not scaling.

    Regards,
    Kristaps.

    P.S.: Epic shoop is epic.
    Saturday, September 19, 2009 8:56 PM
  • Thanks for the reply but I'm telling you Windows bee'd retarded at it. Here's the actual png .
    Saturday, September 19, 2009 9:44 PM
  • Hmm, looks like you are indeed right. Dunno why this is happening...
    Regards,
    Kristaps.

    P.S.: Epic shoop is epic.
    Saturday, September 19, 2009 9:53 PM
  • Hi,

    Generally, the appearance of desktop background is related to screen resolution, picture dimensions and desktop background configuration. I just downloaded your square picture and tested on our test machine, you can adjust the picture to meet your screen resolution by right clicking the Desktop==>clicking Personalization==>clicking Desktop Background==>selecting Stretch under Picture position==>clicking Save changes.

    See if it works.

    Best Regards
    Dale Qiao
    • Marked as answer by Dale Qiao Thursday, September 24, 2009 6:01 AM
    • Unmarked as answer by Davjdag Friday, September 25, 2009 6:43 PM
    Monday, September 21, 2009 7:34 AM
  • You should know better than to suggest that. Stretch is BAD and should ALWAYS be avoided, whether or not you need to deal with portrait mode which is the reason why I made that background square to begin with.
    Friday, September 25, 2009 6:59 PM
  • I've had noticed the same problem in Windows Vista 64 bit which I have in my main computer and what I found was that when I right mouse click in a picture and use the Set as Desktop Background function in Vista it compresses the image and stores it as a .jpg image in a folder with the name Windows Photo Gallery Wallpaper.jpg. There is a way to fix this let me explain:

    It doesn't matter what your starting image format is because Vista (and I presume that Windows 7 does the same as you describe) turns your picture into a too heavily compressed image automatically.

    The problem is not that it stores it as a .jpg and the problem is not that it compresses it, the problem is that it compresses it way too much for some people's tastes including yours and mine. I like my wallpapers to look pristine and not full of artifacts and that's one of the reasons that many times I do them myself because sometimes wallpapers from the web are too heavily compressed.

    It's a common misconception that all .jpg are full of artifacts because people are used to see them like that and that is because for web pages it is OK to compress them a bit for the sake of fast web page display, the problem is when people compress things like wallpapers, paper models (card models) made in a bitmap format (like Jpeg or Png) and similar things too much as they were web page pictures. For some things it is preferable to preserve a higher quality and use far less compression.

    Jpeg images can be stored with far less compression and when you do that they can be virtually free of artifacts. What I do is that I use the .jpg format but when I save an image I save it with a very high setting for quality such as 96 to 99 percent (almost no compression) instead of the 70 to 85 percent (or less) that too many people use for wallpapers, etc. which is a pity cause for high definition you can tell the artifacts even more easily that in yesterdays displays.

    This is still a lossy method because the .jpg format losses some information when it compresses things but at such a high setting the quality of an image is very high and virtually artifact free.

    The advantage of saving images as .jpg with a very low compression setting is that even at that setting the file size is way lower than saving it as a Windows Bitmap or as a PSD (Photoshop file) or other formats that have lossless compression or no compression at all.

    So you can save or export them as a .jpg with a very low compression (test it until you find a setting that you are satisfied with) and still preserve your wallpaper image quality. You can still save and you should save your image also in the original image editor format such as a .xcf (The Gimp) or .psd (Photoshop), etc. because those formats are lossless and those image editor formats also preserve their layers for further editing in the future and as for vector original formats such as CorelDraw you always save an original vector format of course so its not a problem for future editing.

    It is OK to save them as .jpg, just use a very low compression (I sometimes use the maximum, 99) and for .png it does not matter what setting you use cause .png is a lossless compression system and the difference between the lowest and maximum compression seting is merelly encoding and decoding speed. Png files are usually compressed in programs from 1 to 9 and 1 is the lowest compression. I use now the maximum cause it is the one that compresses the images the most even if it takes longer to save. I rather wait a little and save precious disk space. But it is better to save them as .jpg for Vista wallpapers as I will show you.

    If you want to prevent too many compression artifacts in your Vista or Windows 7 wallpapers you save you images to the place where Windows stores them manually without using the Set as Desktop Background feature. In my computer this folder is in C:\Windows\Web\Wallpaper.

    Try to find that folder and store your wallpapers there yourself manually. In my case (Vista) when I right mouse click on the desktop I select Personalize and I choose Desktop Background and right there I get this folder and you can see its location when you click the Browse button in the window that appears. Just click in the address bar above and you will see the whole address to that folder and you can even create a shortcut on your desktop to take you to that place directly to make it easy to put other wallpapers there in the future but if you want to you can just copy & paste a wallpaper right there in that folder that appears after you clicked on the Browse button. As for what format to use in that folder I found that it works with .jpg only as far as I know cause if I put a .png image in that folder when I click the Browse button I don't see the picture so I use the .jpg format to put wallpapers there.

    Do this and then normally select any image that you manually placed on that folder as a wallpaper and voila! your artifacts will be gone. :)


    • Edited by PixelOz Sunday, February 16, 2014 2:20 AM
    Friday, January 15, 2010 7:41 PM
  • Found a solution to have your desktop wallpaper image without the jpeg artifact of windows 7 compression.

    Open your lossless BMP image in Firefox, right click the image, and select “Set As Desktop Background…” This solution is weird since it lets you use a bitmap as your wallpaper. So, obviously, the code is there to let you do this.

    solution found on

    http://www.wybe.us/2010/04/07/windows-7-annoyance-1-desktop-wallpaper/

    Wednesday, April 14, 2010 3:15 AM
  • I was wondering this too. As far as I can tell this is a Windows 7 problem. I wouldn't call it a bug, because it is completely purposeful. I order for Windows 7 to create a slide show background, the program automatically takes your nice image and compresses it to a bad quality JPEG. It does this every time the background changes.

    If you are using the slide show option, there is no solution unless Microsoft fixes the the compression settings.

    If you are using one wallpaper try saving your image as a JPEG in the folder C:\Users\YOUR USERNAME\AppData\Roaming\Microsoft\Windows\Themes. Make sure to name the file "TranscodedWallpaper." This might work, but Windows may recreate this if the PC is restarted.

    Sunday, July 11, 2010 8:27 PM
  • Yay!
    I actually found a fix after searching all of everything and no luck.
    This fix works well and lets you use the Windows slideshow, or auto changing wallpapers or whatever it's called.
    Save your images as a bitmap, aka .bmp and then rename to .jpg so the file itself is actually a bitmap but it gets passed to the OS as a jpeg, so it thinks it doesn't have to compress it, and the native reader interprets bitmaps.
    I tried with .png's and .tif's and no luck.  Bitmaps are the only way I've found that works.

    Hope that helps!

    http://www.deviantart.com/download/185292593/artifact_test_by_spigget-d32bgoh.png
    http://www.deviantart.com/download/185292788/artifact_screenshot_by_spigget-d32bgtw.png
    Sunday, November 7, 2010 2:32 AM
  • HI All

    I've just spent 1hr with this same problem, I just processed a batch of images from my 15MP DSLR, look fine with every image viewer  i have but if I set them to a desktop they are really bad, the solution I found is that the images need to be reduced in size before setting them has desktops.

    i.e my 3056x4592 (40.1M) look great has desktop if I reduced the image size to around 768x1024 then set them has desktops.

    Sunday, November 7, 2010 4:40 AM
  • You sir are a genius!
    Saturday, February 5, 2011 4:29 AM
  • There is another solution than renaming a BMP if you want to use the slideshow or themes features. Windows won't recompress the image if it's already JPG, so basically we just need to use the highest JPG compression, which is lossless (tested). For that, open our PNG image with GIMP, click on File, Save as..., and select Quality: 100, and Subsampling: 1x1, 1x1, 1x1 (best quality). See this screenshot, made with this method:

    http://imageshack.us/photo/my-images/28/img004mzh.jpg/

    Files will usually be bigger than their PNG equivalent (but not always) but not nearly as big as a BMP file ;)


    I'm a student, and a hobbyist programmer (freeware pc apps & video game consoles), using VS 2008.

    Wednesday, May 25, 2011 4:46 PM
  • This is ridiculous. Why the hell can't I change this setting?

    Anyone have a real solution? I have a beautiful wallpaper and W8 insists on compressing it.

    Wednesday, November 14, 2012 5:00 AM
  • OK I have found a temp solution to fix the Microsoft buggy issue!!

    The Solution:

    1. Open this Directory
    C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Windows\Themes


    2. Inside the folder themes you will see your wallpaper file called TranscodedWallpaper which is the automatically compressed wallpaper from windows.

    Rename this file to "TranscodedWallpaper1"

    3. The high resolution Wallpaper you would like to set as your background locate and copy it into the themes folder.

    4. Rename your wallpaper to TranscodedWallpaper and remove the .jpg extention / bmp extention from your file name.

    5. Go to your desktop right click and refresh!

    6. You now have your High Resolution wallpaper!


    This is a temp fix until Microsoft sorts the issue out.


    Cheers
    Grant.
    • Proposed as answer by GrantLK Tuesday, December 11, 2012 9:23 AM
    Tuesday, December 11, 2012 8:48 AM
  • I have been avoiding this issue as follows:

    If I use the Set as Desktop Background image function available from the Windows Explorer my already optimal .jpg wallpaper get artifacts when displayed. I mean that I set the .jpg compression to 100% (the minimal) and save my wallpapers always as such and when I open that image in any program it is virtually artifacts free cause in the maximum setting Jpegs are still pretty good but if I use the Set as Desktop Background option with those same images Windows over-compresses them and screws them up rather badly.

    I found how to bypass this by opening the folder where Windows Vista (mine is 64 bit) stores the wallpapers and saving my .jpg wallpapers directly there by hand. In my case that folder is in C:\Windows\Web\Wallpaper and I open it through the Windows Explorer and save the wallpapers in that folder manually.

    Another way in which I do that is by right clicking on the desktop and selecting Personalize then selecting Desktop Background and then clicking on the Browse button. Once that window with the wallpapers folder opens I paste my .jpg wallpapers there directly and when I select them they do not get overly compressed like that, they are clean.

    Now, you have to make sure that you use the Fit to screen (first option to the left) option in the Desktop Background window in the area at the bottom of the window where it says How should the picture or video be positioned? cause if you use the Crop to fit screen setting (last option to the right) it may look similar at first sigh but it will over-compress the pictures anyway and show them all full of artifacts. It does not damage your manually placed .jpg pictures, it merely does so to the temporary one it stores for displaying it as a wallpaper. If you had selected the Crop to fit screen setting before, your pictures will look right again when you change the setting to Fit to screen.

    • One last tip if you are a Photoshop user. Do not save your .psd images (Photoshop images) as .jpg from Photoshop itself, save them as a .psd and then use the The Gimp (free open source paint program -  http://www.gimp.org/) to open the .psd files and then save them as .jpg from The Gimp with the compression at the minimum (100%) cause believe it or not Gimp will save the .jpg images with better quality at 100% than Photoshop at the same setting, YES IT DOES.

    If you do not believe me try it with several pictures and look carefully and particularly at those with more banding (many 24 bit images can suffer from banding cause of limited colors) specially at darker areas where there is supposed to be a smooth transition. When saved as .jpg from The Gimp they have less banding (even though in the .jpg format images usually get a little more banding due to the lossy compression) but in The Gimp they get less. When saved from Photoshop with 100% setting they have far more banding and artifacts. Pretty interesting isn't it? Given the fact that Photoshop is like the premier pixel editor of the world. My version is CS4 which is not that far back and in that version I noticed this a long time ago. I do not know if the issue is still there in the last two versions CS5 and CS6 (or CS6.5 which is where it is now) but the current version of The Gimp does a much better job at 100% when saving a .jpg. If the current version of Photoshop still suffers from this then Adobe has to address this issue and rather pronto, we will see.

    If  you have things like layer effects then create a flattened image first before saving it as a .psd cause the layer effects do not work the same in The Gimp (they are done with a separate non-parametric plugin) and when you open the .psd image with them in The Gimp they will be discarded. So save it as a separate temporary flattened .psd (perhaps with the word flat in the file name) to prevent you from damaging the layers of your carefully crafted .psd file and then open the flattened .psd in The Gimp and save it as a 100% .jpg from there and your .jpg will have even better quality.

    Now, do not get me wrong, I am not saying that The Gimp is a better program than Photoshop is, it is not. I can use both of them to the max and Photoshop is still way better but amazingly Gimp is still better at a few things, not many but a few things and it is still a very powerful image editor that cost nothing and the heck Photoshop can't beat that. In the next version 2.10 it will have much better 16 and 32 bit color capability making it even more powerful than it already is.


    • Edited by PixelOz Sunday, February 16, 2014 2:21 AM
    Saturday, February 15, 2014 11:58 PM