none
Bitlocker bootsplash screen is corrupted after upgrade on July 12th 2016

    Question

  • HI,

    my system upgraded yesterday successfully, however today I recognize when booting my computer that the splashscreen that normally appears after the BIOS messages, where I enter the bitlocker password to unlock the system drive does not show up correctly anymore.

    I can only see an color bar at the top of the screen, but the rest of the screen is black, there is no box where the password is entered and the other information does not display at all. However, luckily I can still unlock the drive by entering the password "blind". Having all that said, in the case of an error and the lack of the bitlocker prompt screen, I may not be able to recover.

    For your information, I only use a password for bitlocker since my computer does not have an built in TPM.

    Can you please let me know where I can raise this issue? Or can you raise it?

    Thank you


    Thursday, July 14, 2016 5:49 AM

Answers

All replies

  • All machines here are bitlocked and on win10 and have already installed this week's updates. No bootscreen corruption, so it is a problem on your machine. I have seen bootscreens that change from the (as of windows 8 and higher) new look (blue) to the oldschool look (black and white) for some unknown reason and then back on the next reboot. So my first attempt to solve it would be to reboot a couple of times. if that does not solve it, you can go though the usual suspects that are:

    -dism restorehealth (google that command)

    -decrypt and re-encrypt

    Thursday, July 14, 2016 10:54 AM
  • Thanks for your information, I rebooted at least 10 times since the loading the Microsoft patches on Tuesday this week and the behavior is still the same.

    It also should be noted that it is not only me who has this issue, there are several others who ran into the same issue after the last pacht day, see also link below.

    Microsoft Support Forum - Bitlocker Issue

    The dism command ended successfully and no errors were found, but the bitlocker prompt screen is still corrupted.

    Before following the suggestion to decrypt / re-encrypt,  what happens if I cannot read the information again when the bitlocker prompt appears after re-encrypting?



    • Edited by techie333 Thursday, July 14, 2016 7:22 PM
    Thursday, July 14, 2016 6:52 PM
  • Hi doeffi,

    As far as I know, the machine hasn`t been boot into the Windows system when we are on that screen. That screen could be more related to the BIOS. Please check whether there is a BIOS update has been installed on the machine.

    To troubleshoot whether it is related to the latest update, we could try to uninstall the latest updates manually to have a troubleshoot.
    If the issue is caused by the latest updates, we may refer to the following link to disable them and wait for the next update release.
    How to temporarily prevent a Windows or driver update from reinstalling in Windows 10
    https://support.microsoft.com/en-sg/kb/3073930

    You may try to submit the issue on the following link:
    The July updates KB3163912 and KB3172985 are out for Windows10!
    https://social.technet.microsoft.com/Forums/en-US/8fa75b41-c83f-4cef-b8e8-bb199968d25c/the-july-updates-kb3163912-and-kb3172985-are-out-for-windows10?forum=win10itprogeneral

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Friday, July 15, 2016 6:18 AM
    Moderator
  • You can only improve your situation, so I would not speculate what happens then before trying.

    Of course you can inform yourself what file that is that holds the boot screen and analyse it (try to display it somehow), but that might be complicated. It will be somewhere on the small boot partition that (by default) does not have a drive letter.

    Friday, July 15, 2016 6:18 AM
  • No, it's not related to the BIOS, it's probably rather this file:

    X:\EFI\Boot\bootx64.efi\.rsrc\HTML\bootmgr.xsl

    (I assigned x: to my 100MB boot partition using diskpart assign).

    Inside that file there's the bitlocker text and color info:

    -<xsl:template match="fve-legacy-ui">


    -<osxml:text-mode-ui>


    -<head>


    -<title color="XXXXRGBX">

    <xsl:text> BitLocker drive encryption </xsl:text>

    </title>


    -<xsl:for-each select="@footer-multi-continue">


    -<footer color="XXXXRGBX">

    <xsl:text> ENTER=Continue F11=OS Selection ESC=Recovery </xsl:text>

    </footer>

    <meta action="continue" key="ENTER"/>

    <meta action="recovery" key="ESC"/>

    <meta action="multi" key="F11"/>

    </xsl:for-each>


    -<xsl:for-each select="@footer-multi-continue-winkey">


    -<footer color="XXXXRGBX">

    <xsl:text> ENTER=Continue F11=OS Selection WINDOWS KEY/ESC=Recovery </xsl:text>

    </footer>

    <meta action="continue" key="ENTER"/>

    <meta action="recovery" key="ESC"/>

    <meta action="winrecovery" key="WINDOWS"/>

    <meta action="multi" key="F11"/>

    --

    But that seems to be the legacy BL screen, maybe the new one is in another file.

    Friday, July 15, 2016 6:28 AM
  • Others are having similar problems with the latest patches, see link below and I do not want to trial and error on my productive computer, event it is just my personal one.

    https://social.technet.microsoft.com/Forums/en-US/2d7bd961-5ded-42b9-996e-945bd63e0a15/bitlocker-screen-is-orange-with-white-lines?forum=win10itprogeneral

    I nthe above thread, they also claim, decrypted re-encrypt does not solve the issue. So this will not help at all and just waist time.

    The issue defintely comes from the latest update and the BIOS is not the root cause of the issue.

    Sorry but, guessing which file to edit does not help either.
    • Edited by techie333 Friday, July 15, 2016 7:50 PM
    Friday, July 15, 2016 7:49 PM
  • Hi doeffi,

    "The issue defintely comes from the latest update "

    So you have tested that the issue disappeared when we removed the latest update, right?  If that is the issue, please report back to the thread as I pointed out before and submit the issue with the built-in "Feedback" tool. I hope there will be an update later.

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com



    Monday, July 18, 2016 6:56 AM
    Moderator
  • I have the same problem. So does a colleague and so do others I've seen reporting this elsewhere.

    Starting with the last update, I get a plain light blue screen on startup and no bitlocker PIN entry box.

    I can type the PIN blind into the blank screen and it works.

    No solution found yet.

    Rolling back the update did not work for my colleague.

    SFC /SCANNOW did not work for me.

    Monday, July 18, 2016 1:23 PM
  • Good news, please check the below stream and see the solution that worked on my system perfectly and on others too.

    https://social.technet.microsoft.com/Forums/en-US/2d7bd961-5ded-42b9-996e-945bd63e0a15/bitlocker-screen-is-orange-with-white-lines?forum=win10itprogeneral

    Monday, July 18, 2016 5:07 PM
  • Hi doeffi,

    I am glad the issue has been resolved and thanks for updating.

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Tuesday, July 19, 2016 2:49 AM
    Moderator