windows 7 explorer process cpu 50% RRS feed

  • Question

  • Ok, I simply boot up my Windows 7 machine, which I do development in VS2008 and VS2010 on, and within a few minutes explorer.exe is running at 50%.  Since the machine is a dual core machine, it is using 100% of one core.  This has been going on for months and is just getting more and more irriating, fore there are times when the machine simply stops because explorer is using too much CPU.

    What I have done to try to solve this problem over the months:

    • Updated all the drivers, including some that had not been installed, such as for the card reader I never use.
    • Under Explorer's Folder Options, set the "Always show icons, never thumbnails".
    • Removed all files from my desktop.

    I saw a post somewhere that mentioned "Find out what file explorer.exe is using" but it never state HOW to do that.  Any suggestions?


    Wednesday, May 4, 2011 7:25 PM

All replies

  • It is to the point now that I open Explorer and it is running at 50%.  There has to be a way to find out what it is doing, the only question is now!
    Wednesday, May 4, 2011 7:50 PM
  • Disable thumbnails?



    • Marked as answer by Miya Yao Tuesday, May 24, 2011 9:23 AM
    • Unmarked as answer by EHCarleton Tuesday, May 24, 2011 2:21 PM
    Thursday, May 5, 2011 3:08 PM
  • Heck, I saw it in a post somewhere and thought i would try it.
    Thursday, May 5, 2011 3:10 PM
  • Disable thumbnails?



    I find it very sad that a moderator of this forum would come in and mark a question to my question as the answer.  It provided no useful info wait so ever, I assume the moderator is simply trying to up his forum points. 
    Tuesday, May 24, 2011 2:22 PM
  • I'm not a moderator.  You're welcome.


    Wednesday, May 25, 2011 2:17 PM
  • You can Click Start->type resmon->select resource monitor from the results. Toggle through the different tabs, firstly the CPU tab. Observe the usage and source.


    Try a clean boot and find out if a non-microsoft service is the cause.

    Click Start->type msconfig->select it from the program results->slect the services tab->select hide all microsoft services->uncheck all others->ok and restart the computer and observe the processor usage

    You can 50\50 if it helped  and find the culprit by elimination or just run it again and turn all services on if that was no help


    Temporarily disable the security\anti-malware software. Open windows defender and turn off real-time protection. Only run one active or real-time security application at a time.



    Thursday, May 26, 2011 1:10 AM
  • Actually I have traced it down to something running in explorer.exe.  When I use Process Explorer (sysinternals.com), explorer.exe is running at 48% to 49%.  When I double click on it and look at threads, it is ntdll.dll that using everything.  When I look at the thread stack for that ntdll.dll, but I don't know what to make of it, other then to kill explorer.exe by killing the thread.  explorer.exe comes back but isn't eating up all the CPU. 

    Here is the ntdll.dll call stack:


    Friday, May 27, 2011 2:43 PM