locked
Alt-tab + Peek in real world RRS feed

  • General discussion

  • Can you make possible change current style (Release Candidate) of Alt-TAB to one of:
    1) turn off Aero Peek on it only (Aero peek on task bar was a good idea)
    2) change delay of Aero Peek on it only
    3) use Aero Peek only on mouse over required application in Alt-tab

    "On paper" this was good idea. But in real world this feature very annoying...

    Current aero-style of Alt-TAB already have application's active screen shots which help to see any changes in all applications. Change anything while user only choosing which application activate is very strange for him.

    Few samples:
    1) User can hold on some application in Alt-tab, but watch by another while something change on it. He don't need change something else in this situation.
    2) User press Alt-TAB, select required application, but still look at previous one for some information (for write it in next application, for example). He don't need change something else in this situation too. He look at previous application. He don't want look at big preview of next one...

    thank you.
    • Changed type Arthur Xie Tuesday, May 5, 2009 4:00 AM
    • Edited by SailorMax2 Friday, October 30, 2009 4:49 PM small fixes
    Saturday, May 2, 2009 5:03 PM

All replies

  • Thank you for your suggestion. This thread will be viewed by related department.
    Arthur Xie - MSFT
    Tuesday, May 5, 2009 4:00 AM
  • Can I take a moment to second this suggestion.  The aero peek on alt-tab is driving me nuts.  Maybe it is just the way it looks on a dual monitor machine but it is not a user friendly feature.  I'm sure there must be a registry entry to change the delay or turn it off but I can't find any mention of it.  If there isn't any way to turn it off please add that feature before RTM.

    Thanks!
    Sunday, May 10, 2009 10:34 AM
  • I'm also being driven crazy by Aero Peek in Alt-Tab.   If I pause on a window when alt-Tabbing, then peek is good, but if I then tab to the next window, I don't want to peek at that full window unless I pause again.   If that behavior isn't possible, then I'd prefer to turn it off for Alt-Tab.
    Monday, May 11, 2009 10:12 AM
  • /wrench

    I've found the Aero-Peek + Application Switcher combination to be pretty useful.
    Monday, May 11, 2009 10:51 AM
  • I also agree... This is what I normally do:

    1) I hold alt-tab to look for the desired application and
    2) press alt-tab until I hit the desired app.

    But what happens now, Aero Peek kicks in between 1 and 2, hiding the alt-tab preview window. Not only does it make me dizzy but it makes task switching a lot less efficient. For me anyway...

    I think if the alt-tab window would at least stay on top, that would make things better.

    Thank you,

    J-F Bohemier

    edit: Is the window preview that kicks in after pausing on alt-tab really Aero Peek?
    edit: I don't think so because if I turn Aero Peek off, alt-tab keeps the same behaviour
    • Edited by bohemier Friday, May 15, 2009 2:45 PM
    Friday, May 15, 2009 2:21 PM
  • I like it the way it is. Just my opinion.
    Friday, May 15, 2009 2:35 PM
  • The alt-tab preview window stays on top for me.  But the big windows flashing behind it are still a distraction.

    Friday, May 15, 2009 2:47 PM
  • Strange... it's back on top now. Ever since I installed RC1 (2 weeks ago) it had the behavior described above, but now it's back to normal and stays on top. The only significant thing I did today was to activate Windows 7...
    Friday, May 15, 2009 6:30 PM
  • I was also annoyed with the Peek in the alt-tab menu, I liked it the old way where you can pause on any item for as long as you wish and nothing ever happens, no peek no switch, until you release Alt.

    I was able to get win7 RC1 (7100) to do this for me finally after looking all over many forums and not finding anything. Here is how:

    1) Go to System Properties (right click "Computer" in an explorer window and do properties)
    2) Click Advanced System Settings
    3) you should be on the Advanced Tab, in the performance section, click "Settings..."
    4) Uncheck "Enable Aero Peek"
    5) click OK     

    voila! back to normal, no more migraines! (I use alt-tab alot really quickly...) 

    (it also seems to make my system a bit more responsive, a bonus)

    -Agronqui
    Thursday, June 11, 2009 1:33 AM
  • Great work Agronqui! Thank you for posting this tweak, it works wonderfully without the Aero Peek constantly flashing windows. You saved me many headaches :)

    Thursday, June 11, 2009 2:23 AM
  • Dear developers,
    Coud you please please allow us to assign the functionality of the win+tab and alt+tab to mouse buttons. You know most mouses come with more than 3 buttons. It would be very very useful if one could access win+tab and alt+tab just by using the extra mouse buttons
    Thursday, June 11, 2009 4:24 AM
  • 2Agronqui: problem not in Aero Peek. Problem in Aero Peek on Alt-Tab. Aero Peek on "Show desktop" and on "task bar buttons" - very useful!
    Thursday, June 11, 2009 9:23 AM
  • irfanbulu, there are a number of ways to do this: I personally use the Intellipoint driver (available at microsoft.com/mouse) to assign the mouse wheel button to "Ctrl-Alt-Tab" via the macro editor (assign a macro to do the following: Ctrl(down) Alt(down) Tab(10) Alt(up) Ctrl(up) ).  If you don't have a microsoft mouse, AutoHotkey can also do it. See http://cybernetnews.com/2008/02/24/alttab-mouse-shortcut/ for an example.

    Thursday, June 11, 2009 1:08 PM
  • You are right SailorMax, but saddly AeroPeek gets in the way of the most basic function: Alt-Tabbing. I believe this should be fixed... I still loose the alt-tab window sometimes when aero peek kicks in, which makes it almost impossible to get to the right window. This happens mostly when I've had my sesison opened for a couple of days...
    Thursday, June 11, 2009 1:13 PM
  • irfanbulu, there are a number of ways to do this: I personally use the Intellipoint driver (available at microsoft.com/mouse) to assign the mouse wheel button to "Ctrl-Alt-Tab" via the macro editor (assign a macro to do the following: Ctrl(down) Alt(down) Tab(10) Alt(up) Ctrl(up) ).  If you don't have a microsoft mouse, AutoHotkey can also do it. See http://cybernetnews.com/2008/02/24/alttab-mouse-shortcut/ for an example.

    thanks for this excellent information...But, seriously, this should be included as an option in the OS in a transparent way. It is such a nice feature to be able to access these functionality through the mouse button.
    Friday, June 12, 2009 12:15 AM
  • I just installed Windows 7 RTM and this is absolutely driving me crazy.  I think if the Alt+Tab window stayed ON TOP it would be a satisfactory compromise for all.  Then you can get Aero Peek and be able to see all the apps you are Alt+Tabbing between.  The delay is too quick.  By the time I'm half way done scanning the Alt+Tab list, it's already "previewed" (in Alt+Tab it's not as much of a preview as a full switch) and I have to lift the Alt key and start over again. 

    This is really slowing me down a lot.  And it's sad because Aero Peek is really cool in all other situations (desktop peek, taskbar peek, etc.).

    PLEASE release a hotfix for this (or point us to a registry key or something).  This is like a big UI slow down in an otherwise very slick and very fast OS.
    Sunday, August 16, 2009 8:00 PM
  • I'm not sure what you are saying. If I press and hold ALT then press  tab, I get the ALT Tab windows on top. Then I keep holding Alt and repress tab to get the next window or I can use the mouse hover over the Alt tab window and preview each.
    Sunday, August 16, 2009 8:10 PM
  • I agree.  This is very annoying and confusing.

    Aero peek is cool, and so is Win+Tab.  But when I start using Alt+Tab, I have to stop and think.

    If this could be a separate performance option, that could be disabled separately, that would be best.
    Sunday, August 16, 2009 8:21 PM
  • That is absolutely not what happens for me.  This is a two day old fresh Windows 7 RTM installation.  I hit alt+tab, wait a second, and the alt+tab window goes behind the "preview" and I completely lose visibility of the Alt+Tab window.  I wouldn't mind the preview if alt+tab stayed on top!!

    Are you using RTM?  Is there some setting I missed that keeps alt+tab on top?
    Sunday, August 16, 2009 10:45 PM
  • I have a fresh  clean install of Windows 7 x64 RTM and it stays on top as long as I hold the ALT key down.
    Sunday, August 16, 2009 11:09 PM
  • I have a fresh  clean install of Windows 7 x64 RTM and it stays on top as long as I hold the ALT key down.
    That is weird.  I just did a reboot and now it's working as you described.  I smell a bug...

    I am going to see if I can find the trigger.
    Sunday, August 16, 2009 11:11 PM
  • The exact same thing happened for me. Couldn't find what triggered it...
    Monday, August 17, 2009 1:00 PM
  • Agreed it's annoying.
    Thursday, August 27, 2009 3:48 AM
  • I am also seeing this bug, which makes Alt-Tab impossible to use.  This is a critical bug with Alt-Tab in Windows 7 IMO.

    As soon as Peek preview is activated, the Alt-Tab switching window is lost behind the window being previewed.  This means the only thing you can see is the Peek preview, unless the preview happens to be small enough, or off to the side enough, so that you can still see the Alt-Tab switcher in the background.  

    The only work around is to keep hammering the tab key fast enough so that Peek preview is never activated (which is a pretty quick pace) until you get a good enough look at the Alt-Tab switcher to figure out where the window you want is, and then land on it the next time around.  Ouch!

    I agree it also seems to come and go, but I also haven't found a specific trigger...


    Wednesday, September 23, 2009 8:28 AM
  • I now have a machine with Windows 7 Enterprise RTM\Eval version.

    It is on it's fifth day and no sign of the annoying behavior yet.

    Thursday, September 24, 2009 3:54 AM
  • For those of you getting seizures from the alt-tab aero peek default functionality, which I found is the default in RTM as well (I can see there are some more posting here that might not have seen my response buried in the middle of this thread...):

    A way to disable Aero Peek and increase system performance, at the loss of all Aero Peek functionality, is detailed in my post above, I'll copy it here to avoid search confusion: ( btw I agree with you SailorMax2, it should be broken down into finer grained options to select which types of Aero Peek you want on and off, but barring that so far, this will at least get you "classic windows" alt-tab behaviour for those who rely on it heavily and cannot abide the aero peek version.)


    -------------------------------------------
    I was also annoyed with the Peek in the alt-tab menu, I liked it the old way where you can pause on any item for as long as you wish and nothing ever happens, no peek no switch, until you release Alt.

    I was able to get win7 RC1 (7100) to do this for me finally after looking all over many forums and not finding anything. Here is how:

    1) Go to System Properties (right click "Computer" in an explorer window and do properties)
    2) Click Advanced System Settings
    3) you should be on the Advanced Tab, in the performance section, click "Settings..."
    4) Uncheck "Enable Aero Peek"
    5) click OK     

    voila! back to normal, no more migraines! (I use alt-tab alot really quickly...) 

    (it also seems to make my system a bit more responsive, a bonus)

    -Agronqui
    -------------------------------------------
    Saturday, October 24, 2009 2:54 AM
  • Agronqui, your solution does not work!!!! At least not on my Windows 7 Ultimate.  Any other ideas? 

    What an ANNOYING ALT+TAB behavior, specially if you have more than a dozen windows opened (some of us have to, depending on applications we use). I guess somebody deserves an anti-genius medal in the development team of Windows 7.
    Friday, October 30, 2009 2:51 PM
  • yea i have this problem too, where the peek is going over the alt tab grid, it is so annoying. this never happen when i was using the rc.

    video.
    http://www.screentoaster.com/watch/s..._7_alt_tab_bug

    i have 64bit home premium installed on my laptop and desktop, this bug happen on my laptop but not my desktop.
    Sunday, November 1, 2009 4:57 PM
  • I found this registry tweak on the web some time ago.

    1. Open regedit

    2. Navigate to: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab

    3. Add DWORD.  Type in LivePreview_ms

     

    I'm using Windows 7 Home Premium 64 Bit.  It disables the Alt-Tab Peek, on my computer at least.

    Tuesday, July 13, 2010 8:16 AM
  • I found this registry tweak on the web some time ago.

    1. Open regedit

    2. Navigate to: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab

    3. Add DWORD.  Type in LivePreview_ms

    I'm using Windows 7 Home Premium 64 Bit.  It disables the Alt-Tab Peek, on my computer at least.

    Just one question.  Should the new DWORD entry named LivePreview_ms under the key AltTab be set at 0 for false?
    Tuesday, July 13, 2010 5:48 PM
  • I found this registry tweak on the web some time ago.

    1. Open regedit

    2. Navigate to: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab

    3. Add DWORD.  Type in LivePreview_ms

    I'm using Windows 7 Home Premium 64 Bit.  It disables the Alt-Tab Peek, on my computer at least.

    Just one question.  Should the new DWORD entry named LivePreview_ms  under the key AltTab  be set at 0 for false?

    Yes.  It should be 0.
    Wednesday, July 14, 2010 3:00 AM
  • I tried it and it works fine!  It also disables the Aero TaskBar button hover effect, but it still works for the lower right Desktop Peek button hover, as does Win-Tab.

    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
    "LivePreview_ms"=dword:00000000
    

    Note:  The usual warnings about editing the Registry apply here.

    • Edited by Brian Borg Wednesday, July 14, 2010 5:57 PM
    Wednesday, July 14, 2010 5:51 PM
  • Oh awesome! Glad I could help!
    Wednesday, July 14, 2010 5:54 PM
  • I was also annoyed with the Peek in the alt-tab menu, I liked it the old way where you can pause on any item for as long as you wish and nothing ever happens, no peek no switch, until you release Alt.

    I was able to get win7 RC1 (7100) to do this for me finally after looking all over many forums and not finding anything. Here is how:

    1) Go to System Properties (right click "Computer" in an explorer window and do properties)
    2) Click Advanced System Settings
    3) you should be on the Advanced Tab, in the performance section, click "Settings..."
    4) Uncheck "Enable Aero Peek"
    5) click OK     

    voila! back to normal, no more migraines! (I use alt-tab alot really quickly...) 

    (it also seems to make my system a bit more responsive, a bonus)

    -Agronqui

    This solution worked perfectly for me while having the problem of alt-tab not staying on top.

     

    Thank you for this solution :) 

    Saturday, March 19, 2011 5:59 PM
  • No, it should be set to the number of milliseconds that you want it to wait before the peek kicks in.  ("LivePreview_ms" = "Live Preview milliseconds"). I set mine to 3000 (in decimal) so that it waits 3 seconds before aero peek kicks in.
    Saturday, April 2, 2011 5:07 PM
  • JUST FYI, LivePreview_ms seems to have an upper limit of about 3s = 3000ms. Setting it to a higher value than that seems to have no effect. EG, try 60000 = 1 minute. Delay is still about 3s. I know it is working because if I set the value to 500ms, it goes almost instantly to 'peek'. I'm glad I can shut it off entirely by setting it to 0 (tested this). Testing done on Windows 7 64-bit SP1

    Thursday, May 5, 2011 11:27 PM
  • Thank you, thank you, thank you! I just bought a new computer and have spent the last 2 hours scrolling the internet, the wikipedia 'alt-tab' article, and Windows Help looking for how to fix this. It appears that it is no longer possible to disable the pesky 'aero peek' function via the Control Panel. But this method did the trick. Thank you!
    Tuesday, June 21, 2011 6:51 PM
  • This is perfect. I don't care for "cute" as much as efficiency.  

     

    Thanks Agronqui

    Monday, October 3, 2011 8:44 PM
  • Perfect. "LivePreview_ms"=dword:00000000 does it. Disabling Aero Peek for Alt-Tab makes it usable. I also found a nice tuning utility: http://winaero.com/comment.php?comment.news.5 that enlarges the thumbnails so you don't have to squint at them and figure what window is what. Still, the text in the new Aero Alt-Tab isn't very readable due to overuse of transparency. If you are annoyed that the Alt-tab puts the text separately from the icon, install http://www.ntwind.com/software/vistaswitcher.html that gives you a good looking Alt-Tab with Live thumbnails and readable text+icons.
    • Edited by xpclient Sunday, April 15, 2012 6:15 AM
    Sunday, April 15, 2012 6:14 AM
  • It looks like that works! ("LivePreview_ms"=dword:00000000) Yes! It stops the aero peek on Alt+Tab. And aero peek for applications on the task bar and desktop peek still works. However, I had to kill and restart Explorer (or reboot) to make it work. Just wanted to specify that.
    Friday, March 25, 2016 5:47 PM