locked
Managment Install Fails RRS feed

  • Question

  •  

    I am in the process of upgrading from SMS 2003 to SCCM. On a Secondary Site I removed SMS 2003 using Add/Remove Programs and installed SCCM by logging into the server and running the install locally.

     

    The install showed as successful, then I went to add a MP role to the server and receive these errors:

     

    SMSMP Setup Started....
    <08-28-2008 05:57:00> Parameters: C:\PROGRA~1\MICROS~3\bin\i386\ROLESE~1.EXE /install /siteserver:LA_BU_SMS SMSMP
    <08-28-2008 05:57:00> Installing Pre Reqs for SMSMP
    <08-28-2008 05:57:00>         ======== Installing Pre Reqs for Role SMSMP ========
    <08-28-2008 05:57:00> Found 1 Pre Reqs for Role SMSMP
    <08-28-2008 05:57:00> Pre Req MSXML60 found.
    <08-28-2008 05:57:00> MSXML60 already installed (Product Code: {0A869A65-8C94-4F7C-A5C7-972D3C8CED9E}). Would not install again.
    <08-28-2008 05:57:00> Pre Req MSXML60 is already installed. Skipping it.
    <08-28-2008 05:57:00>         ======== Completed Installion of Pre Reqs for Role SMSMP ========
    <08-28-2008 05:57:00> Installing the SMSMP
    <08-28-2008 05:57:00> Passed OS version check.
    <08-28-2008 05:57:00> IIS Service is installed.
    <08-28-2008 05:57:00> No versions of SMSMP are installed.  Installing new SMSMP.
    <08-28-2008 05:57:00> Enabling MSI logging.  mp.msi will log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log
    <08-28-2008 05:57:00> Installing C:\Program Files\Microsoft Configuration Manager\bin\i386\mp.msi CCMINSTALLDIR="C:\Program Files\SMS_CCM" CCMSERVERDATAROOT="C:\Program Files\Microsoft Configuration Manager" USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=0 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1
    <08-28-2008 05:57:15> mp.msi exited with return code: 1603
    <08-28-2008 05:57:15> Backing up C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log.LastError
    <08-28-2008 05:57:15> Fatal MSI Error - mp.msi could not be installed.
    <08-28-2008 05:57:23> ====================================================================
    <08-28-2008 05:57:23> SMSMP Setup Started....
    <08-28-2008 05:57:23> Parameters: C:\PROGRA~1\MICROS~3\bin\i386\ROLESE~1.EXE /install /siteserver:LA_BU_SMS SMSMP
    <08-28-2008 05:57:23> Installing Pre Reqs for SMSMP
    <08-28-2008 05:57:23>         ======== Installing Pre Reqs for Role SMSMP ========
    <08-28-2008 05:57:23> Found 1 Pre Reqs for Role SMSMP
    <08-28-2008 05:57:23> Pre Req MSXML60 found.
    <08-28-2008 05:57:23> MSXML60 already installed (Product Code: {0A869A65-8C94-4F7C-A5C7-972D3C8CED9E}). Would not install again.
    <08-28-2008 05:57:23> Pre Req MSXML60 is already installed. Skipping it.
    <08-28-2008 05:57:23>         ======== Completed Installion of Pre Reqs for Role SMSMP ========
    <08-28-2008 05:57:23> Installing the SMSMP
    <08-28-2008 05:57:23> Passed OS version check.
    <08-28-2008 05:57:23> IIS Service is installed.
    <08-28-2008 05:57:23> No versions of SMSMP are installed.  Installing new SMSMP.
    <08-28-2008 05:57:23> Enabling MSI logging.  mp.msi will log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log
    <08-28-2008 05:57:23> Installing C:\Program Files\Microsoft Configuration Manager\bin\i386\mp.msi CCMINSTALLDIR="C:\Program Files\SMS_CCM" CCMSERVERDATAROOT="C:\Program Files\Microsoft Configuration Manager" USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=0 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1
    <08-28-2008 05:57:34> mp.msi exited with return code: 1603
    <08-28-2008 05:57:34> Backing up C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log.LastError
    <08-28-2008 05:57:34> Fatal MSI Error - mp.msi could not be installed.
    <08-28-2008 05:57:42> ====================================================================
    <08-28-2008 05:57:42> SMSMP Setup Started....
    <08-28-2008 05:57:42> Parameters: C:\PROGRA~1\MICROS~3\bin\i386\ROLESE~1.EXE /install /siteserver:LA_BU_SMS SMSMP
    <08-28-2008 05:57:42> Installing Pre Reqs for SMSMP
    <08-28-2008 05:57:42>         ======== Installing Pre Reqs for Role SMSMP ========
    <08-28-2008 05:57:42> Found 1 Pre Reqs for Role SMSMP
    <08-28-2008 05:57:42> Pre Req MSXML60 found.
    <08-28-2008 05:57:42> MSXML60 already installed (Product Code: {0A869A65-8C94-4F7C-A5C7-972D3C8CED9E}). Would not install again.
    <08-28-2008 05:57:42> Pre Req MSXML60 is already installed. Skipping it.
    <08-28-2008 05:57:43>         ======== Completed Installion of Pre Reqs for Role SMSMP ========
    <08-28-2008 05:57:43> Installing the SMSMP
    <08-28-2008 05:57:43> Passed OS version check.
    <08-28-2008 05:57:43> IIS Service is installed.
    <08-28-2008 05:57:43> No versions of SMSMP are installed.  Installing new SMSMP.
    <08-28-2008 05:57:43> Enabling MSI logging.  mp.msi will log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log
    <08-28-2008 05:57:43> Installing C:\Program Files\Microsoft Configuration Manager\bin\i386\mp.msi CCMINSTALLDIR="C:\Program Files\SMS_CCM" CCMSERVERDATAROOT="C:\Program Files\Microsoft Configuration Manager" USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=0 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1
    <08-28-2008 05:57:53> mp.msi exited with return code: 1603
    <08-28-2008 05:57:53> Backing up C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log.LastError
    <08-28-2008 05:57:53> Fatal MSI Error - mp.msi could not be installed.
    <08-28-2008 05:59:18> ====================================================================
    <08-28-2008 05:59:18> SMSMP Setup Started....
    <08-28-2008 05:59:18> Parameters: C:\PROGRA~1\MICROS~3\bin\i386\ROLESE~1.EXE /install /siteserver:LA_BU_SMS SMSMP
    <08-28-2008 05:59:18> Installing Pre Reqs for SMSMP
    <08-28-2008 05:59:18>         ======== Installing Pre Reqs for Role SMSMP ========
    <08-28-2008 05:59:18> Found 1 Pre Reqs for Role SMSMP
    <08-28-2008 05:59:18> Pre Req MSXML60 found.
    <08-28-2008 05:59:18> MSXML60 already installed (Product Code: {0A869A65-8C94-4F7C-A5C7-972D3C8CED9E}). Would not install again.
    <08-28-2008 05:59:18> Pre Req MSXML60 is already installed. Skipping it.
    <08-28-2008 05:59:18>         ======== Completed Installion of Pre Reqs for Role SMSMP ========
    <08-28-2008 05:59:18> Installing the SMSMP
    <08-28-2008 05:59:18> Passed OS version check.
    <08-28-2008 05:59:18> IIS Service is installed.
    <08-28-2008 05:59:18> No versions of SMSMP are installed.  Installing new SMSMP.
    <08-28-2008 05:59:18> Enabling MSI logging.  mp.msi will log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log
    <08-28-2008 05:59:18> Installing C:\Program Files\Microsoft Configuration Manager\bin\i386\mp.msi CCMINSTALLDIR="C:\Program Files\SMS_CCM" CCMSERVERDATAROOT="C:\Program Files\Microsoft Configuration Manager" USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=0 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1
    <08-28-2008 05:59:28> mp.msi exited with return code: 1603
    <08-28-2008 05:59:28> Backing up C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log.LastError
    <08-28-2008 05:59:28> Fatal MSI Error - mp.msi could not be installed.

     

     

    I also noticed that in the "Site Systems Status" that the disply pane is empty, it does not show any Shares created in the Storage Object column or any roles in the Roles column.

    Thursday, August 28, 2008 1:27 PM

Answers

  • No, you can't install locally, only through the console. That's why I was asking, you should NOT try it locally.

     

    My only other suggestion (outside contacting product support) would be to set up a different box (IIS, BITS Server Extensions, WebDAV) and try to make it a MP to see if that works.

    • Marked as answer by Garth JonesMVP Saturday, December 19, 2015 8:21 PM
    Tuesday, September 2, 2008 5:52 PM

All replies

  • You need to look at the log specified in the log to see what the issue is:

     

    mp.msi exited with return code: 1603
    Backing up C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log.LastError
    Fatal MSI Error - mp.msi could not be installed.

    1603 is a generic Windows Installer failure. So you need to look at the MPmsi.log (or the LastError version of it) to see what the error is. Search for "return value 3" (without the quotes) and just above that should be the error.

    Thursday, August 28, 2008 11:10 PM
  • Thanks for the info Wally,

    Here is a snippet from the mpMSI.log.last error.

     

     

    MSI (s) (7C:18) [03:37:03:937]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI1790.tmp, Entrypoint: CcmCreateIISVirtualDirectoriesInit
    Action start 3:37:03: CcmCreateIISVirtualDirectoriesInit.
    [3:37:04] Component Flag for Upgrade Code [{ABD0F60F-1622-4311-8989-106B60D784FF}] is 1
    [3:37:04] Queuing IIS virtual directory 'CcmClientRedistDir.BFC13682_FB8F_4455_9724_4DDBBBF713D7'
    [3:37:04] Queuing IIS virtual directory 'CcmIncomingVDir.BFC13682_FB8F_4455_9724_4DDBBBF713D7'
    [3:37:04] Queuing IIS virtual directory 'CcmOutgoingVDir.BFC13682_FB8F_4455_9724_4DDBBBF713D7'
    [3:37:04] Queuing IIS virtual directory 'CcmSystemVDir.8D24F0F7_99DC_460C_9DA6_4193612E0D59'
    [3:37:04] Queuing IIS virtual directory 'CcmSystemRegVDir.8D24F0F7_99DC_460C_9DA6_4193612E0D59'
    [3:37:04] Component 'CcmIsapi_AltAuth.8D24F0F7_99DC_460C_9DA6_4193612E0D59' is not being updated.
    [3:37:04] Component 'CcmIsapiIA64.181B4E66_9269_4E84_9E55_B6E7B91A7472' is not being updated.
    [3:37:04] Component 'CcmIsapi_WindowsAuthIA64.181B4E66_9269_4E84_9E55_B6E7B91A7472' is not being updated.
    [3:37:04] Component 'CcmIsapi_AltAuthX64.181B4E66_9269_4E84_9E55_B6E7B91A7472' is not being updated.
    [3:37:04] Component 'CcmIsapiAMD64.6E186A08_E33E_4FBC_A39A_E3456945465F' is not being updated.
    [3:37:04] Component 'CcmIsapi_WindowsAuthAMD64.6E186A08_E33E_4FBC_A39A_E3456945465F' is not being updated.
    [3:37:04] Component 'CcmIsapi_AltAuthAMD64.6E186A08_E33E_4FBC_A39A_E3456945465F' is not being updated.
    [3:37:04] Queuing IIS virtual directory 'SMS_MP.67022EC1_A401_46E9_91FC_2DF2ED04CF15'
    [3:37:04] Component 'VDirAltAuth.67022EC1_A401_46E9_91FC_2DF2ED04CF15' is not being updated.
    [3:37:04] Component 'VDirX64.0A840968_9A21_4DA4_A2B3_06C6AEAA2EC9' is not being updated.
    [3:37:04] Component 'VDirAltAuthX64.0A840968_9A21_4DA4_A2B3_06C6AEAA2EC9' is not being updated.
    [3:37:04] Component 'VDirIA64.41483201_CB1F_4581_8423_CA84BCFA8A59' is not being updated.
    MSI (s) (7C!24) [03:37:04:187]: PROPERTY CHANGE: Adding CcmRollbackIISVirtualDirectories property. Its value is 'SMS Management Point
    0
    IIS://LocalHost/W3SVC/1
    IIS://LocalHost/W3SVC/1
    MPCWSPath
    1
    true

    true


    '.
    MSI (s) (7C!24) [03:37:04:187]: Doing action: CcmRollbackIISVirtualDirectories
    [3:37:04] Component 'VDirAltAuthIA64.41483201_CB1F_4581_8423_CA84BCFA8A59' is not being updated.
    Action start 3:37:04: CcmRollbackIISVirtualDirectories.
    MSI (s) (7C!24) [03:37:04:202]: PROPERTY CHANGE: Adding CcmCreateIISVirtualDirectories property. Its value is 'SMS Management Point
    0
    IIS://LocalHost/W3SVC/1
    IIS://LocalHost/W3SVC/1
    MPCWSPath
    1
    TRUE
    80
    TRUE
    443
    0
    CCM_CLIENT,,C:\Program Files\Microsoft Configuration Manager\Client,N
    BEGIN PROPERTY
    AccessExecute
    boolean
    false
    AccessRead
    boolean
    true
    AccessSSL
    boolean
    false
    AccessSSLNegotiateCert
    boolean
    false
    AccessSSLRequireCert
    boolean
    false
    AppIsolated
    long
    1
    AppPoolId
    string
    CCM Client Deployment Pool
    AuthAnonymous
    boolean
    true
    ContentIndexed
    boolean
    false
    EnableDefaultDoc
    boolean
    false
    EnableDirBrowsing
    boolean
    true
    END PROPERTY
    BEGIN SCRIPTMAP
    END SCRIPTMAP

    CCM_Incoming,,C:\Program Files\Microsoft Configuration Manager\CCM\Incoming,Y
    BEGIN PROPERTY
    AccessExecute
    boolean
    false
    AccessRead
    boolean
    false
    AccessSSL
    boolean
    false
    AccessSSLNegotiateCert
    boolean
    false
    AccessSSLRequireCert
    boolean
    false
    AppIsolated
    long
    1
    AppPoolId
    string
    CCM Server Framework Pool
    AuthAnonymous
    boolean
    true
    ContentIndexed
    boolean
    false
    EnableDefaultDoc
    boolean
    false
    EnableDirBrowsing
    boolean
    false
    END P
    MSI (s) (7C!24) [03:37:04:202]: Doing action: CcmCreateIISVirtualDirectories
    Action ended 3:37:04: CcmRollbackIISVirtualDirectories. Return value 1.
    Action start 3:37:04: CcmCreateIISVirtualDirectories.
    Action ended 3:37:04: CcmCreateIISVirtualDirectories. Return value 1.
    MSI (s) (7C:50) [03:37:04:218]: Doing action: RegisterUser
    Action ended 3:37:04: CcmCreateIISVirtualDirectoriesInit. Return value 1.
    Action start 3:37:04: RegisterUser.
    MSI (s) (7C:50) [03:37:04:218]: Doing action: CcmFixupServiceConfigInit
    Action ended 3:37:04: RegisterUser. Return value 1.
    MSI (s) (7C:10) [03:37:04:265]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI1791.tmp, Entrypoint: CcmFixupServiceConfigInit
    Action start 3:37:04: CcmFixupServiceConfigInit.
    [3:37:04] ERROR: Failed to cache service configuration (80070002)
    [3:37:04] @@ERR:25001
    MSI (s) (7C!3C) [03:37:04:749]: Product: SMS Management Point -- Error 25001. Setup failed due to unexpected circumstances
    The error code is 80070002

    Error 25001. Setup failed due to unexpected circumstances
    The error code is 80070002
    MSI (s) (7C:50) [03:37:04:749]: Machine policy value 'DisableRollback' is 0
    MSI (s) (7C:50) [03:37:04:749]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
    Action ended 3:37:04: CcmFixupServiceConfigInit. Return value 3.
    MSI (s) (7C:50) [03:37:04:749]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
    MSI (s) (7C:50) [03:37:04:749]: No System Restore sequence number for this installation.
    MSI (s) (7C:50) [03:37:04:749]: Unlocking Server
    Action ended 3:37:04: INSTALL. Return value 3.

     

    Tuesday, September 2, 2008 12:08 PM
  • Well, as stated in the previous response, you search for 'return value 3' and just above it is the error code. You have the return value 3 at the very bottom of the log, and the error lines are:

     

    [3:37:04] ERROR: Failed to cache service configuration (80070002)
    [3:37:04] @@ERR:25001
    MSI (s) (7C!3C) [03:37:04:749]: Product: SMS Management Point -- Error 25001. Setup failed due to unexpected circumstances
    The error code is 80070002

    Error 25001. Setup failed due to unexpected circumstances
    The error code is 80070002

    Error code 80070002 (which you can easily look up in the Configuration Manager version of SMS Trace) is "The system cannot find the file specified".

     

    Unforunately, it does not indicate the file that it cannot find. But there is some file we're looking for that we can't find, thus can't set up the management point. Are you installing locally, or through the console?

    Tuesday, September 2, 2008 5:39 PM
  • I am attempting to install through the console, I haven't tried to install locally, would it be as easy as copying over the install files and executing the mp.msi file?

     

     

     

    Tuesday, September 2, 2008 5:50 PM
  • No, you can't install locally, only through the console. That's why I was asking, you should NOT try it locally.

     

    My only other suggestion (outside contacting product support) would be to set up a different box (IIS, BITS Server Extensions, WebDAV) and try to make it a MP to see if that works.

    • Marked as answer by Garth JonesMVP Saturday, December 19, 2015 8:21 PM
    Tuesday, September 2, 2008 5:52 PM
  • - try deleting the hklm/software/microsoft/ole key, import it fom a good machine, reboot the problem machine and try the install again.

     

    NOTE: Please backup of registry

    Wednesday, June 23, 2010 2:49 PM