On Windows 2008 R2, Sysprep cannot run on a computer that has been upgraded to a new version of windows. you can only run Sysprep on a custom (cliean) install version of windows.


  • After cloned a VM with created a new SID on vCenter, by psgetsid I found both of cloing VM and cloned VM have same SID. Here, I am not sure whether psgetsid can work with wi2008R2 fine or not. I tried to use Sysprep to have a new sid on the cloned VM. then, I got the error message as the title.

    In fact, after another VM with exactly version cloned to another VM, the new cloned VM can work with Sysprep. Also, I copy the Sysprep folder from the succeed VM to the issued VM, run it on the issued VM and got same error message. 

    Their OS versions on both are same: 6.1.7601 service pack1 Build 7601

    Both BIOSs are same

    Both Hardware abstraction layers are same: "6.1.7601.17514"

    Only I can see the differences on both are in update history:

    On the issued VM, update is from 3/12/20013 to 11/8/2013. on the succeed VM, update is from 24/10/20013 to 8/11/2013. It made me confused that issued VM even had less update than succeed VM had.

    How can I fix the issue or where can find new Sysprep for the issued VM?

    much thank in advance!



    Monday, November 11, 2013 8:19 PM