none
ZTI error opening SQL Connection but with udl-file connection succeeds RRS feed

  • Question

  • Hi,

    I have this server on which runs MDT 2013 with an SQL Server Express 2012 database. I configured the DB to use Named Pipes. This has worked and has been tested a month ago and now when trying a new deployment on a test pc I'm having this BDD-error : ZTI Error opening SQL Connection [DBNETLIB] (ConnectionOpen (Connect)). SQL Server does not exist or access denied. I checked the SQL-services and they are running. I did reboot the server. I tried it with the firewall off. Still getting this missing or denied message. Last thing I did on the test pc was an F8 to open a DOS box  and creating an udl-file which I launched. I filled in the servername and the SQL User credentials and I was able to select the MDT database. I got the message "Connection Succeeded". So now I'm a bit baffled. WinPE clearly as all the correct parameters (I can see them in the BDD.log) and the udl-file can make a connection to the SQL-DB but still I got this error message. Any suggestions????

    Paul


    • Edited by KZen Muug Wednesday, April 22, 2015 10:10 AM
    Wednesday, April 22, 2015 10:10 AM

Answers

  • We'll never know what happened.... but everything is working like a charm now. I changed from Named Pipes to TCP/IP Sockets and all is well. And I'm quite sure it'll still work if I change back to Named Pipes..... you know, sometimes you have to "shake the tree", you know, change a setting, save it, change and save it back again and suddenly the system rediscovers the setting....
    • Marked as answer by KZen Muug Thursday, April 23, 2015 11:13 AM
    Thursday, April 23, 2015 11:13 AM