locked
I cannot open command line in libraries! RRS feed

  • Question

  • My issue is that I use frequently the Shift + Right click -> Open command window here function, and in Explorer if I browse a library and press Shift + Right click the option doesn't appear. This doesn't happen if I browse the normal way (i.e. starting from My Computer).
    I believe this is a bug, there's no reason why the option shouldn't be available. If you are in the root of a library then it's obviously shouldn't be there since it isn't an actual folder, but after you click trough a folder why doesn't it work?
    I don't know where to report such a thing for Microsoft so I hope here somebody will notice it and maybe fix this.
    Thursday, July 7, 2011 6:40 PM

Answers

  • The "Open command window from here" context menu item is only available for a folder (including a Library folder, but not the library itself), or drive in Windows Explorer, Navigation Pane, and on the Desktop.
    Also remember that "Open command window from here" context menu item opens a normal command prompt, not an elevated one.

    Bye.


    Luigi Bruno
    • Marked as answer by Cloud_TS Sunday, July 24, 2011 1:08 PM
    Thursday, July 7, 2011 9:38 PM
  • Hi sekmet64,

    The option can be added using a registry edit, but where would you like the Command Prompt to open (which directory path?) by default?


    Ramesh Srinivasan | The Winhelponline Blog
    Microsoft MVP, Windows Desktop Experience
    • Marked as answer by Cloud_TS Sunday, July 24, 2011 1:08 PM
    Saturday, July 9, 2011 3:49 AM
    Answerer

All replies

  • The "Open command window from here" context menu item is only available for a folder (including a Library folder, but not the library itself), or drive in Windows Explorer, Navigation Pane, and on the Desktop.
    Also remember that "Open command window from here" context menu item opens a normal command prompt, not an elevated one.

    Bye.


    Luigi Bruno
    • Marked as answer by Cloud_TS Sunday, July 24, 2011 1:08 PM
    Thursday, July 7, 2011 9:38 PM
  • Hi sekmet64,

    The option can be added using a registry edit, but where would you like the Command Prompt to open (which directory path?) by default?


    Ramesh Srinivasan | The Winhelponline Blog
    Microsoft MVP, Windows Desktop Experience
    • Marked as answer by Cloud_TS Sunday, July 24, 2011 1:08 PM
    Saturday, July 9, 2011 3:49 AM
    Answerer
  • I found a way to do it just now. I'll post it here, since I've come across this thread several times before while trying to find a solution, so hopefully the next guy won't have to wonder. (Why on earth is this thread marked as answered, by the way?)

     

    You just have to add a few registry keys:

    HKEY_CLASSES_ROOT\LibraryFolder\background\shell

    HKEY_CLASSES_ROOT\LibraryFolder\background\shell\cmd (set value to what you want to be displayed on the right click menu, e.g. "Open command window here"

    HKEY_CLASSES_ROOT\LibraryFolder\background\shell\cmd\command (set value to "cmd.exe /k")

     

    If you're not familiar with the registry editor, you can just copy the following text into Notepad, save it as whatever.reg, and double click it:

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\LibraryFolder\background\shell\cmd]
    @="Open command window here"

    [HKEY_CLASSES_ROOT\LibraryFolder\background\shell\cmd\command]
    @="cmd.exe /k"

     

    • Proposed as answer by Adamaer Wednesday, June 20, 2012 2:46 PM
    Sunday, December 18, 2011 9:24 PM
  • The registry modification listed by megadanno works for me, but I was wondering what the reasoning is for now allowing the "Open command window here" dialog to show up for Library folders like other folders.

    In my mind, if I can open a cmd.exe and then cd to the \Users\<username>\Documents folder, then it makes perfect sense to also be able to shift-right click and open a command prompt in that folder from explorer.

    I'd prefer not to have to make a registry modification to get this extremely useful functionality.

    Wednesday, October 17, 2012 12:50 PM
  • This is the real answer. Well, the real answer is that this is a bug that should be fixed. 
    Monday, December 9, 2013 8:03 PM