locked
OneDrive for SharePoint 2019 RRS feed

  • Question

  • Hello Experts,

    As everyone know, MS SharePoint server 2019 Preview is available, and mentioned that it will support new generation sync client with onedrive for business. So we have Configured SP 2019 for testing the Onedrive with new OneDrive setup, however we are unable to sync with client. below error screen for ref. did anyone face the same issue.

    appreciate your help here.

    Regards,

    Vinay

    Monday, August 6, 2018 4:59 AM

All replies

  • Problems here too...

    I have created 2 farms. One of which I have not yet gotten this feature to work at all. The error message pops up: "We don't support syncing SharePoint on-premise folders".

    The other farm will only work when I right click onto the OneDrive icon and then click on "Sync a new library". I also have to open the library with windows explorer too before I enter the URL and then all is okay.

    If I try to sync the same library (even after setting up the URL) using the modern view, I get the same error as above. If I try syncing using the classic experience, then I get the setup screen for OneDrive, with my domain account already entered to sign in. I click on "sign in", then it leads me to a new screen, saying "There was a problem connecting to OneDrive". I could from this screen choose "Personal" or "Work or school". Of course choosing "Work or school" leads to the actual Office 365 OneDrive login. Clicking on "Personal" leads to a popup saying "Getting ready to sync", but never goes away, assuming since it error out beforehand. 

    OneDrive WebApp is setup and user does have a site created within the app. 
    • Edited by mejohnm Monday, August 6, 2018 9:10 AM edit
    Monday, August 6, 2018 9:06 AM
  • Hi,

    The sync client currently supports only NTLM. So if you are using any authentication methods apart from NTLM sync wont work. Also please make sure you set up the GPO as per the documentation here: https://docs.microsoft.com/en-us/sharepoint/install/new-onedrive-sync-client


    Jithin Joseph [MSFT] | SharePoint Technologies

    Monday, August 6, 2018 5:58 PM
  • Thanks Jithin,

    Let me check this and update here soon.

    Regards,

    Vinay

    Tuesday, August 7, 2018 7:09 AM
  • As of right now, this is a flighted feature that will need to be enabled with the latest version of the sync client. I believe our public documentation will be coming out very soon detailing  these steps. However, in the meantime please confirm your client version?


    Mike Lee

    Tuesday, August 7, 2018 2:26 PM
  • Did you see the document that Jithin provided Configure syncing with the new OneDrive sync client?

    The steps provide a zip file in the requirements section to enable to required flight feature.

    Here is the reg key mentioned:


    1. Opt-In to ensure the on-prem features are enabled.

     

    HKCU\SOFTWARE\Microsoft\OneDrive\EnableTeamTier_Internal=1

     

    2.       To make the change take place immediately, delete the JSON file

     

    del /a "%localAppData%\Microsoft\OneDrive\settings\PreSignInSettingsConfig.json"

     

    3.       Then kill "OneDrive.exe" and restart the client.

    Also, please make sure you configure the group policies required for on-prem.

    Can you try this and let us know?


    Mike Lee


    Tuesday, August 7, 2018 5:30 PM
  • We have done with the steps mentioned here and installed latest version of OneDrive .

    So when we click sync option from sharepoint site by using the latest OneDrive, it will ask for sign in details for OneDrive. I had given my domain account there because, while syncing with classic experience  domain account get already signed in and i cant edit from there. So after syncing it will show like some problem with connecting to OneDrive, and we have to choose "personal" or "work or school account". I clicked Personal account. After that it will show getting ready to sync but nothing happens.

    Regards,

    Shanid



    Friday, August 10, 2018 4:59 AM
  • Did you apply the group policies?

    1 Configure Local polices:

    a. Navigate to %localappdata%\Microsoft\OneDrive\build#\adm.

    b. Copy the *.admx files to your %windir%\PolicyDefinitions directory.

    c. Copy the *.adml files to your %windir%\PolicyDefinition\en-US directory.

    d. Launch Group Policy Editor (GPEdit.msc).

    e. In the left pane, navigate to Local Computer Policy – Computer Configuration – Administrative Templates – OneDrive.

    f. In the right pane, double click on SharePoint on-premises Server URL.

    g. In the dialog that opens, click the Enabled radio button (instead of Not Configured).

    h. In the Options pane (lower left), put the URL of a SharePoint Server 2019 web application in the edit box.

    For example: http://spwfe  

    i. Enable the SharePoint prioritization setting and prioritize the on-premises SharePoint Server.

    j. Set, “Prioritize syncing a user’s OneDrive for Business personal sites with SharePoint on-premise sever.”

    k. Press OK to apply the policy.

    2. Run “GPUPDATE /Force”

    3. Run the following commands to check settings.

    reg.exe query HKLM\Software\Policies\Microsoft\OneDrive /v SharePointOnPremFrontDoorUrl
    reg.exe query HKLM\Software\Policies\Microsoft\OneDrive /v SharePointOnPremPrioritization

    Also, check the OneDrive Setting files to ensure the flight in enabled.

    findstr /m /i /r "{.id.:30,.offset.:0,.share.:100}" "%localAppData%\Microsoft\OneDrive\settings\PreSignInSettingsConfig.json"

    Does the above command return the file?

    Your local server should prompt you for a password.

    Example:


    Mike Lee

    Friday, August 10, 2018 1:34 PM
  • I have been following your steps but I still don't get the login prompt to the local server.

    The OneDrive client re-directs the authentication to Office 365.

    Is there any way to troubleshoot this some more?
    • Edited by S_Larsson Monday, August 13, 2018 9:02 AM
    Monday, August 13, 2018 9:02 AM
  • Did you check the OneDrive Setting files to ensure the flight in enabled?

    findstr /m /i /r "{.id.:30,.offset.:0,.share.:100}" "%localAppData%\Microsoft\OneDrive\settings\PreSignInSettingsConfig.json"

    Does the above command return the file?

    It should look like this:


    Mike Lee

    Monday, August 13, 2018 3:06 PM
  • I did but unfortunately that didn't help.

    However, I managed to solve it.

    Turns out you need to specify the web application URL for the "My Site"-site collection and not the default SharePoint site collection when you configure the GPO.

    So after I had updated the GPO with the right port (I have the same name on both web applications, but different ports) it started to work.

    Hope someone else finds this useful, and maybe this should be specified in the documentation.
    • Proposed as answer by S_Larsson Tuesday, August 14, 2018 7:44 AM
    • Unproposed as answer by S_Larsson Tuesday, August 14, 2018 11:19 AM
    Tuesday, August 14, 2018 7:44 AM
  • Mike, we have performed all the steps you mentioned above.

    S_Larsson, i have mentioned the Webapp url of mysite however still the issue persist. when i sync its ask me personal and work or school account, i have clicked on personal after that nothing happens,

    Anything i am missing. below is screen.

    Tuesday, August 14, 2018 10:55 AM
  • Mike, we have performed all the steps you mentioned above.

    S_Larsson, i have mentioned the Webapp url of mysite however still the issue persist. when i sync its ask me personal and work or school account, i have clicked on personal after that nothing happens,

    Anything i am missing. below is screen.

    I don't think that you should configure OneDrive for Personal users. Shouldn't it be Work/School account that is linked to the domain users?
    Tuesday, August 14, 2018 11:16 AM
  • Did you add your on-prem mysite site to the synced accounts in the OneDrive client?  http://2019.local:90 <-  is that your mysite web app?  If so, once you add this to your accounts in OneDrive, you should be prompted by your local server for domain creds. I believe once you do this, the sync button should work for document libraries.

    Mike Lee

    Tuesday, August 14, 2018 3:21 PM
  • i meant, once the onedrive wizad opens its ask for login once we clicked on login, its ask me two option one personal and second work or school account. if i click on personal nothing happens. if i click work or school its navigate to office 365 page.

    Thursday, August 23, 2018 6:23 AM
  • Hi Mike,

    yes its "http://2019.local:90" i have added this url to shrepoint on prem URL setting and set up Prioritize to sharepoint onprem server. however no luck.

    Thursday, August 23, 2018 6:27 AM
  • attaching policy details below,
    Thursday, August 23, 2018 6:50 AM
  • Are you ever seeing the local logon prompt like the screen shot I provided above? Did you confirm that NTLM was being used?

    Mike Lee

    Thursday, August 23, 2018 3:07 PM
  • No, its not prompted any login screen. i have followed your steps as it is

    Wednesday, September 12, 2018 8:57 AM
  • Can you confirm your Auth type on the problematic web app?

    Mike Lee

    Wednesday, September 12, 2018 5:47 PM
  • I have the same sync issue. the

    findstr /m /i /r "{.id.:30,.offset.:0,.share.:100}" "%localAppData%\Microsoft\OneDrive\settings\PreSignInSettingsConfig.json"

    is not returning the file in my case, what could be the issue? That json file exists there and Im using NTLM   authentication.


    -Mash "http://sharepointxperiments.wordpress.com"

    Wednesday, January 9, 2019 4:56 PM
  • Also in the json, we are seeing the value set to {"id":30,"offset":0,"share":50} instead of {"id":30,"offset":0,"share":100}. when we manually overwrite it, we are successful. Why does the json not having an updated value to support SP19? Any ideas?

    -Mash "http://sharepointxperiments.wordpress.com"

    Thursday, January 10, 2019 10:02 PM
  • This means the Internal Tier flight is not enabled.

    1. Opt-In to ensure the on-prem features are enabled.

     

    HKCU\SOFTWARE\Microsoft\OneDrive\EnableTeamTier_Internal=1

     

    2.       To make the change take place immediately, delete the JSON file

     

    del /a "%localAppData%\Microsoft\OneDrive\settings\PreSignInSettingsConfig.json"

     

    3.       Then kill "OneDrive.exe" and restart the client.


    Mike Lee

    Friday, January 11, 2019 7:02 PM
  • Hi MIke,

    The above steps helped for NTLM. We are trying the One Drive sync from a web application configured for custom claims provider, is that not supported?


    -Mash "http://sharepointxperiments.wordpress.com"

    Wednesday, January 30, 2019 9:17 PM
  • Right now the only supported Auth types are NTML and Kerberos. SAML support is on the road map but not in the product at the moment.

    Mike Lee

    Tuesday, February 5, 2019 8:05 PM
  • Hi MIke,

    I got the prompt like above to enter domain credentials and after entering I am getting error like below.

    Below snap is ref to enter domain credentials.

    Can you please reply on this?

    Regards,

    Shanid



    • Edited by Shanid E Friday, March 29, 2019 4:58 AM
    Friday, March 29, 2019 4:54 AM