none
Sample Reports loosing their FQDN, and will not open - any thing to check? RRS feed

Answers

  • I agree to you. Keep the default name, follow the action plan below.

    I believe that the Secure store service is not configured appropriately after the secure store service application recreation.

    Click the link for the Secure Store Service Application from Manage Service Applications page.

    Click Generate New Key. Enter a PassPhrase1. Click OK.

    Click New and enter the following information:

               Target Application ID: ProjectServerApplication (this is the required value, no customization allowed)

               Dispaly Name: ProjectServerApplication

               Contact E-mail: abcd@efgh.com

               Traget Application Type: Group

    Click Next.Accept the defaults and click Next

    Target Application Administrators: The Farm Admin account has access by default.  Add the necessary accounts for extra measure.

    Members: Enter the AD Groups that will be authoring and/or reading reports; ReportAuthors and ReportReaders. Click OK.

    Click Set Credentials
    Enter the information for the FarmAdmin and click OK


    Cheers. Happy troubleshooting !!! Sriram E - MSFT Enterprise Project Management
    Tuesday, September 7, 2010 2:05 AM
    Moderator

All replies

  • Hi Christophe, thanks for the prompt reply.

    I had just started reading that post whilst wondering what else to try.

    going to try the recommendation.

    Thursday, August 26, 2010 10:13 PM
  • Managed to create a different error message this time (having deleted, and recreated the BI site):

    "An error occurred while accessing application id ProjectServerApplication from Secure Store Service. The following connections failed to refresh Project Server - Project and Task Data"

    Sounds like I need to re-set/refresh the SSS.

    Would that be the right area to start?

    Thursday, August 26, 2010 10:18 PM
  • Yes indeed, give it a try and keep us posted
    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Friday, August 27, 2010 5:21 AM
  • Done some more digging, and found that the data connections were not pointing to the project server application (the default name was not used).

    So now I have modified all of the SSS settings in Excel, and updated the connections library.

    Now I get a new error -

    "08/31/2010 13:08:03.31  w3wp.exe (0x1710)                        0x1D90 Secure Store Service           Secure Store                   7493 Critical The Microsoft Secure Store Service application Secure Store Service failed to retrieve credentials. The error returned was 'Credentials were not found for the current user within the target application 'ProjectServiceAppl'. Please set the credentials for the current user.'. For more information, see the Microsoft SharePoint Products and Technologies Software Development Kit (SDK). f18e75f3-f97c-4554-bece-bf50cdf5edec

    I have tried all searches I can think of, and checked the user credentials in the Secure Store, and the DB access.

    Any suggestions for a good starting point to investigate or fix this?`

     

    Thanks, David.

    Tuesday, August 31, 2010 11:51 AM
  • What ID did you use when you configured Sercure Store Services? (it needs to be the same ID used in the reports) in your care you need a SSS with 'ProjectServiceAppl'
    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Tuesday, August 31, 2010 4:21 PM
  • Agree with your comment, the SSS is using 'ProjectServiceAppl' (just logged on to double check)
    Tuesday, August 31, 2010 9:51 PM
  • OK and Excel Services is configured to use that Application ID (Central Admin -> Excel Services Application Settings)? see this: http://technet.microsoft.com/en-us/library/ff191191.aspx, also make sure the Application ID in the ODC is the same
    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Tuesday, August 31, 2010 10:32 PM
  • Hi Christophe,

    once again, thanks for the fast reply.  I did another double check, that the Application ID in excel services, the secure store, and the ODC files for all of the sample reports says the same thing.

    The ULS seems to point to an authentication issue for credentials.  (And the event log is pointing to the same issue).

    Is there anything else to check in terms of authentication?

    I have done some more searching, and some posts have mentioned that its not a good idea to have a "custom" name for the Project Server Application service - i.e. best to keep it as ProjectServerApplication.  If this is the case, it might just be easier to remove the application, and recreate it, reconnecting to the original site dbs.

    David

    Wednesday, September 1, 2010 8:41 PM
  • David:

    Based on the last error, I think you need to delete the Secure Store Service Target Applicaiton and The Secure Service Application and start over with creating these.


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG
    Wednesday, September 1, 2010 9:45 PM
    Moderator
  • thanks gary - will try your recommendation and report back
    Thursday, September 2, 2010 8:41 PM
  • Hi Gary - does this also imply that it is not a good idea to use a different Project Server Application Name other than "ProjectServerApllication" - i.e. we should set it up again, but this time with the name that matches the Sample reports etc.

    I don't want to risk getting back to exactly the same position I am in now.

     

    Sunday, September 5, 2010 9:12 PM
  • I agree to you. Keep the default name, follow the action plan below.

    I believe that the Secure store service is not configured appropriately after the secure store service application recreation.

    Click the link for the Secure Store Service Application from Manage Service Applications page.

    Click Generate New Key. Enter a PassPhrase1. Click OK.

    Click New and enter the following information:

               Target Application ID: ProjectServerApplication (this is the required value, no customization allowed)

               Dispaly Name: ProjectServerApplication

               Contact E-mail: abcd@efgh.com

               Traget Application Type: Group

    Click Next.Accept the defaults and click Next

    Target Application Administrators: The Farm Admin account has access by default.  Add the necessary accounts for extra measure.

    Members: Enter the AD Groups that will be authoring and/or reading reports; ReportAuthors and ReportReaders. Click OK.

    Click Set Credentials
    Enter the information for the FarmAdmin and click OK


    Cheers. Happy troubleshooting !!! Sriram E - MSFT Enterprise Project Management
    Tuesday, September 7, 2010 2:05 AM
    Moderator