locked
Windows 10 File Permission Issues RRS feed

  • Question

  • Well.... Crap.

    He we are again...

    Okay: workflow... 

    Had a windows 10 PC that was upgraded from 7 then clean installed to fresh Win 10 64 bit.

    Had a secondary drive that I keep all my personal files on that I added to this machine from the windows 7. I have to take control of all the files on that drive in order to access them but everything seems to work okay.

    Today I want to upgrade to a new laptop now.

    I open HP laptop from box. It has windows 7 pro 64. I run updates then I let it upgrade to windows 10. After that I pull HDD and put in New SSD and run clean install of Win 10.

    Everything fine so far...

    Next I put in a 1TB spinner and I copy all my personal files from an external drive bay with my old drive in it to the new computer's 1TB spinner.

    Well the files that were originally on the personal HD from the windows 7 pc copied fine. The files that I created on that drive while using windows 10 are now giving me access denied, no read, no write no copy to new HDD issues.

    I have tried TAKEOWN and it reports SUCCESS but I assure you, it is not SUCCESS.

    How do take control of these files so I can access and copy them?

    They are on a HDD in a USB external drive bay.

    Thanks,

    James

    EDIT: After some more searching, I find it ridiculous that there are programs out there that are written specifically for this... They are not MS programs so I am not much interested in them...


    I Guess ICACLS is the way to go. I just found this after some more searching.

    • Edited by So noob Sunday, January 17, 2016 5:03 PM
    Sunday, January 17, 2016 4:28 PM

Answers

  • ICACLS did the trick.

    I just ran it recursive on the whole drive.

    Worked like a charm.

    • Marked as answer by So noob Sunday, January 17, 2016 5:46 PM
    Sunday, January 17, 2016 5:46 PM