locked
Windows 7 doesn't recognize my USB devices. RRS feed

  • Question

  • Help me. My Windows 7 doesn't recognize my USB devices. I've overlooked the problem for a while now but I got a new Android phone and I'm having the same problem and its pissing me off.  HTC Wildfire S. It doesn't install. 

     

    If I use VMWare it works properly here's what it showed in VMWare.

    http://i.stack.imgur.com/WA5IE.gif

    But here's what happens in device manager on my windows 7 on the same computer

    http://i.stack.imgur.com/7DNkz.gif

     

    Please help this happens on all new USB devices, but my old ones work. I've tried everything from google. Copying .inf files, I've even uninstalled VMWARE. I've done SFC/SCANNOW. Restarted, downloaded all drivers. Please help me.

    I've tried device manager -> scan new hardware changes -> But I'm stuck at "windows found drivers for your hardware but encountered errors when trying to install it". Is this a permission issue?

     

     

    Here's event log data if it is necessary

     

    Fault bucket 1837506052, type 5

    Event Name: PnPDriverNotFound

    Response: Not available

    Cab Id: 0

     

    Problem signature:

    P1: x64

    P2: USB\VID_0BB4&PID_0CB0&REV_0226

    P3: 

    P4: 

    P5: 

    P6: 

    P7: 

    P8: 

    P9: 

    P10: 

     

    Attached files:

    C:\Users\BENNETT\AppData\Local\Temp\DMIB808.tmp.log.xml

     

    These files may be available here:

    C:\Users\BENNETT\AppData\Local\Microsoft\Windows\WER\ReportArchive\NonCritical_x64_5a8bb86f8db89e92f8dc108c50862cfd27e83c54_1688be8d

     

    Analysis symbol: 

    Rechecking for solution: 0

    Report Id: 2b2dd9fd-1ae6-11e1-9c5b-d3f6852c6d5f

    Report Status: 0

    • Edited by mobinga Wednesday, November 30, 2011 12:31 AM
    • Moved by Sabrina Shen Wednesday, November 30, 2011 2:20 AM (From:Windows Vista Hardware)
    Wednesday, November 30, 2011 12:24 AM

Answers

  • I suggest you reinstall USB controllers.

    Use the Mouse
    =============
    First, please disconnect all USB devices and then perform the following steps:

    1. Click "Start", type in Device Manager the Search bar and press "Enter". Click Continue if necessary.
    2. In Device Manager, double click to expand "Universal Serial Bus controllers", right click on the "Host Controller", click "Uninstall" and click "OK".
    3. Repeat the step 2 to uninstall all items under "Universal Serial Bus controllers".

    Then, restart your computer and Windows Vista will reinstall all USB controllers automatically.

    Use the Keyboard
    =============
    First, please disconnect all USB devices. Then, go through the following steps:

    1. Press "Ctrl + Esc" to open the Start Menu.
    2. Type Device Manager in the Search bar and press "Enter". Click Continue if necessary.
    3. In Device Manger, press Tab and use "Up" and "Down" to move the highlight to "Universal Serial Bus Controllers".
    4. Press "Right" and expand it.
    5. Press "Down" to move to the first item and press "Delete" to remove it.
    6. Repeat the step 5 and uninstall all items under "Universal Serial Bus Controllers".

    Then, restart your computer and the system will reinstall all controllers automatically.

    If the issue still occurs, I suggest you upgrade your BIOS, and access the motherboard or computer manufacturer website to find if there is any USB controller drivers can be downloaded. If it does not help either, Please let us know if your chipset is from NVIDIA and if so, install the following hotfix.

    You may encounter problems when you move data over USB from a Windows 7-based or Windows Server 2008 R2-based computer that has an NVIDIA USB EHCI chipset and at least 4GB of RAM.
    http://www.microsoft.com/download/en/details.aspx?id=3689


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Friday, December 9, 2011 8:43 AM
    Thursday, December 1, 2011 3:24 AM