none
Add a use or group to Hyper-V Administrators goup on Windows 10 machine

    Question

  • I am running a 2008 R2 domain, and I have a couple of machines running Windows 10 joined to the domain.  I am running Hyper-V on the windows 10 machines, and basic users can open the Hyper-V manager, but will receive a message saying you do not have the required permission to complete this task, when connecting to the virtual machine management service.

    I know I can go into computer management on the machine and just add the domain user to the Hyper-V Administrators group, under local users and groups, but would prefer to use a GPO instead.

    I have already tried this with group policy preferences but did not have any luck.  Thanks for any suggestions.

    Thursday, April 28, 2016 10:16 PM

Answers

  • Hi,

    If the reply above has resolved your problem, please mark it as answer as it would be helpful to anyone who encounters similar issues.

    Thank you.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by zeb2100 Wednesday, May 4, 2016 2:28 PM
    Wednesday, May 4, 2016 2:03 AM
    Moderator

All replies

  • Hi,

    To achieve your goal, you could try to perform these actions below.

    1. Create a computer OU and add the computer which running Hyper-v to the OU
    2. Open Group Policy Management, right-click the computer OU and create a GPO
    3. Configure the GPP like below under the computer configuration

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 29, 2016 9:22 AM
    Moderator
  • Thanks for replying.  I already tried that and it did not work.
    Friday, April 29, 2016 2:28 PM
  • Update.  Tried group policy preferences on test 2012 R2 domain, and it seems to work.  Still would like to find out why it does not work in 2008 R2 domain.
    Friday, April 29, 2016 10:24 PM
  • Hi,

    I suggest you check the policy has been applied on client with running the command GPresult /h C:\gpresult.html.

    You could also run the command and post the result to us to research.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, May 2, 2016 8:07 AM
    Moderator
  • Thanks for your help.  I was able to resolve the issue after running the command.  I removed the rename group option from the gpp and it worked.
    Tuesday, May 3, 2016 5:51 PM
  • Hi,

    If the reply above has resolved your problem, please mark it as answer as it would be helpful to anyone who encounters similar issues.

    Thank you.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by zeb2100 Wednesday, May 4, 2016 2:28 PM
    Wednesday, May 4, 2016 2:03 AM
    Moderator