locked
How to remove imported calendar from Outlook 2013? RRS feed

  • Question

  • If I open an ICS file to copy the calendar entries into my personal calendar, Outlook adds the imported calendar to the navigation list on the left-hand side:

    If I right-click on any of the calendars, the option to delete the calendar is disabled.

    What can I do to remove these?

    Thanks.

    Philip

    Monday, February 25, 2013 11:55 AM

Answers

  • Hello Philip,

    These are default Clendars and would not be removed from Outlook as the " Delete " option is totally grayed out. You can still delete them using MFCMAPI.

    You can download MFCMAPI from http://mfcmapi.codeplex.com

    CLOSE THE OUTLOOK COMPLETELY

    Follow these steps :

    1. Extract theexe file

    2. Click on session and selct Logon

    3. Select the appropriate profile

    4. Double click the mailbox or PST which contains these calendars

    5. Now expand Root Container

    6 Expand Top Of personal Folders or IPM_SUBTREE or Top of Information store

    ( For POP account it would be Top of Personal Folders , For cached Exchange mode it would be IPM_Subtree and for Exchange online mode it would be Top Of Information Store )

    7. Now right click the folder which you would like to delete and selct delete folder. Below is the screenshot for same.

    8. Now close all the windows

    9. Start Outlook

    Hope this helps

    Monday, March 4, 2013 3:42 AM
    Answerer

All replies

  • Have you tried the same - http://office.microsoft.com/en-001/outlook-help/create-view-or-delete-a-calendar-group-HP010356480.aspx?

    DeVa, M.S., {MSFT} Please remember to mark the replies as answers if they help

    Tuesday, February 26, 2013 1:43 AM
  • Did you try deleting it from File, Account Settings, Internet calendars tab?


    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter


    Tuesday, February 26, 2013 5:37 AM
  • Nice suggestion but it doesn't work, I'm afraid. I get an error telling me I don't have permission to delete the group. Once I move the imported calendars out of the group, I can then delete the group, so Outlook clearly doesn't want me to delete them!

    Very weird problem.

    Tuesday, February 26, 2013 7:49 AM
  • There isn't a Subscribed calendars tab. I have Internet Calendars and Published Calendars, but both of these are empty.

    Tuesday, February 26, 2013 7:50 AM
  • Hello Philip,

    These are default Clendars and would not be removed from Outlook as the " Delete " option is totally grayed out. You can still delete them using MFCMAPI.

    You can download MFCMAPI from http://mfcmapi.codeplex.com

    CLOSE THE OUTLOOK COMPLETELY

    Follow these steps :

    1. Extract theexe file

    2. Click on session and selct Logon

    3. Select the appropriate profile

    4. Double click the mailbox or PST which contains these calendars

    5. Now expand Root Container

    6 Expand Top Of personal Folders or IPM_SUBTREE or Top of Information store

    ( For POP account it would be Top of Personal Folders , For cached Exchange mode it would be IPM_Subtree and for Exchange online mode it would be Top Of Information Store )

    7. Now right click the folder which you would like to delete and selct delete folder. Below is the screenshot for same.

    8. Now close all the windows

    9. Start Outlook

    Hope this helps

    Monday, March 4, 2013 3:42 AM
    Answerer
  • hi...im having same problem...have you resolved issue...did the MFCMAPI route work (legit???)???
    Thursday, March 7, 2013 8:20 AM
  • I am having the same problem. Surely there must be a way to do this using Office tools.
    Sunday, April 7, 2013 10:10 PM
  • This worked for me (MFCMAPI method).

    Thanks a lot!!!


    • Edited by BigThunder Wednesday, April 17, 2013 3:20 AM
    Wednesday, April 17, 2013 3:17 AM
  • when I try to delete the calendar, I get the error: 

    Error: 
    Code: MAPI_E_UNKNOWN_FLAGS == 0x80040106
    Function lpParentFolder->DeleteFolder( lpItemEID->cb, (LPENTRYID) lpItemEID->lpb, lpProgress ? (ULONG_PTR)m_hWnd : NULL, lpProgress, ulFlags)
    File MsgStoreDlg.cpp
    Line 950

    help plz

    Thursday, April 18, 2013 11:42 AM
  • You probably have the Hard Delete button checked. Uncheck it. That should work. You don't need to delete it beyond recovery.
    Tuesday, July 23, 2013 2:41 PM
  • I am having the same problem. I'd rather not use the MFCMAPI method, seems there should be an easier way. I am interested in your response here -- where can I uncheck the Hard Delete button? If I have to go use MFCMAPI to do this, that is fine with me. It's a big problem when Delete Calendar is greyed out upon right-click for a calendar I've added myself.

    Tuesday, August 20, 2013 2:33 PM
  • "6 Expand Top Of personal Folders or IPM_SUBTREE or Top of Information store"

    None of these options were available for me.

    Still can't delete these folders.

    Monday, October 21, 2013 7:04 PM
  • If delete is disabled, it means it's a default calendar in a mailbox. You can hide it (using MFCMAPI) but can't delete it.

    What type of email account do you use?

    Is the Calendar listed on the Internet Calendars tab in File, Account Settings? If not, go to the Folder list (Ctrl+6) - what data file is the calendar in?



    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Monday, October 21, 2013 10:29 PM
  • I followed your suggestion by deleting the Calendar folder. But now I want to know how do I restore my Calendar after it has been deleted because I noticed that my Outlook 2013 calendar went missing after I deleted it using MFCMAPI. How do I restore it to the original state? Is a rollback possible?
    Tuesday, December 31, 2013 7:28 AM
  • You'll need to restore it using a backup unless it is in the deleted items folder, then you can drag it out.


    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Tuesday, December 31, 2013 4:40 PM
  • This is the most complicated "fix" I have seen in ages.

    Why is Microsoft so damn clunky and counter intuitive?

    I simply cannot delete calendars I no longer use.   WHAT A DRAG.

    Tuesday, February 4, 2014 4:57 PM
  • What type of email account do you have? There may be better ways to delete it. The only calendar that needs to be deleted using MFCMAPI is a default calendar in your data file.



    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Tuesday, February 4, 2014 5:08 PM
  • I had the same issue. I found that for now there is only one method that works for me to remove these "undeletable" calendars from Outlook 2013. (Of course I hope Microsoft will resolve this situation in a future update of Outlook...). Note that I tried the MFCMAPI method described above, but this did not help. I could remove the unwanted calendars within the tool, but they still showed up in Outlook 2013.

    Before I outline my "solution", please note that my main account is an Exchange Active Sync account (I use Outlook.com for mail, contacts and calendar). This means that Mail, People and Calendar are stored on the Outlook servers in the cloud. Therefore, in such a case, it is quite safe to delete local copies of all of these, since they will be rebuilt from the cloud server through automatic synchronization via the EAS-protocol.

    If you are unsure whether your Mail, People and Contacts are indeed stored on a cloud server, and not locally, then do NOT use the method below.

    This is my solution:

    1. In Outlook, delete any remaining calendar items which may be lingering in these unwanted calendars.
    2. In Outlook, identify which data file is used to store your calendar, as follows: in the File menu, open Account Settings, click on the Data Files tab.
    3. Select the Outlook Data File which is indicated as the default, then click on the Open File Location button.
    4. Just a as precaution, make a backup copy of this data file on your desktop. (You can delete it later).
    5. Close the Outlook application.
    6. In the folder you opened in step 2, delete the data file which contains your calendar, then empty the Recycle Bin.
    7. Open the Outlook application. The unwanted calendars will be gone.
    8. Unfortunately, you may have to reconfigure certain settings you made for this account, such as View preferences, category colors and names in the calendar, etc.





    • Edited by Van Cotthem Sunday, May 11, 2014 8:40 AM
    • Proposed as answer by Zensundae Tuesday, May 27, 2014 8:00 AM
    Sunday, May 11, 2014 8:27 AM
  • This worked for me, thank you very much 
    Tuesday, August 5, 2014 7:16 PM
  • Great suggestion! I had to access a few Outlook archive files on a work laptop and struggling with a similar issue after I removed the external hard drive containing the extra calendars.

    I wasn't in a position to download software and this was a quick 2 second fix! Thanks.

    Wednesday, August 13, 2014 6:10 PM

  • By default the imported calendar will be grayed out but this Utility allowed me to remove the imported calendar.  

    Thank you so much for your contribution!

    Friday, January 16, 2015 5:46 PM
  • MFCMAPI.exe worked perfectly thanks!
    Sunday, January 18, 2015 4:05 AM
  • I agree this worked for me and the directions were easy to follow. Not sure if this is related to microsoft or ics but this function should not have to be complicated. As a user, I should have the option to remove the calendar if I don't want it but I understand there a other factors involved, ie Microsoft, email account etc.
    Tuesday, January 27, 2015 2:23 AM
  • I found the solution! NO 3rd PARTY SOFTWARE REQUIRED!!! (or exporting/importing shuffling)


    Delete these user specific folders:


    C:\Users\username\AppData\Roaming\Microsoft/Outlook

    C:\Users\username\AppData\Local\Microsoft/Outlook


    Emails and calenders only connect with the emails will re-sync, but all locally saved data will be lost. In result, the imported calender(s) will be gone.


    Getting rid of the annoying calenders quickly, without loosing the important stuff!!!



    *username for windows 8 would be the name assigned by Windows for your local account (usually the first 5 alphabetical characters of the email (skipping special characters), underscore, and 0000)


    ex. qwert_0000

     (qwe.rtyuiop15@outlook.com)


    Monday, March 23, 2015 4:51 PM
  • Thank you, krono-matrixerMFCMAPI deleted the calendar, but when I brought outlook back up, the calendars appeared again. This worked for me!

    James


    Saturday, April 4, 2015 8:17 PM
  • No It doesn't as it also says per user that it grey out the folder. we need some other alternative for sure.
    Sunday, April 12, 2015 3:21 AM
  • This worked perfectly fine. Thanks. :)

    BTW I got an exception error when I first choose the option "Hard Delete". Without that option it deleted without issue. 

    Sunday, April 12, 2015 4:03 AM
  • This is the REAL DEAL! Works like an African charm. Thank you very much
    Wednesday, May 20, 2015 8:30 AM
  • This works.

    Signatures and settings are saved.

    Make sure you use syncend calendars etc.

    Wednesday, May 20, 2015 8:52 AM
  • This worked for me!  Thank you!
    Wednesday, August 26, 2015 9:48 PM
  • You need to open your MSN home page and sign into the email account under which these are appearing (presumably the same if the email account you are bringing into Outlook is Comcast, log into your Comcast account, if it's Yahoo, log into Yahoo, and so on), from there, open your web based email, go to the calendars.  So if it is an MSN based email account, I navigate to Outlook.com, once it displays my emails, I navigate to Calendars, still web-based.  From there, it lists my primary calendar associated with the account as "Calendar," then the other pesky ones I want to get rid of are listed beneath.  Click on the first calendar you wish to delete, and make sure to click again on your primary calendar, you will see the view remove those from display, and simply delete.  Repeat for however many random calendars were syncing to your account.  You should be left with only the primary.  It all should then sync back to your Outlook 2013.  I absolutely hate everything about Windows 10, Office 2013, Acrobat DC, all of it that has been so dumbed down visually, yet over complicated to actually accomplish anything.  It's absurd...
    Monday, December 12, 2016 2:46 PM
  • Hi I have just had the same issue with Outlook 2013, the following worked for me:-

    • In Outlook
    • Go to the File Option
    • Select Account Settings
    • Then Account Settings again
    • Select Internet Calendars
    • Select the Calendar
    • Press Remove

    Hope this helps some people

    Wednesday, September 13, 2017 1:06 PM