none
Getting different values in Excel while browsing SSAS cube using filter RRS feed

  • Question

  • Hello,

    I have very weird issue. My cube is showing right value but when I create report in Excel with same measures, Dimension and filter that gave me different value.  I have a measure "Sum", "Time" & "Flag" Dimensions. I am using "Time" Dimension (Year. Quarter.Month Hierarchy) as a filter.

    In Excel, when i am filtering out with year, it works fine but when I go one level down for quarter it gives me wrong value while for the same filter I an getting right value in VS/SSMS. I am not using any MDX query here.

    I don't know I have to make any changes in particular property level for dimension or it is problem with Excel connection. Well, we are using strategy companion and getting same issue like Excel.

    Any help would be appreciate.

    Thanks!!

    Wednesday, January 30, 2013 11:00 PM

All replies

  • The OWC 2003 component used by VS / SSMS is riddled with issues like this.  I usually ignore it and conduct all testing using the client tools that will be used by your users.  There are other practical advantages e.g. saving queries & results, output of results etc etc.
    Thursday, January 31, 2013 12:01 PM
  • Hi there,

    Try to confirm that relationships and key settings match up with a sample database such as Adventureworks or Contoso.

    It might be an issue with the way things are related or you may need to use composite keys in date dimension.

    Other thing to do is check SQL Profiler to see what MDX is being generated for each tool, and share here.

    cheers,

    Andrew


    Andrew Sears, T4G Limited, http://www.performancepointing.com

    Thursday, January 31, 2013 2:04 PM
  • Hey Mike/Andrew,

    Thanks for your reply. We are using strategy companion as client tool. Even in that it shows different value. Excel/strategy companion are act differently only for one cube. I am using same Dimensions with same property in other Database cube but it works fine for other cubes.

    Well, I noticed that it happens only in Grand Total. Individual numbers seems correct but when we see GRAND TOTAL it is different in Excel/strategy companion. I don't how this GRAND TOTAL works differently other than VS/SSMS when we use this dimension as a filter.

    Thanks,

    Ankit


    • Edited by arpatel Thursday, January 31, 2013 3:27 PM
    Thursday, January 31, 2013 3:22 PM
  • Hi Ankit,

    It seems you encountered a similar issue in the thread below:
    AdventureWorks DW 2008, cube browser different result vs Excel 2007: http://social.technet.microsoft.com/Forums/en/sqlanalysisservices/thread/70952647-f6f8-48f1-94e0-cde72b852423

    Regards,


    Elvis Long
    TechNet Community Support

    Monday, February 4, 2013 7:22 AM
    Moderator