none
Read-only in MS Project but can read-write in PWA RRS feed

  • Question

  • I have a user who has 'full' permissions as a resource in Project Server 2010. For three months he was able to edit projects in PWA as well as MS Project. For some reason, he can now only edit (i.e. save) projects in PWA but when he opens them in MS Project it says "you selected a project that can be only opened read only".

    In other words, he can check out and edit projects in PWA but not in MS Project.

    No permissions were changed on his user. He has cleared the local cache but this didn't help.

    Any ideas?

    Monday, August 6, 2012 11:15 AM

Answers

All replies

  • Sounds like a security setting has either changed or perhaps got cancelled or errored while it was processing. If not on the user specirfically, then most likely a group setting. The 'publish and save project' permission can be found when you click on a category for that particular group or user. Good practice is to use groups generally but you can also tick these permissions at the individual user level if you need. If you notice the group or user already has this permission, try re-doing the permissions to force the permission job to apply the necessary changes again. For example uncheck the permission, click save, then check it again and click save. Remeber to wait until the queue has finished processing before proceeding.

    Regards,

    Piet Remen
    http://pietremen.blogspot.com.au

    Monday, August 6, 2012 3:00 PM
  • Apart from Piets great answer, it may be local cache on the PC. does this only happen on his PC or on all? If it is only on his PC you may want to clear the local cache and see if this resolve the issue.

    Marc Soester [MVP] http://marcsoester.blogspot.com

    Monday, August 6, 2012 11:29 PM
    Moderator
  • Thanks for the two useful answers. The problem went away after a couple of tries after I had saved and re-saved as per Piet's suggestion. I am not sure, however, if that was the reason. Let me share a bit of additional information about what I was doing at the time.

    I have two PWA usernames and was logging in and out of each of them on the same pc. This worked fine for an hour or two but I suspect that after a while things got confusing. Now what happens is that each time a project is opened for editing, PWA prompts for the username and password to be entered.

    That's the bad news but the good news is that the user is able to edit projects.

    We can therefore close this item and thanks again for your help!

    Hessel

    Tuesday, August 7, 2012 9:16 AM
  • Good to hear all is working again. As for the logon prompt. Check your IE broswer settings under internet options. Add the PWA web application to one of the trusted or intranet zones and set the option as showin in the screen shot below.


    Regards,

    Piet Remen
    http://pietremen.blogspot.com.au

    Tuesday, August 7, 2012 3:24 PM
  • The second part was already set but I added the site url to the trusted sites and it seems to have helped. 

    Thanks again

    Thursday, August 9, 2012 2:30 PM