locked
App-V 5.1 Client Only - Application Crashing AppVEntSubsystems64.dll RRS feed

  • Question

  • Just working through the possibilities at my end before I log a call with MSN but I thought I had better check no one else is already on top of this. We have Autodesk Revit packaged in 5.0 SP3 Sequencer working fine on 5.0 SP3 client / full AppV infrastructure. If I upgrade the client to 5.1, the package breaks. I get an APPCRASH error Fault Module Name - AppVEntSubsystems64.dll.

    Every other package I have tested works ok so presumably there is something the client doesn't like in the package but we have been led to believe everything that works on 5.0SP3 client will work on 5.1. Any ideas?


    • Edited by AndrewKelly Wednesday, September 16, 2015 11:13 AM
    Wednesday, September 16, 2015 10:07 AM

Answers

  • If the primary virtualization hooking DLL is crashing, I would open a support ticket as this may require some deep debugging. Perhaps a conflict between App-V and something else that may leverage Detours (like some sort of security software.)


    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    http://blogs.technet.com/gladiatormsft/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Sunday, October 18, 2015 4:46 AM
  • Been through the process with Support. Recommendation has to been if we want to use this Application with App-V 5.1 then we should upgrade to W10. There is more information on similar Forum Topic started by Simon Dettling.

    Tuesday, October 20, 2015 3:12 PM

All replies

  • I would log a ticket. Applications should be backwards compatible. You could also try to resequence with appv5.1 Or just open for upgrade and save again.
    Thursday, September 17, 2015 9:43 AM
  • Have you seen this?

    https://social.technet.microsoft.com/Forums/en-US/d94cbdcf-127d-42d7-b2e2-81b2e348fab9/appv-50-applications-crashing-after-upgrade-to-sp2?forum=mdopappv

    That's from a previous upgrade, I think from SP1 to SP2.... where MS released a hotfix for fixing a similar issue.
    Thursday, September 17, 2015 6:42 PM
  • Thanks Tiberivs and Vinodreddy597. Presumably, it is something similar. I will log a call first thing Monday. I have tried to re-sequence in 5.1 and if I publish to 5.0SP3 it fires up ok, it will also let me extract it to the 5.1 Sequencer and run it but as soon as I try to open the App up on 5.1 client it crashes.

    I have also checked and on a PC with the 5.1 client it will let me double click on the executable from the ProgramData\AppV folder and it opens up fine.

    Makes me think an Upgrade on the Package unlikely to make any difference. If I get a satisfactory answer, I'll let you all know.


    • Edited by AndrewKelly Monday, September 21, 2015 9:06 AM updated info
    Friday, September 18, 2015 9:21 PM
  • If the primary virtualization hooking DLL is crashing, I would open a support ticket as this may require some deep debugging. Perhaps a conflict between App-V and something else that may leverage Detours (like some sort of security software.)


    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    http://blogs.technet.com/gladiatormsft/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Sunday, October 18, 2015 4:46 AM
  • Been through the process with Support. Recommendation has to been if we want to use this Application with App-V 5.1 then we should upgrade to W10. There is more information on similar Forum Topic started by Simon Dettling.

    Tuesday, October 20, 2015 3:12 PM