none
Auto Replies (Out of Office) not working - Exchange 2010 with Autodiscover running properly. RRS feed

  • Question

  • Exchange 2010, Outlook 2010 on all Windows 7 clients. I've gone through just about all the other threads in this sub-forum, as well as the Outlook 2010 one, and after triple-checking Autodiscover, our certificates, our local/group policies, etc et al, I just can't find a solution to sporadic users not being able to use Automatic Replies (Out of Office). It works just fine for what seems to be %70 or so of our users (myself included, on two separate computers), except for the fact that it doesn't work through OWA - when any user clicks on Automatic Replies in OWA, it logs them off immediately. 

    I'm at my wit's end, here, but luckily, we have forums like these so I can hopefully get some insight into this issue. I'm the network administrator, and have access to anything/everything, so I can reset/change/restart/etc anything - don't be shy to ask if you think it might help.

    Thanks in advance!

    Thursday, September 13, 2012 9:53 PM

All replies

  • It looks like there is a problem with the configuration of Exchange Web Services.

    Run:

    Get-WebServicesVirtualDirectory | FL

    Start by looking at the InternalURL and ExternalURL settings and make sure that they resolve and match the certificate.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Friday, September 14, 2012 12:52 AM
    Moderator
  • hi,

    Per my understanding, your issue is:

    If your user use outlook 2010, about 70% of the users can use the oof message, but if their use owa, no one can use the oof, is it right?

    If i am right, please do this test.

    First try to use other browsers to log on your owa and set the oof again.

    Second, run the test-autoemailautoconfiguration on your problematic user's outlook and the normal user's. Compare the two result.

    thanks,


    CastinLu

    TechNet Community Support

    Friday, September 14, 2012 8:24 AM
  • It looks like there is a problem with the configuration of Exchange Web Services.

    Run:

    Get-WebServicesVirtualDirectory | FL

    Start by looking at the InternalURL and ExternalURL settings and make sure that they resolve and match the certificate.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    They match and they're both accessible. 
    Monday, September 17, 2012 12:47 AM
  • hi,

    Per my understanding, your issue is:

    If your user use outlook 2010, about 70% of the users can use the oof message, but if their use owa, no one can use the oof, is it right?

    If i am right, please do this test.

    First try to use other browsers to log on your owa and set the oof again.

    Second, run the test-autoemailautoconfiguration on your problematic user's outlook and the normal user's. Compare the two result.

    thanks,


    CastinLu

    TechNet Community Support

    Yep, you understood the problem correctly. I just tested with Firefox, as I had already tried it on IE8 and Chrome before, but the same issue came up - it just logged me right out of OWA. Just for giggles, I tried it from completely outside the network and while VPN'ed in (had previously tried it only from within the network), but the results were just the same as well.

    When I ran the Test (the Ctrl-right-click test on the system tray icon, correct?) on my own account (which the Auto Replies work for in regular Outlook) and the user's, all of the details were identical. Any other ideas?

     
    Monday, September 17, 2012 1:03 AM
  • hi,

    >>>When I ran the Test (the Ctrl-right-click test on the system tray icon, correct?) on my own account (which the Auto Replies work for in regular Outlook) and the user's, all of the details were identical.

    Since there are still 30% users can't set oof when they use outlook. So may be it is caused by the autodiscover service. Please post the test result here.

    Hit the CTRl key and right click the outlook icon, choose test-emailautoconfiguration, uncheck the second and third box and test.

    >>>when any user clicks on Automatic Replies in OWA, it logs them off immediately.

    Can you give me more information about owa log off? If you can, post a screenshot here. Owa directly call the oof API to get and set the oof message, so if owa oof can't work, outlook also will be fail.

    hope can help you

    thanks,


    CastinLu

    TechNet Community Support

    Monday, September 17, 2012 2:16 AM
  • hi,

    >>>When I ran the Test (the Ctrl-right-click test on the system tray icon, correct?) on my own account (which the Auto Replies work for in regular Outlook) and the user's, all of the details were identical.

    Since there are still 30% users can't set oof when they use outlook. So may be it is caused by the autodiscover service. Please post the test result here.

    Hit the CTRl key and right click the outlook icon, choose test-emailautoconfiguration, uncheck the second and third box and test.

    >>>when any user clicks on Automatic Replies in OWA, it logs them off immediately.

    Can you give me more information about owa log off? If you can, post a screenshot here. Owa directly call the oof API to get and set the oof message, so if owa oof can't work, outlook also will be fail.

    hope can help you

    thanks,


    CastinLu

    TechNet Community Support

    I'd rather not post the full results of that tool here, as they contain sensitive data about my network. I can tell you from looking at the results, however, that AutoDiscover is being found and connected to when I run the test under my user account just as well as when I run it with two other users who cannot access Automatic Replies.

    As per the OWA logoff, it literally just kicks the user back to the OWA login screen when they click on Automatic Replies. It does change the URL to this, however - "https://mail.myexternalmailserveraddress.com/owa/auth/logon.aspx?replaceCurrent=1&reason=2&url=https%3a%2f%2fmail.myexternalmailserveraddress.com%2fecp%2f%3frfr%3dowa%26p%3dOrganize%2fAutomaticReplies.slab

    Monday, September 17, 2012 8:41 PM
  • Hi,

    Since only 30% users cannot set OOF, I suggest move one problematic user to another mailbox database. After that, please check if he can set OOF.

    In addition, I suggest we login to the problematic mailbox via Outlook on another machine and check if he can set OOF.

     

    Sean Qiu


    Thursday, September 20, 2012 7:25 AM
    Moderator
  • Hi,

    Since only 30% users cannot set OOF, I suggest move one problematic user to another mailbox database. After that, please check if he can set OOF.

    In addition, I suggest we login to the problematic mailbox via Outlook on another machine and check if he can set OOF.

     

    Sean Qiu


    Great idea! I will try this out later today or tomorrow, depending on time constraints.

    Also, I was just alerted that when any user in OWA clicks on Options->See All Options, that the user gets logged out immediately, just the same as when you click on Automatic Replies. Does that give any insight into what service might be failing?
    Tuesday, September 25, 2012 4:48 PM
  • Hi,

    Since only 30% users cannot set OOF, I suggest move one problematic user to another mailbox database. After that, please check if he can set OOF.

    In addition, I suggest we login to the problematic mailbox via Outlook on another machine and check if he can set OOF.

     

    Sean Qiu


    So, I tried moving impacted users to different mailbox databases and they still had the exact same issues. ToolTips have actually been unavailable as well since I started here two months ago (I inherited the infrastructure and it was not in very good shape). Doesn't this point to some sort of issue with AutoDiscover?
    Thursday, October 4, 2012 4:10 PM
  • Hi,

    Since only 30% users cannot set OOF, I suggest move one problematic user to another mailbox database. After that, please check if he can set OOF.

    In addition, I suggest we login to the problematic mailbox via Outlook on another machine and check if he can set OOF.

     

    Sean Qiu


    So, I tried moving impacted users to different mailbox databases and they still had the exact same issues. ToolTips have actually been unavailable as well since I started here two months ago (I inherited the infrastructure and it was not in very good shape). Doesn't this point to some sort of issue with AutoDiscover?
    This reply was actually from me, but accidentally signed in with an old account from my company. Either way - any ideas?
    Thursday, October 4, 2012 5:56 PM
  • Hi,

    Can we set OOF in Outlook? If so, I think the ECP virtual directory may be corrupted. Please remove and recreate ECP virtual directory:

    Remove-ECPVirtualDirectory "CAS server name\ecp (Default Web Site)"

    New-ECPVirtualDirectory

    Sean Qiu

    Wednesday, October 24, 2012 7:13 AM
    Moderator