locked
Regarding teh network problem with Hyper-V Redhat. RRS feed

  • Question

  • Hi everyone,

                  I have been trying to ping to the Host Machine (WS2008R2) from the Redhat 6.0 installed on my Hyper-V and this is not working for me. But when i get Ping from my Host Machine (WS2008R2) it is getting response from Hyper-V redhat. Can anyone tell me what might be the problem.


    http://technetnepal.net/blogs/aerrow
    Monday, January 9, 2012 5:10 AM

Answers

  • Windows Firewall (on parent partition) will drop ICMP echo by default, that's why I suspect you cannot ping your host OS from the RH guest. While RH also has a default packet filtering configured (i.e. managed by 'system-config-firewall') but if doesn't drop pings.

    If this doesn't help, check how your networking is done, like if your virtual network is bridged with the parent partition or not (default if you create a external virtual network in hyper-v.

    Monday, January 9, 2012 8:01 AM
  • Provided your RHEL VM has network connectivity, this is extremely unlikely to have anything to do with the drivers, and is likely to be with the firewall configuration.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, January 10, 2012 5:09 AM

All replies

  • Windows Firewall (on parent partition) will drop ICMP echo by default, that's why I suspect you cannot ping your host OS from the RH guest. While RH also has a default packet filtering configured (i.e. managed by 'system-config-firewall') but if doesn't drop pings.

    If this doesn't help, check how your networking is done, like if your virtual network is bridged with the parent partition or not (default if you create a external virtual network in hyper-v.

    Monday, January 9, 2012 8:01 AM
  • Provided your RHEL VM has network connectivity, this is extremely unlikely to have anything to do with the drivers, and is likely to be with the firewall configuration.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, January 10, 2012 5:09 AM
  • I have tried to ping with w2k8 by disabling the firewall too..but it is not working.:(
    http://technetnepal.net/blogs/aerrow
    Tuesday, January 10, 2012 7:04 AM