locked
Windows 10 denying UNC Paths RRS feed

  • Question

  • So maybe not denying it would be the right way to put this one but that's the best I can see that happening at the current time. I have a test network setup all with a local admin account in the following configurations 2x Windows 10 Pro and 2x Windows 7 Pro all using the same local admin login account between them with the same exact setup. 

    The two Win7 machines can UNC between each other with no issues and the two Win10 machines can UNC into the Win7 with no issues using the local account created. But when the Win7 machine tries to UNC into the Win10 machine or the two Win10 machines try to UNC into each other they get the login prompt and using the login still get's an access denied. 

    I have checked the sharing on the root drive which shows both Win 10 machine that c$ is already enabled and cannot be created. Advanced Sharing options seem to mirror those of Win7 for file sharing aspects and I don't remember of anyone or maybe I missed it during the Win Insiders testing of issues nor did I test that feature in my VMs during that time.

    Any ideas?

    Monday, August 3, 2015 5:29 PM

Answers

  • Hi,

    Hi, first of all, please check the sharing settings, make sure the account have permission to access.

    Then try to use IP address access to the sharing file for test. If failed, this can be DNS problem.

    On the other hand, please also check NTFS Permission, make sure there is no problem with it.



    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Roger Lu Wednesday, August 19, 2015 8:52 AM
    • Marked as answer by Karen Hu Friday, September 4, 2015 2:54 AM
    Thursday, August 6, 2015 8:31 AM

All replies

  • Have you checked that the file and printer sharing is turned on?

    Monday, August 3, 2015 5:48 PM
  • Yes have checked all the advanced file sharing settings and they are set including these. Normally I have it turned off in the public network and only have it on in the home and domain networks but for testing and to make sure this setting wasn't somehow tripping me up I enabled it for the guest network even through all the computers are set to run in private network mode.
    Monday, August 3, 2015 6:00 PM
  • Hi,

    Hi, first of all, please check the sharing settings, make sure the account have permission to access.

    Then try to use IP address access to the sharing file for test. If failed, this can be DNS problem.

    On the other hand, please also check NTFS Permission, make sure there is no problem with it.



    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Roger Lu Wednesday, August 19, 2015 8:52 AM
    • Marked as answer by Karen Hu Friday, September 4, 2015 2:54 AM
    Thursday, August 6, 2015 8:31 AM
  • Sorry for being late to the party, but did you ever get this sorted?

    I have the same issue. I can get to \\Win10Machine and see the Documents and Users shares, but if I try to go to C$ or D$ I am asked for a username and password. And typing in either MACHINE\USERNAME or the email address I log on with doesn't work.

    Monday, November 30, 2015 3:41 PM
  • Try this:

    http://www.dedoimedo.com/computers/windows-10-network-share-access.html


    Thursday, January 7, 2016 10:43 AM
  • I got the Access is denied issue solved when i tried to access a Netowrk share on another computer

    ex \\192.168.1.0\c$\

    It seemed to be a UAC issue. The below Link helped.

    https://support.microsoft.com/en-gb/kb/951016

    We will need to add a new DWORD

    1. Click Start, click Run, type regedit, and then press ENTER.
    2. Locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
    3. If the LocalAccountTokenFilterPolicy registry entry does not exist, follow these steps:
      1. On the Edit menu, point to New, and then click DWORD Value.
      2. Type LocalAccountTokenFilterPolicy, and then press ENTER.
    4. Right-click LocalAccountTokenFilterPolicy, and then click Modify.
    5. In the Value data box, type 1, and then click OK.
    6. Exit Registry Editor.


    Gautam.75801

    • Proposed as answer by Qas786 Thursday, July 7, 2016 11:59 AM
    Saturday, January 9, 2016 11:22 AM
  • Thank you !
    Sunday, September 3, 2017 10:58 AM
  • I had a case where simply accessing the properties of a directory, clicking on the sharing tab, going to advanced sharing, checking "share this folder", clicking OK, worked fine on my Win7 machine. But doing those same steps on my Win10 machine didn't work, and I got a "cannot access" error message when doing \\computername\foo or \\internal_ipv4_addr\foo in file explorer (with the exception of \\localhost\foo or \\127.0.0.1\foo which would work fine as expected).

    I tried completely turning off my firewall and anti-virus, giving everyone full access to that shared folder, double checking sharing settings in control panel to make sure it was set to completely loose/insecure settings. None of those let me access my shared folder over LAN, so I reverted those back.

    What somewhat fixed this for me was going to Control Panel, Network and Internet, Network and Sharing Center, clicking on the network connection name which opens the connection status window, clicking on properties, then disabling "File and Printer Sharing for Microsoft Networks", click OK, then re-enabling that same item, click OK. I have to do this every time I reboot unfortunately. Seems like a bug...

    I'm running Windows 10 Pro x64 with a TP Link Wireless Adapter, driver version 1030.3.831.2015 as shown in device manager for the Archer T9UH. Windows updates are all up to date.



    • Edited by solstice333 Friday, January 26, 2018 9:49 PM
    Friday, January 26, 2018 9:47 PM
  • Thank you, this works for me as a workaround. Hopefully Microsoft will have a solution soon, as it's a pretty annoying bug.

    For me it started a couple of weeks ago, after the latest round of Windows updates. After a reboot, I had no network at all (yellow triangle and no connectivity, despite valid IP config). Performing the Win 10 'network reset' option would fix this until next reboot, when the issue would return. I then found that updating my Intel I219 NIC drivers to latest version resolved this, but I'm now left with this file & print sharing bug.

    Wednesday, August 22, 2018 2:04 PM
  • This was a life-saver!

    Thanks so much!!

    Now I can roll out images without having to worry about this problem.

    Thank you!

    Monday, October 22, 2018 3:27 PM
  • This works, thank you.

    Suracha S.

    Saturday, July 6, 2019 9:59 PM
  • had the same issue. What has fixed it for me is to go to Control Panel, then Programs and Features, turn Windows features on and off, then scroll to SMB 1.0/CIFS File Sharing Support. Turn this feature off (uncheck the box), exit, then go back in and turn it on again (check the box). Now when I reboot my PC I can access the computer via the unc name or ip (e.g. \\<IP address> or <pc name>). Hope this helps.

    Other that that, the workaround I used before was to go into the network settings and uncheck File and printer Sharing for Microsoft Networks, exit, go back in and check it, but that only worked until the pc was rebooted. The solution above to uncheck and check the box for the SMB 1.0 seems to be a permanent solution.    

    Tuesday, December 3, 2019 1:37 PM