none
Can't get message queue - procedure number out of range.

    Question

  • When I try to see all of my queues in Exchange 2010, I run the following command:

    get-exchangeserver | get-queue
    

    And I get all of the queues from all of the servers except for one. That server in particular responds with:

    The Queue Viewer operation on computer "SERVER" has failed with an exception. The error message is: The procedure number is out of range

    Image

    Has anyone else seen this issue before?

    Running Exchange 2010 SP3

    Friday, June 09, 2017 8:45 AM

Answers

  • Hi Vivek,

    This error always means that there is a version control problem in the application.

    Please run the following command to check if all server have the same version:

    Get-ExchangeServer |Ft Name, ServerRole, AdminDisplayVersion

    If the problematic server has a different version, we can try to update to the latest SP3 UR17, and check the result.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Vivek_Vardhan Monday, April 09, 2018 6:13 AM
    Monday, June 12, 2017 8:25 AM
    Moderator
  • Updating the Rollup worked. Thanks for all your help !!!
    • Marked as answer by Vivek_Vardhan Monday, April 09, 2018 6:14 AM
    Monday, April 09, 2018 6:13 AM

All replies

  • Please don't post pictures, they're hard to read.  Post the text.

    What update rollup are you running?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Saturday, June 10, 2017 2:46 AM
  • Hi Vivek,

    This error always means that there is a version control problem in the application.

    Please run the following command to check if all server have the same version:

    Get-ExchangeServer |Ft Name, ServerRole, AdminDisplayVersion

    If the problematic server has a different version, we can try to update to the latest SP3 UR17, and check the result.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Vivek_Vardhan Monday, April 09, 2018 6:13 AM
    Monday, June 12, 2017 8:25 AM
    Moderator
  • Updating the Rollup worked. Thanks for all your help !!!
    • Marked as answer by Vivek_Vardhan Monday, April 09, 2018 6:14 AM
    Monday, April 09, 2018 6:13 AM