locked
Authorize Access to HealthVault Loop on Surface 8.1 RRS feed

  • Question

  • I have successfully signed my mom up for HealthVault online. However, when I try to authorize her Surface tablet to access her account, I get caught in a loop after entering her Microsoft Account password. HealthVault then repeatedly asks to "Authorize Access" with the choice of "I Accept" or "Cancel". After accepting I get the spinning dots then rinse and repeat with "Authorize Access" and "I Accept" or "Cancel" and spinning dots.

    I have uninstalled the app and reinstalled it, signed up online and in the app, deactivated and reactivated the HealthVault account...nothing. Can anyone offer any suggestions as to how to get the Surface to gain access to HealthVault?

    Saturday, January 18, 2014 7:04 AM

Answers

  • Hi,

    Sorry to have to inconvenience you on this but so far you're the only user to have reported this loop and we are not having any luck reproducing the issue here.  The only next steps we have would be to gather some data from you regarding the errors.

    We do log the error in isolated storage with file name error.txt. It should be located at “C:\Users\<user name>\AppData\Local\Packages\Microsoft.HealthVault_8wekyb3d8bbwe\LocalState\HealthVault\”. The error should also be logged to event viewer.    (Not sure if Windows 8 Surface has access to event viewer)

    If you could check those areas and see that would be great. We'll continue trying to investigate a possible cause, you also mentioned you have a HV account and yours works fine right? Was your mother's MSA account created recently?

    Thanks for your help.

    • Marked as answer by Tomas El Saturday, February 22, 2014 3:02 AM
    Monday, January 20, 2014 10:18 PM

All replies

  • Yikes.  Let me try to gather more information from you so I can investigate more in the code.

    Your mom has a Surface tablet, and to login to the tablet, does she use a Microsoft Account? Is this Microsoft Account the same one as what she is using for the HealthVault app, or a different one?

    When your mom goes to www.healthvault.com and logs in with her Microsoft Account, does she get into HealthVault successfully and has her own record?

    In the browser, does it say "account.healthvault.com" or "account.healthvault.co.uk"

    Thanks!

    Saturday, January 18, 2014 10:55 PM
  • Yes, she uses her Microsoft Account, same one for the tablet and Health Vault. When she's online she has no problem accessing Health Vault using her log-in credentials. The online site is the account.healthvault.com domain (US/English).


    She has no problems with email, other apps, or signing into the tablet.

    Thanks!

    Sunday, January 19, 2014 2:13 AM
  • Hi,

    Sorry to have to inconvenience you on this but so far you're the only user to have reported this loop and we are not having any luck reproducing the issue here.  The only next steps we have would be to gather some data from you regarding the errors.

    We do log the error in isolated storage with file name error.txt. It should be located at “C:\Users\<user name>\AppData\Local\Packages\Microsoft.HealthVault_8wekyb3d8bbwe\LocalState\HealthVault\”. The error should also be logged to event viewer.    (Not sure if Windows 8 Surface has access to event viewer)

    If you could check those areas and see that would be great. We'll continue trying to investigate a possible cause, you also mentioned you have a HV account and yours works fine right? Was your mother's MSA account created recently?

    Thanks for your help.

    • Marked as answer by Tomas El Saturday, February 22, 2014 3:02 AM
    Monday, January 20, 2014 10:18 PM
  • I have the same problem. But it just started yesterday. I could access it a couple of days before that. Now, I cannot access my HealthVault data because the app keeps on asking to authorize the access even though I already tapped the "I Accept" button.

    My wife has an account on the same Surface, and she too cannot access the HealthVault app for the same reason.

    We're using a Surface RT 8.1. Our HealthVault accounts are on "account.healthvault.co.uk".

    The HealthVault app works fine on our ASUS All-in-one.

    • Edited by pub.decoy Saturday, January 25, 2014 3:28 AM
    Saturday, January 25, 2014 3:23 AM
  • The HealthVault app on both of my Nokia Lumias required me to sign in again a few hours after my previous post, which was weird because it never required me to that before. But then I thought something must have happened on HealthVault's end which required me to sign-in again. So I got out my Surface, and lo and behold, the HealthVault app worked perfectly again! Even the HealthVault app on my wife's account worked! I haven't had any similar issues since, so I guess the problem has been resolved.
    • Marked as answer by Tomas El Saturday, February 22, 2014 3:01 AM
    • Unmarked as answer by Tomas El Saturday, February 22, 2014 3:02 AM
    Wednesday, January 29, 2014 3:37 AM