locked
Hot issue - Skype Click to Call cause Copy & Paste function behave abnormally RRS feed

  • General discussion

  • Hi all,

    Recently, we noticed many people get affected with Copy & Paste issue after installed an update for Skype.

    Symptom:

    • Cannot copy & paste with correct formatting, the formatting will lose during copy & paste.
    • When check the Paste Special option, the "keep source formatting" option is not available.

    Cause:

    The ClipBoard has been interfered with by the recently released Skype Click to Call (Version 5.10.0.9560).

    Solution:

    Skype has released a new version of Click to Run (http://www.skype.com/intl/en-us/get-skype/on-your-computer/click-to-call/windows/). Skype will do a silent upgrade to existing customers to fix the problem. The build that will fix this issue is 5.11.0.9874.
    Microsoft has also released a KB article that addresses the situation (http://support.microsoft.com/kb/2697462)

    Thanks Hans Vogelaar (MVP) for keep monitoring on this issue!


    Max Meng
    TechNet Community Support

    • Edited by Max Meng Tuesday, April 24, 2012 7:35 AM update link info
    Friday, March 30, 2012 1:16 PM

All replies

  • Hi Max - nice to see that you are being pro-active and bringing this to everybody's attention. We need more of this! A solution included as well!
    Friday, March 30, 2012 1:26 PM
  • That was the problem! Thank-you so much, Max.

    -Pam

    Monday, April 2, 2012 4:05 PM
  • Excellent!

    I tried rebuiding MS Office and that worked for a little while (I now see it worked until I ran Firefox again with Skpe Click to Call.

    This worked very well.

    Thanks

    Tuesday, April 3, 2012 7:56 AM
  • Thank you good sir, this has been driving me silly for about 4 hours, and I been using Spreadsheets since SuperCalc & Lotus.   I uninstalled Skype and everything is beer & skittles..  Great job!!

    Wednesday, April 4, 2012 2:51 AM
  • Thank you so much. I had tried everything...
    Thursday, April 5, 2012 11:30 AM
  • Thanks a lot!  I never would have figured this out on my own!

    Friday, April 6, 2012 1:16 AM
  • Hello,

    Jan here :-)

    I told my colleagues I was uninstalling Skype Click to Call to solve my copy/paste problems and they (Gary and Geoff) scoffed at the idea, well guess what!!

    IT WORKED! copy paste works again both equations and tables (in MS Word). I also ended up removing a small icon on Google chrome (top right) for skype to call! I had trouble uninstalling Skype to Call, as it kept complaining about chrome being open (which it was not). In the end I force deleted skype/toolbar folder from my Program Files!

    Life can be stranger than fiction, who would have guessed. I'd like to know how anyone figured it out, trial and error?

    Jan

    ps: the truth is I am still worried, as this will be the third time I have made it work, and then it reoccurred a short time later...fingers crossed....

    Wednesday, April 11, 2012 3:16 AM
  • Life can be stranger than fiction, who would have guessed. I'd like to know how anyone figured it out, trial and error?


    I think the honours for working this out go to Hans Vogelaar

    Ed Ferrero
    www.edferrero.com

    Wednesday, April 11, 2012 3:52 AM
    Answerer
  • I think the honours for working this out go to Hans Vogelaar


    Thanks for the compliment, but it was a collective effort - it took a while before a clear cause emerged.

    Regards, Hans Vogelaar

    Wednesday, April 11, 2012 5:47 AM
  • Skype has released an updated version of the Click to Call browser add-on that should be free of the problem mentioned above.
    If you want it, go to http://www.skype.com/intl/en-us/get-skype/on-your-computer/click-to-call/windows/ and click Download Now.

    Regards, Hans Vogelaar

    Wednesday, April 11, 2012 7:19 PM
  • If you do not update your addin (That happens in FFox)..

    You can switch to turn off Skype addin


    And everything back to normal.



    Oskar Shon, Office System MVP

    Press if Helpful; Answer when a problem solved

    Friday, April 13, 2012 7:24 PM
  • I just clicked on your link above to get the uodated version of Click to Call but only got version 5.10.0.9560
    Thursday, April 19, 2012 7:18 AM
  • downloaded from link and all good now :)

    THANKYOU!!!

    this was driving me MAD!!!

    Wednesday, April 25, 2012 2:32 PM
  • I had this issue too.  Removed Skype to call and is now resolved.  Isn't the internet brilliant?  I never would have figured this out otherwise.

    Thanks folks.

    :)

    Friday, July 20, 2012 9:11 AM
  • Hello,  I've just found this thread.  I'm using a PC, Windows 7 (64bit), FireFox 22.0, with Skype installed but turned off unless actually in use.  I've been having the 'copy/paste' issue for ~ 3 weeks now after many years of normal function.  Initially presumed it to be a mouse mechanical issue and tried (unsuccessfully) to remedy with LogiTech (wireless mouse & keyboard) - they provided a replacement mouse that failed to correct the issue. 

    I notice that all the prior posts are at least a year or more old.  Does your advice to install the 'new' version of 'Click to Run' still hold?  Should I uninstall 'click to Run' and if so, how do I do that other than by uninstalling Skype?

    Thursday, July 25, 2013 2:28 AM
  • If your Skype hasn't been updated since 2012, Skype Click to Call might cause the problem, otherwise it's unlikely.

    But you can give it a try. You should be able to uninstall Skype Click to Call through the Programs and Features control panel.


    Regards, Hans Vogelaar

    Thursday, July 25, 2013 5:30 AM
  • Hello Hans,

    Thanks for your reply.

    I followed your advice, did an uninstall/reinstall but after a brief trial saw no improvement.  Also tried disabling C2C in my task manager... no joy.  Uninstalled C2C and that seems to have significantly improved the issue. Although relatively frequent copy/paste failure still occur, they seem (empirically) fewer than before.  Another issue I didn't mention is that I'm also having 'run-away scrolling'.  I will, at times, attempt to scroll up or down (using my mouse's scroll wheel) and the screen will suddenly begin scrolling upwards (never down) for a page or two.  I will be able to up or down cursor with the keypad or use the 'slider' on the edge of the screen when that happens.  It lasts a few minutes, then stops until it starts again.

    All that said, any other thoughts?

    Marshalldoc


    • Edited by Marshalldoc Saturday, July 27, 2013 12:15 AM Follow-up
    Saturday, July 27, 2013 12:13 AM
  • Try the trouble-shooting steps in http://www.jkp-ads.com/Articles/StartupProblems.asp

    Regards, Hans Vogelaar

    Saturday, July 27, 2013 8:30 AM