none
PDF files have a login prompt RRS feed

  • Question

  • Let me start by stating this is on a MOSS 2007 single server install.  I have done the necessary steps to index the PDF files as well as add the icon.  PDF documents show up in the search just fine.  The issue is that when users browse to a folder within a document library that contains a pdf file, they will get a login prompt.  They can cancel out of it, but the icon doesn't show.  They can still open the pdf file.

    This only happens for domain users.  The problem disappears when I log in as the site collection admin on the user's pc.  I can't go around doing this for everyone, so I need to fix the issue.  I have narrowed it down to it being a permission issue, but I am at a loss of how to fix it.

    Any advice will be greatly appreciated.  I am new to SharePoint, so please forgive my lack of knowledge on the subject.

    Thanks!

    **I should state that Office files open fine with no login prompt.  I have it setup for Windows authentication type & integrated windows authentication with Kerberos.  Anonymous access is not enabled.  This is an intranet site & outside access is not needed.
    Monday, October 19, 2009 7:47 PM

Answers

  • Have you checked the security permissions on the PDF icon file itself?  Go into "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\Images" and compare security permissions on your PDF icon file (usually "pdficon.gif") versus another similar file such as icpng.gif.
    Andre Galitsky, MCTS, Lexington, KY -- My SharePoint Blog: http://www.sharepointnomad.com
    • Marked as answer by Mike Walsh FIN Tuesday, October 20, 2009 3:21 PM
    Tuesday, October 20, 2009 11:58 AM

All replies

  • Have you checked the security permissions on the PDF icon file itself?  Go into "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\Images" and compare security permissions on your PDF icon file (usually "pdficon.gif") versus another similar file such as icpng.gif.
    Andre Galitsky, MCTS, Lexington, KY -- My SharePoint Blog: http://www.sharepointnomad.com
    • Marked as answer by Mike Walsh FIN Tuesday, October 20, 2009 3:21 PM
    Tuesday, October 20, 2009 11:58 AM
  • That was the issue!!  Thanks for the response.  I didn't think about permissions on an icon, but it is web based.  Thanks again.
    Tuesday, October 20, 2009 3:17 PM