none
Servermanager.xml and Server 2012 R2. RRS feed

  • Question

  • I'm trying use roles and features in our task sequence. I have selected Webserver and a bunch of other IIS components.

    When MDT tries to add the Webserver role it fails with error

    ---------------------------------------

    Property Parameters is now = -FeatureName Web-Server
    Validating connection to \\MDTServer\Deploymentshare$\Operating Systems\Windows Server 2012 R2 SERVERSTANDARDCORE x64
    Mapping server share: \\MDTServer\Deploymentshare$
    Already connected to server MDTServer as that is where this script is running from.
    Copying source files locally from \\MDTServer\Deploymentshare$\Operating Systems\Windows Server 2012 R2 SERVERSTANDARDCORE x64\sources\sxs
    ZTI ERROR - Unhandled error returned by ZTIOSRole: Path not found (76)
    ---------------------------------------

    If I do

    Dism /Online /Get-Features >C:\out.txt

    I don't see any Web-Server. Instead I see IIS-WebServer.

    I looked at Servermanager.xml for Roles ID="11" Core="no" DisplayName="Windows Server 2012 R2" 

    In that segment I've <Role DisplayName='Web Server (IIS)' Id='Web-Server'> but nothing with IIS-WebServer.

    File creation date for Servermanager.xml is 16 july 2013, 17:41:20.

    File creation date for install.wim is 18 september 2013, 16:01:40 (modified 22 ‎august ‎2013, ‏‎19:07:08)

    I'm using MDT 2013 version 6.2.5019.0

    To solve the problem I had to add a run command line in the tasksequence and install the features using dism.

    Am I using the wrong Servermanager.xml or the wrong Windows Server 2012 R2?


    Thursday, March 13, 2014 3:49 PM

Answers

  • It's entirely possible that the name in the servermanager.xml is wrong. Feel free to change the file from "web-server" to "IIS-WebServer" to see if it fixed the problem. If so then please file a bug against MDT on Connect.

    Otherwise, the error above is weird to me, it looks like it's having problem "finding" a folder, either the source or the dest. is this a *full* OS source, or just a captured WIM file?


    Keith Garner - keithga.wordpress.com

    Thursday, March 13, 2014 5:42 PM
    Moderator

All replies

  • It's entirely possible that the name in the servermanager.xml is wrong. Feel free to change the file from "web-server" to "IIS-WebServer" to see if it fixed the problem. If so then please file a bug against MDT on Connect.

    Otherwise, the error above is weird to me, it looks like it's having problem "finding" a folder, either the source or the dest. is this a *full* OS source, or just a captured WIM file?


    Keith Garner - keithga.wordpress.com

    Thursday, March 13, 2014 5:42 PM
    Moderator
  • It's entirely possible that the name in the servermanager.xml is wrong. Feel free to change the file from "web-server" to "IIS-WebServer" to see if it fixed the problem. If so then please file a bug against MDT on Connect.

    Otherwise, the error above is weird to me, it looks like it's having problem "finding" a folder, either the source or the dest. is this a *full* OS source, or just a captured WIM file?


    Keith Garner - keithga.wordpress.com

    hi Keith

    The path above is to the full source imported from an ISO.

    Some day I let you know if this is a bug or human error.

    Friday, March 14, 2014 1:49 PM