locked
Problems Opening Word and Excel Documents with Office 2010 from SharePoint 2007 RRS feed

  • Question

  • I am having difficulty finding a solution that we are currently experiencing in our SharePoint 2007 environment.  The problem we are observing is that users are having problems opening Office files on some (not all) sites in a MOSS 2007 environment with Office 2010.  This is also just limited when connected via our VPN.  When users are connected to the LAN, the system works as designed.  Users can edit, check out, save and check in documents.  This is only on the VPN.  This has also been confirmed to be a problem on multiple systems.

    The other thing to notate is that my identical test/dev environment is not experiencing this same problem.  Office files are interacting with SharePoint as designed.  The dev environment is running the same Windows server, SharePoint server, but has slightly older content DB's tied into it. 

    I am running a MOSS 2007 SP2 farm with Windows Server 2008 R2 Enterprise.

    What I have done so far (and failed to resolve the problem) is updating the registry to enable basic authentication without SSL, made the SharePoint server a trusted site, checked and unchecked "Automatically Detect settings in IE", tested in IE8 and IE9, reset browser to default settings and tested on multiple machines.

    I have been through hundreds of online forums with no resolution.  I am also unable to find a forum where the issue is limited to VPN and the problem only occurs on some sites.  Any assistance in addressing this matter would be greatly appreciated.

    Monday, July 23, 2012 5:53 PM

Answers

  • I was able to resolve this issue by doing the following:

      • Navigate to Start – Run, type “regedit” or type in “regedit” in the search box.
      • Click OK to open the registry editor program.
      • Navigate to the following registry key:  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
      • On the edit menu, select New – DWORD value.
      • Type “UseBasicAuth” (No quotes and case sensitive) and press enter.
      • Right click “UseBasicAuth” and click Modify.
      • In the Value box, enter ‘1’ and click OK.
      • Add a new DWORD Value by clicking Edit – New – DWORD Value.
      • Type “BasicAuthLevel” (No quotes and case sensitive) and press enter.

    10.  Right click “BasicAuthLevel” and click Modify.

    11.  In the Value box, enter ‘2’ and click OK.

    12.  Navigate to the following registry key:  HEKY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet

    13.  On the edit menu, select New – DWORD value.

    14.  Type “BasicAuthLevel” (No quotes and case sensitive) and press enter.

    15.  Right click “BasicAuthLevel” and click Modify.

    16.  In the Value box, enter ‘2’ and click OK.

    17.  Close out of the registry editor program and restart the machine.

    18.  The user should now be able to access the necessary files and work with SharePoint as it is designed on the VPN.  If they are still having problems, reinstall Aventail.

    19.  If this is still an issue, escalate to the OMG interchange (SharePoint) queue.

    The steps 3 through 7 were only supposed to be done on Windows Server 2003 and Windows XP machines, but I did this on a Windows 7 machine and that cleared the problem. 

    • Marked as answer by Mike Karriker Wednesday, September 5, 2012 12:21 PM
    Wednesday, September 5, 2012 12:21 PM

All replies

  • Hi Mike,

    It only occurring on some sites?  Are you using the same URL internally as through the VPN?

    Symptoms KB943280

    Consider the following scenario.

    • On a computer that is running Windows Vista or Windows 7, you do not configure a proxy in Windows Internet Explorer.
    • You use Web Distributed Authoring and Versioning (WebDav) to access a fully qualified domain names (FQDN) site.

    In this scenario, you are prompted to enter your credentials, even though the user account that you are using has sufficient permission to access this site.

    For example, when you open a Microsoft Office file from a Microsoft Office SharePoint site by using 2007 Microsoft Office on a Windows Vista-based client computer that has no proxy configured, you are prompted for authentication.

    You may also see the following error when working with moved folders via explorer view:

    Your client does not support opening this list with Windows Explorer."

    Note This problem does not occur on a Windows XP-based computer.

    Important This hotfix is included in Windows Vista Service Pack 1 or a later service pack. However, you must still configure the AuthForwardServerList registry entry. For more information, see the Registry information section. http://support.microsoft.com/kb/943280

    To configure the AuthForwardServerList registry entry for a single user

     

    1.    ClickStart, type regedit in the Start Search box, and then pressENTER.

    2.    Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

    3.    On theEdit menu, point to New, and then click Multi-String Value.

    4.    TypeAuthForwardServerList, and then press ENTER.

    5.    On theEdit menu, click Modify.

    6.    In theValue data box, type the URL of the server that hosts the Web share, and then clickOK.

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.

    Saturday, July 28, 2012 10:55 PM
  • Ivan,

    Thank you so much for your reply on this.  I tested the solution listed on the KB article and it failed to work. 

    To answer your question, I am using the same URL when connecting through our VPN and this problem is only occuring on some sites.    I should also notate that I have had our networking team look into this and they are not saying it is not an issue on their side.  We also have a test VPN solution that I can connect to and testing on that VPN connection to our production SharePoint site, the system works as designed on all sites. 

    Since it is not a VPN issue (per our networking team), it appears to be site specific.  I have found no differences in Central Admin or site settings on my test or production environment.

    Let me also add, if I uncheck "Automatically Detect Settings" from IE -> Internet Options -> Connections -> LAN Settings, I can open the document locally on the system.  However, if I check this option, I cannot open the document at all.

    • Edited by Mike Karriker Monday, July 30, 2012 2:08 PM
    • Marked as answer by Mike Karriker Wednesday, September 5, 2012 12:18 PM
    • Unmarked as answer by Mike Karriker Wednesday, September 5, 2012 12:18 PM
    Monday, July 30, 2012 1:52 PM
  • I was able to resolve this issue by doing the following:

      • Navigate to Start – Run, type “regedit” or type in “regedit” in the search box.
      • Click OK to open the registry editor program.
      • Navigate to the following registry key:  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
      • On the edit menu, select New – DWORD value.
      • Type “UseBasicAuth” (No quotes and case sensitive) and press enter.
      • Right click “UseBasicAuth” and click Modify.
      • In the Value box, enter ‘1’ and click OK.
      • Add a new DWORD Value by clicking Edit – New – DWORD Value.
      • Type “BasicAuthLevel” (No quotes and case sensitive) and press enter.

    10.  Right click “BasicAuthLevel” and click Modify.

    11.  In the Value box, enter ‘2’ and click OK.

    12.  Navigate to the following registry key:  HEKY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet

    13.  On the edit menu, select New – DWORD value.

    14.  Type “BasicAuthLevel” (No quotes and case sensitive) and press enter.

    15.  Right click “BasicAuthLevel” and click Modify.

    16.  In the Value box, enter ‘2’ and click OK.

    17.  Close out of the registry editor program and restart the machine.

    18.  The user should now be able to access the necessary files and work with SharePoint as it is designed on the VPN.  If they are still having problems, reinstall Aventail.

    19.  If this is still an issue, escalate to the OMG interchange (SharePoint) queue.

    The steps 3 through 7 were only supposed to be done on Windows Server 2003 and Windows XP machines, but I did this on a Windows 7 machine and that cleared the problem. 

    • Marked as answer by Mike Karriker Wednesday, September 5, 2012 12:21 PM
    Wednesday, September 5, 2012 12:21 PM