none
UAG and IE Kiosk Mode RRS feed

  • Question

  • We have a few internal machines (in branch offices) that we have turned into Kiosks - these were used for our old Citrix deployment.

    We are wanting to keep the same functionality (Access to UAG only, no user interaction with the local resources).

    In our test environment, we can get our portal to launch, and we can access all Browser-Embedded Apps, but any remote apps refuse to open.

    The exact behavior is:

    Click on Remote App

    Pass through Credentials

    Logon to RD Farm (Can see the logon process complete in the "Details" section of the Remote App window)

    Logoff from RD Farm (Can see the logoff process initiate and complete in the "Details" section of the Remote App window).

     

    Same machine and user, without Kiosk mode, UAG works like a charm - Remote Apps, Browser Embedded, SharePoint, OWA.

    Any ideas?


    • Edited by JC DelP Thursday, October 27, 2011 8:59 PM
    Monday, October 17, 2011 4:22 PM

All replies

  • I believe that Single Sign-On (SSO) for RemoteApps does not work when UAG component installation and activation is disabled... 


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Tuesday, October 18, 2011 9:02 AM
    Moderator
  • Understood - The test Kiosk machine already has the components installed (and will allow them to be upgraded/re-installed if needed).

    Component Activation and installation has not been disabled on the portal.

     

    We are able to login to Remote Desktop session, and then launch the rd farm apps; it's only when launching the apps directly from the portal that this failure occurs.

     


    JC
    Tuesday, October 18, 2011 2:10 PM
  • Can you confirm you definition of Kiosk mode? Do you mean IE kiosk mode?

    If so, I am guessing the ActiveX controls used by RemoteApps are not available are not availble in kiosk mode...

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Tuesday, October 18, 2011 2:37 PM
    Moderator
  • Apologies - yes, IE8, IE9 Kiosk mode (-K) set using GPO.

    We are investigating the ActiveX bit.


    JC
    Tuesday, October 18, 2011 2:50 PM
  • Unfortunately, even running with all ActiveX controls enabled (trusted site, 0 security) we are still experiencing the same problem. This is directly related to changing the interface to IE Kiosk Mode, rather than the standard windows interface.

    Running (ran) out of ideas - any other takers?

    Thanks

     

    JC


    JC
    Thursday, October 27, 2011 3:51 PM
  • As a work around, we have used Group Policy to launch IE, Force Fullscreen mode, and then removed access to everything else on the Kiosk machine; a bit more detailed than just changing the interface and using -K, but a viable workaround.
    JC
    Thursday, October 27, 2011 7:02 PM