locked
User cannot access RDWEB page when URL has FQDN RRS feed

  • Question

  • We have a Windows 2008 R2 server running remote desktop services.  This is for internal use only on a single domain and I always set up users IE shortcuts using the fqdn of the server.  Users can access the page using a url with only the server name but will receive a certificate invalid message.

    Up until last Thursday RDWEB has worked flawlessly.  Now I have one user who can access the RDWEB page using her fqdn link BUT when she enters her credentials the page just flashes and stays on the logon page.  If she access the same page using only the server name and clicks through the invalid certificate message she can log on normally and access the Remote App programs as usual.

    No one else in the office has this same problem (yet?).

    The server certificate is valid, she is using IE 11.

    What could cause this?

    Monday, July 27, 2015 3:32 PM

Answers

  • Hmm, that is odd. I remember seeing TechNet threads regarding IE 11 compatibility issues with the 2008 R2 RDWeb portal (basically glitchy icons, warnings about the browser being too old, etc.) but I don't believe those are necessarily applicable to your current situation. If you want to look at the links anyway, here you go:

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/5bd8cca3-f842-4cb3-99f6-56974a0bc39b/rdweb-ie11-browser-not-supported?forum=winserverTS

    https://social.technet.microsoft.com/forums/windowsserver/en-US/39dbd0f3-c1f5-4d83-8a57-6fc36cc5c8c6/remoteapp-icons-windows-2008-r2-missing-via-rdweb-when-using-ie10

    Now, what's interesting to me is your user can access the portal and use her RemoteApps normally if she browses to the server name instead of the FQDN. I'm guessing there are no error messages displayed. 

    • Are there any other users in your environment using IE 11?
    • Do you encounter the same behavior if you login to the portal with another set of credentials on her machine?
    • Do you have any Compatibility view settings applied in the browser settings or via Group Policy?
    • Have you tried using F12 to render the portal page in another mode (Hit F12, go to the Emulation tab, set Document Mode to 9, and then have her try logging in) to see if it works successfully? 
    • Is there a proxy server configured in Internet Options that might be bypassed (or not bypassed) when going directly to the local server name?

    You may have already tried some if not all of these things, but hopefully someone else can chime in and offer some additional suggestions.

    • Proposed as answer by Amy Wang_ Thursday, August 6, 2015 9:40 AM
    • Marked as answer by Amy Wang_ Monday, August 10, 2015 2:23 AM
    Tuesday, July 28, 2015 2:18 AM