none
Exchange 2013 Changing Banner on default receive connector stops TELNET & Mail flow

    Question

  • Hi to all

     

    I am trying to change FQDN on default receive connector

     

    First I used

     

    https://technet.microsoft.com/en-us/library/bb124740(v=exchg.150).aspx

     

    Set-ReceiveConnector "Default Frontend ServerName" -Banner "220 mail.domainname.co.uk"

     

    telnet mail.RecipientDomain.co.uk 25

     

    220 mail.RecipientDomain.co.uk

     

    EHLO SerderDomain.com

     

    250-ExchangeServer2013.RecipientDomain.NET Hello [External IP of RecipientDomain MX record]

    250-SIZE 104857600

    250-DSN

    250-ENHANCEDSTATUSCODES

    250-STARTTLS

    250-AUTH NTLM

    250-X-EXPS GSSAPI NTLM

    250 8BITMIME

     

    MAIL FROM: User.Name@SerderDomain.com

     

    250 2.1.0 Sender OK

     

    RCPT TO: Recipient.User@RecipientDomain.co.uk

     

    250 2.1.5 Recipient OK

     

    DATA

     

    552 Your email has been blocked: Either sender's domain or email address is in the blacklist

     

    Connection to host lost.

     

    What I have observed when I checked properties/Security of "Default Frontend ServerName " Exchange Server authentication was still checked

     

    Although mail flow was not affected I used to remove custom banner with following as stated in document.

     

    Set-ReceiveConnector "Default Frontend ServerName " -Banner $null

     

    I tried same thing with EMC as per document http://www.oxfordsbsguy.com/2016/02/20/exchange-2013-initial-configuration-settings-how-to-change-the-fqdn-on-the-default-frontend-receive-connector-part-9/

     

    External to internal email flow stopped with the same error “552 Your email has been blocked: Either sender's domain or email address is in the blacklist”

     

    I have put everything back to how it was now we have mail flow.

     

    I would very much appreciate for your help why I am getting these errors in different configurations/

     

    Many thanks in advance.

     

    Regards.


    VITP

    Monday, September 12, 2016 12:52 PM

Answers

  • Hi VITP,

    Could you resolve the record of "mail.domainname.co.uk" in internet?

    Please do not forget to also create/use certificate with Subject Name (or Subject Alternative Name) mail.doaminname.co.uk

    Moreover, the article which you had referred also mentioned, nowadays most email systems we setup go through a third party anit-spam gateway service, so remote mail servers never directly speak to our mail server. They will send mail to the anti-spam gateway which will then forward it to our Exchange server, and likewise when Exchange sends an email it is sent to the anti-spam gateway, before going on to the receiving mail server. So we actually need not to change it.

    Best regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 16, 2016 3:02 AM
    Moderator
  • Hi to All

    Sorry for late response.

    Here is the latest situation:

    https://technet.microsoft.com/en-us/library/bb124740(v=exchg.150).aspx

     

    Set-ReceiveConnector "Default Frontend ServerName" -Banner "220 mail.domainname.co.uk"

    Definitely achieved what I want to have.

    I restarted all exchange services but Telnet problem disappeared when I restarted server

    Many thanks for all the guidance.


    VITP

    Friday, September 23, 2016 3:26 PM

All replies

  • Hi

    Can you turn on verbose logging and then set your banner and have a look at the logs if you see anything?


    Microsoft PFE

    Tuesday, September 13, 2016 4:53 AM
    Moderator
  • Hi Edward

    Many thanks for your response.

    How do I turnon on verbose logging & how long should I left. Because as soon as change FQDN mail flow stops.

    Which method I should try regardless  as soon as change FQDN mail flow stops.

    Many thanks in advance,

    Regards.


    VITP

    Tuesday, September 13, 2016 6:46 AM
  • Hi VITP,

    By default, protocol logging is disabled on all Send connectors and Receive connectors, you can use the following command to turn on the protocol logging on a receive connector:

    Set-ReceiveConnector "Default Frontend ServerName " -ProtocolLoggingLevel Verbose

    And then set the banner, when using telnet to send an email failed, check if there is any log in the following path:

    %ExchangeInstallPath%TransportRoles\Logs\FrontEnd\ProtocolLog\SmtpReceive

    More details about protocol logging see: Protocol logging ; Configure protocol logging

    Best regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 13, 2016 9:41 AM
    Moderator
  • Hi Niko

    I assume I need to use [Set-ReceiveConnector "Default Frontend ServerName" -Banner "220 mail.domainname.co.uk"]

    Is that correct EMC configuration disables incoming emails

    Many thanks


    VITP

    Tuesday, September 13, 2016 9:45 AM
  • Hi

    I just checked Verbose protocol logging was enabled, there are many logs I will sift through and get back to you

    regards,


    VITP

    Tuesday, September 13, 2016 10:10 AM
  • Hi

    I have many of them but what am I looking in them they are almost identical.

    Please note; ServerName=MailServer & mail.DomainName.co.uk=MX

    #Software: Microsoft Exchange Server
    #Version: 15.0.0.0
    #Log-type: SMTP Receive Protocol Log
    #Date: 2016-09-11T00:00:39.821Z
    #Fields: date-time,connector-id,session-id,sequence-number,local-endpoint,remote-endpoint,event,data,context
    2016-09-11T00:00:37.336Z,ServerName\Default Frontend ServerName,08D3D93BBD801748,0,127.0.0.1:25,127.0.0.1:61527,+,,
    2016-09-11T00:00:37.336Z,ServerName\Default Frontend ServerName,08D3D93BBD801748,1,127.0.0.1:25,127.0.0.1:61527,*,SMTPSubmit SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender AcceptRoutingHeaders,Set Session Permissions
    2016-09-11T00:00:37.336Z,ServerName\Default Frontend ServerName,08D3D93BBD801748,2,127.0.0.1:25,127.0.0.1:61527,>,220 mail.DomainName.co.uk,
    2016-09-11T00:00:37.336Z,ServerName\Default Frontend ServerName,08D3D93BBD801748,3,127.0.0.1:25,127.0.0.1:61527,<,EHLO,
    2016-09-11T00:00:37.336Z,ServerName\Default Frontend ServerName,08D3D93BBD801748,4,127.0.0.1:25,127.0.0.1:61527,*,SMTPSubmit SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender AcceptRoutingHeaders,Set Session Permissions
    2016-09-11T00:00:37.336Z,ServerName\Default Frontend ServerName,08D3D93BBD801748,5,127.0.0.1:25,127.0.0.1:61527,>,250-mail.DomainName.co.uk Hello [127.0.0.1],

    Many thanks in advance


    VITP

    Tuesday, September 13, 2016 10:28 AM
  • "I am trying to change FQDN on default receive connector "

    Why? Don't mess with those. If you need to create a receive connector for messages from the internet, create a new one and set the FQDN there. Ensure you have a cert that has a subject name that matches that installed and enabled for SMTP on the server as well.


    Blog:    Twitter:   

    Tuesday, September 13, 2016 12:03 PM
  • Hi Andy

    I followed a document to do so but it did give me error even dough I disabled existing. 

    I have feeling it will not make any difference. Please note we have one Exchange server holds all roles. In reality I was trying to hide internal Server names and IP addresses. Perhaps I need to use PS Instead of GUI as described here http://www.oxfordsbsguy.com/2016/02/20/exchange-2013-initial-configuration-settings-how-to-change-the-fqdn-on-the-default-frontend-receive-connector-part-9/

    Set-ReceiveConnector -identity “ServerName\Default Frontend ConnectorName” -AuthMechanism Tls, Integrated, BasicAuth, BasicAuthRequireTLS

    Set-ReceiveConnector -identity “ServerName\Default Frontend ConnectorName” -Fqdn mail.DomainName.com

    But I am very naïve PS I don't know how to revert back if it goes pear shape

    Thanks for your input


    VITP

    Tuesday, September 13, 2016 12:23 PM
  • Hi Andy

    I followed a document to do so but it did give me error even dough I disabled existing. 

    I have feeling it will not make any difference. Please note we have one Exchange server holds all roles. In reality I was trying to hide internal Server names and IP addresses. Perhaps I need to use PS Instead of GUI as described here http://www.oxfordsbsguy.com/2016/02/20/exchange-2013-initial-configuration-settings-how-to-change-the-fqdn-on-the-default-frontend-receive-connector-part-9/

    Set-ReceiveConnector -identity “ServerName\Default Frontend ConnectorName” -AuthMechanism Tls, Integrated, BasicAuth, BasicAuthRequireTLS

    Set-ReceiveConnector -identity “ServerName\Default Frontend ConnectorName” -Fqdn mail.DomainName.com

    But I am very naïve PS I don't know how to revert back if it goes pear shape

    Thanks for your input


    VITP

    I wouldn't bother trying to hide those. Its really not a security issue.


    Blog:    Twitter:   

    Tuesday, September 13, 2016 1:12 PM
  • If we email to> AnyUser@btinternet.com

    We get NDR

    rgin12.bt.ext.cpcloud.co.uk gave this error:
    Your email has been blocked: Either sender's domain or email address is in the blacklist.

    Somehow cpcloud.co.uk add us to their blocked list. In real world none of the RBL has our ip or domain name. This is so severe if it touches to cpcloud regardless recipients domain it gets NDR.

    We enquired with BT their response is; the problem that the hub is not configured to NAT the internal ip addresses to the external ip address.

    Where I have configured Send connector FQDN with mail.DomainName.co.uk

    That is the reson I started this journey, I want to be able to say them we have done everything you asked problem is in your end

    Further thoughts?

    VITP

    Tuesday, September 13, 2016 1:57 PM
  • Hi VITP,

    Could you resolve the record of "mail.domainname.co.uk" in internet?

    Please do not forget to also create/use certificate with Subject Name (or Subject Alternative Name) mail.doaminname.co.uk

    Moreover, the article which you had referred also mentioned, nowadays most email systems we setup go through a third party anit-spam gateway service, so remote mail servers never directly speak to our mail server. They will send mail to the anti-spam gateway which will then forward it to our Exchange server, and likewise when Exchange sends an email it is sent to the anti-spam gateway, before going on to the receiving mail server. So we actually need not to change it.

    Best regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 16, 2016 3:02 AM
    Moderator
  • Hi to All

    Sorry for late response.

    Here is the latest situation:

    https://technet.microsoft.com/en-us/library/bb124740(v=exchg.150).aspx

     

    Set-ReceiveConnector "Default Frontend ServerName" -Banner "220 mail.domainname.co.uk"

    Definitely achieved what I want to have.

    I restarted all exchange services but Telnet problem disappeared when I restarted server

    Many thanks for all the guidance.


    VITP

    Friday, September 23, 2016 3:26 PM