none
NT kernel &System using port 80 unable to stop the process.

    Question

  • I just installed windows 10 and XAMPP on my new laptop. XAMPP is not working because another program is listening on Port 80. After further investigation, I found that System with PID 4 (described as NT kernel & system) is listening on that port. I have tried every ways I know to kill or stop the process  all to no avail. I get error message that access is denied when I tried taskkill from command line. I will appreciate any help I can get.

    Thanks

    Wednesday, August 05, 2015 6:56 PM

All replies

  • Hi feo11,

    sorry for the inconvenience. please follow these steps:

    1. run this command through cmd prompt in elevated mode.

    netstat -nab

    you will see the log. sample looks like this.

    C:\Windows\system32>netstat -nab

    Active Connections

      Proto  Local Address          Foreign Address        State
      TCP    0.0.0.0:80             0.0.0.0:0              LISTENING
     [Skype.exe]
      TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
      RpcSs
     [svchost.exe]
      TCP    0.0.0.0:443            0.0.0.0:0              LISTENING
     [Skype.exe]

    This means that Skype is running in your machine, then change the skype options as below:In skype:
    Go to Tools -> Options -> Advanced -> Connections and uncheck the box "use port 80 and 443 as alternative".

    (OR)

    If you are not using skype still problem exists

    *change the port for either default IIS websites or for the XAMPP port which are referring to port *80.

    you can refer to these url's

    for IIS- http://www.codeproject.com/Articles/708718/How-to-change-default-port-of-IIS-Manager-from

    for XAMPP- http://www.complete-concrete-concise.com/web-tools/how-to-change-the-apache-port-in-xampp

    let us know if you are still facing the problem, we are glad to help you.

    Thanks,

    Ravindra Aditya

    Sunday, August 09, 2015 4:08 AM
  • This is not working for me my netstat -nab is reporting slightly different results - it was unable to enumerate the user

     TCP    [::]:80                [::]:0                 LISTENING
    Can not obtain ownership information
     TCP    [::]:135               [::]:0                 LISTENING
     RpcSs
    [svchost.exe]
     TCP    [::]:445               [::]:0                 LISTENING
    Can not obtain ownership information

    Thanks in advance

    Mat

    Wednesday, March 29, 2017 10:00 PM
    • Proposed as answer by George Herson Wednesday, September 20, 2017 6:31 PM
    Wednesday, September 20, 2017 6:30 PM
  • this will not work if you are planing on also using IIS on different ports (:81 for instance.)
    Saturday, September 01, 2018 11:40 PM