locked
Publish Sharepoint with UAG to Internet and Intranet with Similar Url RRS feed

  • Question

  • I am trying to Publish Sharepoint with UAG to Internet and the desired url is https://abc.contoso.com and the internal people want to access with http://abc.contoso.com.

    I have my AAM in Sharepoint similar to this, which i read from Sharepoint UAG msdn documentation. The Internet people access the site using https to reach UAG which inturn request http to Sharepoint server.

    image

    with the above AAM setup, the internal people will not be able to access the site using http://abc.contoso.com as there is no AAM mapping for it. i am not able to add AAM mapping as it says internal URL already in the collection.

    Can you please help how to make this setup , thanks Joe

     

     

    Friday, September 10, 2010 1:39 PM

Answers

All replies

  • My understanding would be to amend the default to use http://abc.contoso.com if this is what all internal users will use and then add https://abc.contoso.com to the Extranet or Internet zones.

    You may be better asking in the SharePoint forums for info on correct AAM setup...

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Friday, September 10, 2010 2:11 PM
  • hi,

    why don't your internal user connect the site via http://f3-moss2007?? when trying to resolve moss.f3contoso.com they reach the uag which portal only allows https?

    is split-dns an option?


    gruss, jens mander aka karsten hentrup - www.aixperts.de - www.forefront-tmg.de - www.hentrup.net |<-|
    Friday, September 10, 2010 2:13 PM
  • I am afraid it is not possible i tried this before and if i do this change, it will remove the 3rd AAM in the diagram and have only 2 AAM with default internal and Public url as http://abc.contoso.com and this screws up UAG which needs the 3rd AAM entry to resolve https with Http response .
    Friday, September 10, 2010 2:51 PM
  • http://fe-moss2007 is not resolvable outside the Sharepoint Box and the requirement is to use same url with a difference of http(internal)  and https(external)
    Friday, September 10, 2010 2:52 PM
  • Hi,

    How is the SharePoint server defned in the web servers tab?

    The AAMs I suggested should work if you get the UAG application configured correctly; try using the abc.contoso.com name in the web servers tab (under the addresses section). Don't forget that sharepoint will be expecting the correct host headers to be used.

    I am assuming here this is not a sharepoint farm?

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Friday, September 10, 2010 11:29 PM
  • I had a call with MSFT UAG Expert and he said it is not possible to have same https://abc.contoso.com for Internet users and http://abc.contoso.com. for the internal people with UAG and so i have gone for https://abc.contoso.com for Internet users and http://abc.contoso.corp  for the internal people. Thanks Joe
    Monday, September 13, 2010 12:30 PM
  • Well, that is interesting seeing as though I am using that exact configuration in our production environment, but what do I know ;)
    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Monday, September 13, 2010 2:49 PM
  • Same here, we did run into some funky issues with some of the Check-In/Check-Out functionality, but we sorted that using a dummy AAM of abc.uag.contoso.com and configuring the UAG Application to forward that same URL as the host header.
    Monday, September 13, 2010 3:56 PM