locked
SQL Server Does Not Start At Boot Time on Windows 10 RRS feed

  • Question

  • Hi,

    I recently upgraded from Windows 7 pro to Windows 10. As a developer I also run MS SQL Server 2012 Developer edition. The database engine service is configured to start automatically at boot time. It used to Windows 7, but no longer on Windows 10. I can start the database engine service manually, but it won't start automatically after machine is rebooted.

    Does anybody know is this a compatibility issue? Any workarounds?

    Thanks in advance.

    Peter


    PMBT

    Tuesday, November 10, 2015 1:54 PM

Answers

  • Hi,

    I talked with colleagues in SQL team, and they didn't recive any similar compatibility report recently.

    Regarding to compatibility of SQL server and Windows 10, we’d suggest There you can get more effective suggestion by other experts who familiar with SQL. Your understanding is highly appreciated.

    https://social.technet.microsoft.com/Forums/en-US/home?category=sqlserver

    In the other hand, if you run msconfig, you can setup the proper services that you need on startup. You should check and make sure that they are enabled there. The system corruption might also cause similar issues.

    As a workaround, if there is no problem with the service itself, we can use net start command and logon script to get same goal. It can start the service automatically after system logon.

    Use Startup, Shutdown, Logon, and Logoff Scripts

    https://technet.microsoft.com/en-us/library/cc753404.aspx

    Start, Stop, Pause, Resume, Restart the Database Engine, SQL Server Agent, or SQL Server Browser Service

    https://msdn.microsoft.com/en-us/library/hh403394.aspx#CommandPrompt

      

    Regards,

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by Zen the Ocelot Thursday, December 3, 2015 9:56 PM
    Wednesday, November 11, 2015 2:54 AM