locked
Windows 7 VM Display too large with connection with Remote Desktop Connection RRS feed

  • Question

  • I have a VMWare computer with Windows 7, 64 bit installed.  When I use Remote Desktop to connect to it, the display is too large, and I am unable to make it smaller.  Any ideas on how to do this?

    Thursday, December 15, 2011 7:52 PM

Answers

  • The problem is that you're getting "Medium" icons.

    You wrote:

    Yes, the problem is the icons are too big, and they are already set to smaller. Any other ideas?

    I don't mean to belabor this, but you used the word "smaller" instead of "Small Icons"...

    Just to be absolutely clear, if you right-click on the desktop, choose View, then Small Icons, you're saying it doesn't change?

    -Noel

    • Marked as answer by Cloud_TS Thursday, December 22, 2011 8:23 AM
    Tuesday, December 20, 2011 4:50 PM

All replies

  • Is the Remote Destop client window full-screen?  If so, hover the mouse near the top-center and when the drop-down bar opens, click the icon to "restore" the session into a window.

    If you DO have it displaying in a window, and the window is just too large, keep in mind you set the size of an RDP window using settings in the RDP client application before establishing the session.  For example, click the Options button:

     

    Then choose the Display tab, and you can set the size window you want:

     

    If you want to set up an RDP session that always opens the same way, rather than with whatever parameters the remote desktop client application was last used with, there are buttons near the bottom of the General tab that allow you to save a .rdp file that you can double click to start a unique session.

    Hope this helps!  :)

    -Noel

    Thursday, December 15, 2011 9:19 PM
  • It is not set to full screen, and I tried saving the rdp session, and changing the settings through the RDP connection, but it has no effect, the icons on the Windows 7 desktop are still large.

    Friday, December 16, 2011 2:17 PM
  • You did not initially say it was the icon size that is bothering you.

    Specifically, can you not change the icon size by right-clicking on the desktop, choosing View, and selecting a different icon size?  My guess is that it is already telling you that you have Small Icons selected, right?

     

    What setting is active if you right-click on the desktop, choose Personalize, the click the Display link over on the left?  150%?

    It will not let you change that setting via RDP, but you CAN change it for future RDP sessions through the console as follows:

    • Log in to the VM locally on the VM console window.
    • Right-click the desktop, choose Personalize, then click the Display link.
    • Change to the ( ) Smaller - 100% (default) setting.
    • Log off to ensure the settings are saved in your registry.

    Now it will be set to the smaller size the next time you connect via RDP.

    -Noel


    • Edited by Noel Carboni Saturday, December 17, 2011 7:12 PM corrected typo
    Saturday, December 17, 2011 5:13 PM
  • Yes, the problem is the icons are too big, and they are already set to smaller.  Any other ideas?
    Monday, December 19, 2011 2:46 PM
  • Did you see the second section of what I wrote above?  The part about Personalize - Display, 100% / 125% / 150%?

    -Noel

    Monday, December 19, 2011 4:47 PM
  • The display is set to smaller (100%)
    Monday, December 19, 2011 5:32 PM
  • Could you please capture what you see on the screen and post the image here?  Perhaps upon seeing it someone will be able to make more suggestions.

    -Noel

    Monday, December 19, 2011 6:42 PM
  • Tuesday, December 20, 2011 4:05 PM
  • The problem is that you're getting "Medium" icons.

    You wrote:

    Yes, the problem is the icons are too big, and they are already set to smaller. Any other ideas?

    I don't mean to belabor this, but you used the word "smaller" instead of "Small Icons"...

    Just to be absolutely clear, if you right-click on the desktop, choose View, then Small Icons, you're saying it doesn't change?

    -Noel

    • Marked as answer by Cloud_TS Thursday, December 22, 2011 8:23 AM
    Tuesday, December 20, 2011 4:50 PM
  • That is correct.  Small Icons is selected, but they are still too large.
    Thursday, December 22, 2011 6:03 PM
  • We've eliminated the obvious causes, I think.  I take it your local desktop is also set to 100% (Smaller) and View - Small icons as well.

    Just so you know, I've been trying all these settings with a VM of my own.  In every case the settings have taken effect as expected, and the icons are not too large.

    A kind of "drop back and punt" strategy might be to create an entirely new user account on the VM and see if the icons come out the correct (small) size for you with that.

    I'm sorry but I have no further ideas beyond the above.

    -Noel

    Thursday, December 22, 2011 6:23 PM
  • I am actually connecting from a Windows XP computer with two monitors, and the icon size is set to normal.  This is how I want to connect to it, however, because I am setting up a Windows 7 virtual to test applications that we are currently using on Windows XP, and our users have the same setup as me - Windows XP with two monitors.

    And I did create a new profile no the Windows 7 virtual, but the icons are still large.

    • Edited by CindyKF Tuesday, December 27, 2011 4:55 PM
    Tuesday, December 27, 2011 4:55 PM