none
Software Center crashing after updating Configuration Manager to 1802 RRS feed

  • Question

  • I recently upgraded our Primary site to Configuration Manager 1802, client 5.00.8634.1010.  All seem to be working fine but i realize that if i have a software built as a Package in Software center it Crash the SCClient when i select install after a few seconds, but, if i reopen the Software Center it say it is downloading and it finish the installation, so it worked but it just crashed the Software Center.   This doesn't seem to be happening if the software its built by Applications (instead of Packages).  What can it be?  I'm still holding to upgrade the client to my environment to next month. Let me know if there is any log that can help this, since the software package installation worked.

    Worth to mention, that i tried at lest 3 computers, windows 10 and windows 7 included.







    Tuesday, May 29, 2018 5:35 PM

All replies

  • Hi Miguel,

    I saw a similar issue:

    https://social.technet.microsoft.com/Forums/en-US/1ed98e5f-80b9-4700-985e-f7e6e1e173d1/scclient-crashing-on-load?forum=configmanagerdeployment

    And a related blog:

    https://blog.endpointfocus.com/configmgr-software-center-crashing-with-scclient-has-stopped-working-on-windows-10/

    Hope it helps.

    Best regards

    Yuxiang


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by Yuxiang Shi Wednesday, May 30, 2018 5:25 AM
    Wednesday, May 30, 2018 3:09 AM
  • Thanks Yuxiang for the reply, for what i can read in the related Posts, the first one is crashing just in one computer model, im using 3 different ones and its crashing in all of them even if its windows 7.  In the second post seems to be crashing just by opening the Software center, mine is just doing it when i Install Software built in Package method, Application is not making the bug.

    So, this is what im getting from the Event viewer.  Worth to mention, that the Netframework version they have, is the one that the SCCM client installs, which i believe is the 4.5.2

    Application: SCClient.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.NullReferenceException
       at Microsoft.SoftwareCenter.Client.ViewModels.ApplicationDetailsViewModel+<WmiDataConnection_WmiNotificationEvent>d__132.MoveNext()
       at System.Runtime.CompilerServices.AsyncMethodBuilderCore+<>c.<ThrowAsync>b__6_1(System.Object)
       at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(System.Object)
       at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
       at System.Threading.ThreadPoolWorkQueue.Dispatch()
       at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

    -----------

    Faulting application name: SCClient.exe, version: 5.1802.1022.1000, time stamp: 0x5a922ac6
    Faulting module name: KERNELBASE.dll, version: 10.0.15063.1029, time stamp: 0x99b50546
    Exception code: 0xe0434352
    Fault offset: 0x000f0132
    Faulting process id: 0x3cb8
    Faulting application start time: 0x01d3f82295473d63
    Faulting application path: C:\WINDOWS\CCM\ClientUX\SCClient.exe
    Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
    Report Id: 494cc71e-60d5-478b-a76e-98cd8d2d590a
    Faulting package full name:


    Wednesday, May 30, 2018 3:37 PM
  • Any other idea guys? Im still on the same place here. I even tried it over new fresh deployed computer with Windows 1803, software center and nothing else installed. Same behavior

    Thursday, June 7, 2018 5:38 PM
  • Today all the Applications and packages were not available in the Software center, i restarted the primary site in order to fix it.

    The Application Catalog Web Service Point was showing this error,  could it be related to my situation too?

    Application Web Service Control Manager detected AWEBSVC is not responding to HTTP requests.  The http status code and text is 500, Internal Server Error.

    Possible cause: Internet Information Services (IIS) isn't configured to listen on the ports over which AWEBSVC is configured to communicate.
    Solution: Verify that the designated Web Site is configured to use the same ports which AWEBSVC is configured to use.

    Possible cause: The designated Web Site is disabled in IIS.
    Solution: Verify that the designated Web Site is enabled, and functioning properly.

    For more information, refer to Microsoft Knowledge Base.

    Friday, June 8, 2018 3:13 PM
  • We have Software Center 5.1802.1022.1000.  Software deployed as a package/program, Available, to a user-based collection.  New Software Center user interface which shows the program listed in the Application page - no need for Application Catalog.  The program shows up, not with a package icon (grey with sort of horizontal parallel arrows), but as if it was an application that has not been given an icon (rectangle with a blue pic with tiny lines beside). 

    If I run one of those, Software Center crashes (Windows 7 so KERNEL is v6 not v10) but essentially the same error.  I can re-open Software Center straight away to follow installer progress and it works normally.

    I have a package uninstaller (these are big applications, cannot use ccmcache so cannot use application model); the uninstaller also crashes Software Center if I run it.

    Now here's the interesting thing:  After running each of those 'Available' user-targeted package/programs, each of their icons changes from application-style (with the small blue rectangle pic) to the proper package icon (grey with horizontal arrows).  And if I run them again (installer first, then uninstaller), this time neither causes Software Center to crash.

    I'd say this is a bug for the Configuration Manager guys.  I'll see if there's anything in uservoice and post back if I see (or create) something.

    Tuesday, July 3, 2018 5:53 AM